Project

General

Profile

Feature #10284

Bug #7161: Support more than 24 HTTP mirrors

Design how the IA+DAVE will support the new mirror pool system

Added by u over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
09/26/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Research
Starter:
Affected tool:
ISO Verification Extension

Description

  • Rewriting download URL to point to a random mirror.
  • We'll be modifying the download page with JS. If the ISO verification extension plans to do the same, we need to check if these modifications are compatible.

Related issues

Blocks Tails - Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration Resolved 01/09/2015 04/15/2016

Associated revisions

Revision 83de9d1f (diff)
Added by intrigeri about 2 years ago

Tentatively redesign new mirrors pool handling to match the fact that downloads are supposedly primarily handled via DAVE nowadays.

Refs: #10284

Revision dfcaf5e0 (diff)
Added by intrigeri about 2 years ago

Mirror pool: list more affected download links.

refs: #10284

History

#1 Updated by u over 2 years ago

  • Parent task set to #7161

#2 Updated by intrigeri over 2 years ago

  • Assignee changed from sajolida to u
  • QA Check deleted (Info Needed)
  • Type of work changed from Discuss to Research

Look for "ISO description file" in wiki/src/blueprint/bootstrapping/extension.mdwn.

#3 Updated by intrigeri over 2 years ago

  • Category set to Infrastructure
  • Status changed from New to Confirmed
  • Target version set to Tails_1.7

#5 Updated by intrigeri over 2 years ago

  • Subject changed from Find out where the installation assistant will retrieve the download URL from to Design how the ISO verification extension will support the new mirror pool system
  • Status changed from Confirmed to In Progress
  • Assignee changed from u to intrigeri
  • % Done changed from 0 to 10
  • Blueprint set to https://tails.boum.org/blueprint/HTTP_mirror_pool/
  • Affected tool changed from Installation Assistant to ISO Verification Extension

u wrote:

related to https://labs.riseup.net/code/issues/7161 we were wondering where the installation assistant will retrieve the download URL from?

I had a look and it seems that it's rather about the ISO verification extension: the assistant itself shouldn't be affected. Retitling accordingly.

Eventually, it could use the same JSON file?

The JSON file we have in mind for storing the mirror pool database lacks most data that the ISO verification extension needs, so that would be too simplistic to work. But indeed, the extension will eventually have to rewrite the hostname (dl.amnesia.boum.org) in URLs the same way as what we plan to do for normal web browsing.

#6 Updated by intrigeri over 2 years ago

Next step is to check with Giorgio if what we have in mind is doable, once we'll have a library to point him to.

#7 Updated by intrigeri over 2 years ago

  • Subject changed from Design how the ISO verification extension will support the new mirror pool system to Have the ISO verification extension will support the new mirror pool system

#8 Updated by intrigeri over 2 years ago

  • Subject changed from Have the ISO verification extension will support the new mirror pool system to Design how the ISO verification extension will support the new mirror pool system

#9 Updated by intrigeri over 2 years ago

  • Description updated (diff)

#10 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to Elevated

I'd like to discuss with Giorgio about that ASAP. Waiting for code to be pushed on #8639.

#11 Updated by intrigeri over 2 years ago

  • Priority changed from Elevated to High
  • Target version changed from Tails_1.7 to Tails_1.8

intrigeri wrote:

I'd like to discuss with Giorgio about that ASAP. Waiting for code to be pushed on #8639.

Actually code was pushed for #8639 so I can now do that. Time has flown though, bumping priority.

#12 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_1.8 to Tails_2.2

#13 Updated by intrigeri about 2 years ago

  • Subject changed from Design how the ISO verification extension will support the new mirror pool system to Design how the IA+DAVE will support the new mirror pool system
  • % Done changed from 10 to 20

Told the IA+DAVE crew about our plans, asked them the questions I had in mind: https://mailman.boum.org/pipermail/tails-dev/2016-February/010262.html

#14 Updated by intrigeri about 2 years ago

  • Blocks Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration added

#15 Updated by intrigeri about 2 years ago

  • % Done changed from 20 to 80

Giorgio's reply makes me confident that our proposed design will work. There's only one remaining question in the thread, plus sajolida's feedback would be useful.

#17 Updated by intrigeri about 2 years ago

  • Assignee changed from intrigeri to u
  • QA Check set to Ready for QA

Please review the design that's on the blueprint + the conclusions we reached on tails-dev@. Thanks!

#18 Updated by u about 2 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#19 Updated by u about 2 years ago

intrigeri wrote:

Giorgio's reply makes me confident that our proposed design will work. There's only one remaining question in the thread, plus sajolida's feedback would be useful.

By "remaining question in the thread" do you mean this:
"The only caveat for integrating it into DAVE is that every time the
extension starts/resume a download or is installed/upgraded/reloaded,
downloader.js loops through all the download jobs already "known" to the
browser's built-in download manager and, if any of them matches the URL
in the IDF, picks the active one, or if none is currently active, the
most advanced one and makes it "current", resuming it if required." ?

#20 Updated by u about 2 years ago

  • Assignee changed from u to intrigeri
  • QA Check changed from Ready for QA to Info Needed

Otherwise, I've reviewed the blueprint and conclusions reached and they look good to me.

#21 Updated by intrigeri about 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Info Needed to Pass

u wrote:

intrigeri wrote:

Giorgio's reply makes me confident that our proposed design will work. There's only one remaining question in the thread, plus sajolida's feedback would be useful.

By "remaining question in the thread" do you mean this: [...]

No, this was rather a conclusion, and I've already pointed to it on #11109.

I think I was rather refering to:

@sajolida + @Giorgio: is this done as part of the Installation Assistant or DAVE course of operation, or only due to external factors (e.g. the user manually reloading the page, or restarting their browser)?

To which Giorgio replied in https://mailman.boum.org/pipermail/tails-dev/2016-February/010281.html. I think this is well tracked in #11109 already, so as long as we re-read this thread when we implement that other ticket, we should be good.

So it appears that we have a sensible plan, and I'm closing this ticket.

#22 Updated by BitingBird almost 2 years ago

  • Priority changed from High to Normal

Also available in: Atom PDF