Project

General

Profile

Bug #10455

Totem cannot access DVD readers

Added by hybridwipe almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
10/29/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
bugfix/10455-aa-p-e-1.6
Type of work:
Debian
Blueprint:
Easy:
Affected tool:

Description

Noticed in #7674.

Apparmor prevents totem accessing /dev/sr0. If apparmor is stopped (sudo /etc/init.d/apparmor stop && sudo /etc/init.d/apparmor teardown), then totem can access the dvd and playback works (with patch applied).


Related issues

Related to Tails - Bug #9990: Totem freezes when trying to disable visual effects Resolved 08/13/2015
Blocks Tails - Feature #7674: Allow users to watch CSS protected DVDs Resolved 07/28/2014

Associated revisions

Revision 05680a8d (diff)
Added by intrigeri almost 2 years ago

Install apparmor-profiles-extra from jessie-backports, that grants Totem access to DVD readers (refs: #10455), and fixes a freeze when trying to disable visual effects (refs: #9990).

Revision dac5cce1
Added by intrigeri almost 2 years ago

Merge branch 'bugfix/10455-aa-p-e-1.6' into feature/jessie

Closes: #10455, #9990

History

#1 Updated by intrigeri almost 2 years ago

  • Blocks Feature #7674: Allow users to watch CSS protected DVDs added

#2 Updated by intrigeri almost 2 years ago

  • Status changed from New to Confirmed
  • Target version changed from Tails_1.8 to 246

Hint: this should be fixed in http://bazaar.launchpad.net/~apparmor-dev/apparmor-profiles/master/ and then in the apparmor-profiles-extra Debian package.

#3 Updated by hybridwipe almost 2 years ago

  • Assignee set to hybridwipe

#4 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri almost 2 years ago

  • Assignee changed from hybridwipe to intrigeri
  • Type of work changed from Code to Debian

Thanks! Your patch was applied upstream (r153) and I'll update apparmor-profiles-extra.

#6 Updated by intrigeri almost 2 years ago

  • Subject changed from Totem cannot access /dev/sr0 to Totem cannot access DVD readers
  • Target version changed from 246 to Tails_2.0
  • % Done changed from 0 to 30

intrigeri wrote:

I'll update apparmor-profiles-extra.

Uploaded aa-p-e 1.6 to sid. Next step is to backport it for Jessie, upload to jessie-backports, and set up our feature/jessie branch to install the backport. (I'm not going to spend any of my time fixing this on Tails/Wheezy at this point.)

#7 Updated by hybridwipe almost 2 years ago

intrigeri wrote:

Thanks! Your patch was applied upstream (r153) and I'll update apparmor-profiles-extra.

For reference, it's https://bazaar.launchpad.net/~apparmor-dev/apparmor-profiles/master/revision/153

#8 Updated by intrigeri almost 2 years ago

intrigeri wrote:

intrigeri wrote:

I'll update apparmor-profiles-extra.

Uploaded aa-p-e 1.6 to sid. Next step is to backport it for Jessie,

The package migrated to testing so we can now do that.

#9 Updated by intrigeri almost 2 years ago

  • Related to Bug #9990: Totem freezes when trying to disable visual effects added

#10 Updated by intrigeri almost 2 years ago

  • % Done changed from 30 to 40

Uploaded 1.6~bpo8+1 to jessie-backports.

#11 Updated by intrigeri almost 2 years ago

apparmor-profiles-extra_1.6~bpo8+1_i386.changes ACCEPTED into jessie-backports, jessie-backports

#12 Updated by intrigeri almost 2 years ago

  • Feature Branch set to bugfix/10455-aa-p-e-1.6

The upgrade to aa-p-e breaks the startup of apparmor.service:

Dec 07 22:15:01 amnesia apparmor[249]: profile has merged rule with conflicting x modifiers
Dec 07 22:15:01 amnesia apparmor[249]: ERROR processing regexs for profile launchpad_integration, failed to load
Dec 07 22:15:01 amnesia apparmor[249]: failed!

#13 Updated by intrigeri almost 2 years ago

... but indeed it drops the AppArmor denials when accessing the DVD.

#14 Updated by hybridwipe almost 2 years ago

intrigeri wrote:

... but indeed it drops the AppArmor denials when accessing the DVD.

Wooooo!

intrigeri wrote:

The upgrade to aa-p-e breaks the startup of apparmor.service:

[...]

Not woo.

#15 Updated by intrigeri almost 2 years ago

intrigeri wrote:

The upgrade to aa-p-e breaks the startup of apparmor.service:

... that's due to a usr.bin.pidgin.orig being left over. Apparently our build hook that detects such problems is not perfect. Indeed there's also /etc/init.d/alsa-utils.orig.

#16 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

#17 Updated by intrigeri almost 2 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF