Project

General

Profile

Feature #10574

Feature #5663: Return to Icedove

Change default protocol (IMAP vs POP3) depending on whether persistence is enabled or not

Added by kytv almost 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/17/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/6154-secure-autoconfig-in-icedove
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

In #9303 we decided that we should have POP as the default protocol if persistence is enabled and IMAP as the default if persistence is not enabled.

This ticket is for the actual implementation.

Associated revisions

Revision 979f390b (diff)
Added by anonym about 2 years ago

Make extensions.torbirdy.defaultprotocol affect the auto wizard.

We need this for #10574, to make POP the default when persistence is
enabled, and IMAP when persistence is disabled.

Note that we also rename the other patch against TorBirdy to ensure
that they are applied in the correct order.

This patch will be upstreamed in TorBirdy.

Will-fix: #10574

Revision 4a692f51 (diff)
Added by anonym about 2 years ago

Make Icedove default to POP iff persistence is enabled.

Will-fix: #10574

Revision 898564ba
Added by intrigeri about 2 years ago

Merge branch 'feature/6154-secure-autoconfig-in-icedove' into devel

fix-committed: #6154, #10906, #10905, #10574, #10464

History

#1 Updated by intrigeri over 2 years ago

  • Assignee set to kytv

(Please fix assignee if that's wrong, but it can't be more wrong than no assignee at all :)

#2 Updated by sajolida over 2 years ago

  • Target version changed from 246 to Tails_2.0

#3 Updated by u over 2 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#4 Updated by u over 2 years ago

In Tails 2.0~rc1 it seems that IMAP is the default, fyi.

#5 Updated by u over 2 years ago

  • Priority changed from Normal to Elevated

Raising priority as this seems to be something which should be done asap.

#6 Updated by intrigeri over 2 years ago

  • Subject changed from Change protocol (IMAP vs POP3) depending on whether persistence is enabled or not to Change default protocol (IMAP vs POP3) depending on whether persistence is enabled or not

I had a look at #9303 that lead to the creation of this ticket, and I'm actually not sure why this is on the SponsorS M4 plate, nor why it would be urgent: Claws Mail defaulted to IMAP, Icedove still does. We have good reasons to switch to POP3 by default when persistence is enabled, but for me this is out of the scope of what we committed to do as part of SponsorS M4. Did I miss anything?

#7 Updated by sajolida over 2 years ago

I agree with you and I think we should remove this one from SponsorS_M4.

As a more general note, I think that sometimes it's cool to take advantage of a momentum when working fast on a new feature to sneak in other related improvements even if slightly out of the scope of the deliverable, because it might then be way faster to solve this extra stuff than some months later or by someone else (if time allows of course). But here we're quite far away from such a momentum indeed and it looks like it's time to simplify kytv's plate as much as we can :)

I'll let u update the metadata as the tracker for this project.

#8 Updated by u over 2 years ago

  • Priority changed from Elevated to Normal
  • Target version changed from Tails_2.2 to Tails_2.4

ack! delaying it then and removing the sponsor.

#9 Updated by anonym over 2 years ago

  • Assignee changed from kytv to anonym

#10 Updated by anonym about 2 years ago

  • Target version changed from Tails_2.4 to Tails_2.6
  • Type of work changed from Code to Discuss

I know that I originally (on #9303) came up with this idea, but after having looked briefly at it, it will not be simple. It will definitely require more upstream Thunderbird patches. Quite honestly, I think we can spend our time on more important stuff.

So I'm raising the discussion for making this a low-prio wishlist feature.

#11 Updated by sajolida about 2 years ago

If you are sure that this will imply upstream patches, then I'm also in favor or rejecting this straight away :)

#12 Updated by intrigeri about 2 years ago

If you are sure that this will imply upstream patches, then I'm also in favor or rejecting this straight away :)

+1

#13 Updated by u about 2 years ago

+1

#14 Updated by anonym about 2 years ago

sajolida wrote:

If you are sure that this will imply upstream patches, then I'm also in favor or rejecting this straight away :)

After a last look at this, apparently I was not, so I have now pushed a solution to: https://github.com/fred-a-kemp/torbirdy/tree/post-secure-autoconfig-fixup . It is hacky (monkeypatches!), but hey, this is a Mozilla add-on. :) Assuming my patch works, we just have to import it into config/chroot_local-patches and add three lines of trivial code to the icedove wrapper, so it is not hard and will require little implementation.

#15 Updated by u about 2 years ago

Could you reassign this ticket to me once you've pushed this to my torbirdy repository so that I can make a pull request upstream please? Thanks!

#17 Updated by u about 2 years ago

  • % Done changed from 0 to 10
  • Type of work changed from Discuss to Code

#18 Updated by anonym about 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_2.6 to Tails_2.4
  • % Done changed from 10 to 50
  • Feature Branch set to feature/6154-secure-autoconfig-in-icedove

Let's do it! :)

#19 Updated by intrigeri about 2 years ago

  • % Done changed from 50 to 60
  • QA Check set to Ready for QA

Code seems sane, will now test.

#20 Updated by intrigeri about 2 years ago

  • % Done changed from 60 to 90

Tested with & without persistence, works as expected!

#21 Updated by intrigeri about 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100
  • QA Check changed from Ready for QA to Pass

#22 Updated by anonym about 2 years ago

  • Status changed from Fix committed to In Progress

#23 Updated by intrigeri about 2 years ago

  • Status changed from In Progress to Fix committed

#24 Updated by anonym about 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF