Project

General

Profile

Bug #10658

Only ship in $PATH custom scripts that we intend users to run

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/24/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/10658-clean-up-path
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

/usr/local/*bin contains lots of helper scripts that users should not be tempted to run. They should go to /usr/local/lib. Now we won't have anything serious to forward-port from Wheezy to Jessie anymore, we'll be testing feature/jessie a lot for 2 months, so perhaps it's the good time to do it in feature/jessie. Not a blocker though.

Associated revisions

Revision 2462e3bb (diff)
Added by intrigeri over 2 years ago

Move connect-socks out of the $PATH.

Refs: #10658

Revision 0b1017e8 (diff)
Added by intrigeri over 2 years ago

Move end-profile out of the $PATH.

Refs: #10658

Revision 6a1b4c1f (diff)
Added by intrigeri over 2 years ago

Move generate-tor-browser-profile out of the $PATH.

Refs: #10658

Revision cfa9624f (diff)
Added by intrigeri over 2 years ago

Move getTorBrowserUserAgent out of the $PATH.

Refs: #10658

Revision 9b897e02 (diff)
Added by intrigeri over 2 years ago

Move kill-boot-profile out of the $PATH.

Refs: #10658

Revision fee18ea2 (diff)
Added by intrigeri over 2 years ago

Move tails-spoof-mac out of the $PATH.

Refs: #10658

Revision 97e9dd2d (diff)
Added by intrigeri over 2 years ago

Move tails-set-wireless-devices-state out of the $PATH.

Refs: #10658

Revision 853eafdd (diff)
Added by intrigeri over 2 years ago

Move tails-configure-keyboard out of $PATH.

Refs: #10658

Revision d53a3569 (diff)
Added by intrigeri over 2 years ago

Move do_not_ever_run_me out of the $PATH.

Refs: #10658

Revision a620810b (diff)
Added by intrigeri over 2 years ago

Move boot-profile out of the $PATH.

Refs: #10658

Revision abba4613 (diff)
Added by intrigeri over 2 years ago

Move tails-unblock-network out of $PATH.

Refs: #10658

Revision 34a15746 (diff)
Added by intrigeri over 2 years ago

Move tor-controlport-filter out of the $PATH.

Refs: #10658

Revision 10a502dd (diff)
Added by intrigeri over 2 years ago

Move tails-virt-notify-user out of $PATH.

Refs: #10658

Revision c2533533 (diff)
Added by intrigeri over 2 years ago

Move tails-htp-notify-user out of $PATH.

Refs: #10658

Revision 8ccbfcf0 (diff)
Added by intrigeri over 2 years ago

Move udev-watchdog-wrapper out of $PATH.

Refs: #10658

Revision 685fc235
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/feature/10658-clean-up-path' into devel

Fix-committed: #10658

History

#1 Updated by intrigeri over 2 years ago

  • Feature Branch set to feature/10658-clean-up-path

#2 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • Priority changed from Low to Normal
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

I did a full test suite run, and it didn't seem more broken than current feature/jessie => please review'n'merge :)

#3 Updated by anonym over 2 years ago

Since it's my fault that this branch has bit rotted I have merged devel into it, and built and uploaded tails-greeter 0.8.16+feature10658.1. Will give it a full automated test suite run.

#4 Updated by anonym over 2 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#5 Updated by anonym over 2 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#6 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF