Project

General

Profile

Feature #10756

Feature #5663: Return to Icedove

Icedove wrapper is not integrated in our i18n system

Added by intrigeri almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
12/15/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
kytv/bugfix/10756/icedove-po
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I see gettext commands in the script but the strings are not in our PO files. See refresh-translations and po/POTFILES.in. Once done, I suggest translating a string and checking that it indeed appears translated in the UI.

Associated revisions

Revision 18869103
Added by anonym almost 3 years ago

Merge remote-tracking branch 'kytv/bugfix/10756/icedove-po' into devel

Fix-committed: #10756

History

#1 Updated by kytv almost 3 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to kytv/bugfix/10756/icedove-po

The gettext strings are extracted when refresh-translations is run, but the warning added by bert in #10458 is not displayed with tails-persistence-setup 1.1-3. Maybe it's because the claws preset has been removed?

#2 Updated by kytv almost 3 years ago

Then again, running tails-persistence-setup yields

Error: Persistence volume is not readable. Permissions or ownership problems?

So perhaps this is the problem?

+ test -z 
+ TEXTDOMAIN=tails
+ export TEXTDOMAIN
+ CLAWSMAIL_DIR=/home/amnesia/.claws-mail
+ PROFILE=/home/amnesia/.icedove/profile.default
+ claws_mail_config_is_persistent
+ findmnt --noheadings --output SOURCE --target /home/amnesia/.claws-mail
+ [ /dev/mapper/TailsData_unlocked[/claws-mail] = /dev/mapper/TailsData_unlocked[/claws-mail] ]
+ [ -f /home/amnesia/.claws-mail/accountrc ]
+ start_icedove
+ TMPDIR=/home/amnesia/.icedove/profile.default/tmp
+ mkdir --mode=0700 -p /home/amnesia/.icedove/profile.default/tmp
+ export TMPDIR
+ unset SESSION_MANAGER
+ /usr/bin/icedove --class Icedove -profile /home/amnesia/.icedove/profile.default

The wrapper bits seem to be correctly determining that Claws is persistent...

#3 Updated by kytv almost 3 years ago

Oh, I see. I don't have ~/.claws-mail/accountrc even though I do have claws configured (and working).

#4 Updated by kytv almost 3 years ago

  • Assignee changed from kytv to intrigeri
  • % Done changed from 0 to 40
  • QA Check set to Ready for QA

Tested and working. Translated strings appeared in the message zenity displayed.

(I don't know why I didn't have accountrc)

#5 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to anonym

Reassigning to the RM for 2.0 :)

#6 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 40 to 100

#7 Updated by anonym almost 3 years ago

  • QA Check changed from Ready for QA to Pass

#8 Updated by anonym over 2 years ago

  • Assignee deleted (anonym)

#9 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF