Project

General

Profile

Bug #10782

Feature #7563: Update the automated test suite for Jessie ISO images

Regression in "I synchronize keys in Seahorse" recovery_proc

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
12/20/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
test/10782-restart-seahorse-in-same-manner
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

889411fdc54afbbd56ba4ef4858806d13690d220 did:

@@ -120,7 +117,7 @@ Then /^I synchronize keys in Seahorse$/ do
     if @screen.exists('GnomeCloseButton.png') || !$vm.has_process?('seahorse')
       step 'I kill the process "seahorse"' if $vm.has_process?('seahorse')
       debug_log('Restarting Seahorse.')
-      start_or_restart_seahorse(withapplet = @withgpgapplet)
+      start_or_restart_seahorse(withgpgapplet)
     end
   end

... but withgpgapplet is not defined in this scope. I think this was exactly why kytv used something with broader scope than a local variable in the first place.

In practice, I think it means that if the initial sync fails, and we meant to test with Seahorse started from the OpenPGP applet, then the retries will be run from a Seahorse started differently, which is not what we want to test in this case.

Associated revisions

Revision ada1297a (diff)
Added by anonym over 2 years ago

Make sure we restart Seahorse in the same manner as initially.

We need to save the manner we started Seahorse in in a greater scope
(hence the class variable).

Will-fix: #10782

Revision 01babf08 (diff)
Added by intrigeri over 2 years ago

Seahorse test suite: update expected OpenPGP Applet icon to work even when it's truncated.

While running tests for test/10782-restart-seahorse-in-same-manner,
I've seen the "I start Seahorse via the Tails OpenPGP Applet" step
fail every time due to "FindFailed: can not find GpgAppletIconNormal.png
on the screen", apparently because the OpenPGP Applet icon was a tiny
bit truncated. With this small change to the image, it passes just fine.

refs: #10782

Revision 45de9cf1
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/test/10782-restart-seahorse-in-same-manner' into testing

Fix-committed: #10782

History

#1 Updated by anonym over 2 years ago

Wow. Good catch! :)

#2 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress

#3 Updated by anonym over 2 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/10782-restart-seahorse-in-same-manner

#4 Updated by intrigeri over 2 years ago

kytv: in case you can't handle this review within a week from now, please let me know, so I take it over. Note that I won't be able to do it after Jan 21, so I need to know pretty quickly.

#5 Updated by anonym over 2 years ago

  • Assignee changed from kytv to intrigeri

intrigeri wrote:

kytv: in case you can't handle this review within a week from now, please let me know, so I take it over. Note that I won't be able to do it after Jan 21, so I need to know pretty quickly.

Since we haven't heard anything from kytv yet I'm assigning it to you, as decided earlier.

#6 Updated by intrigeri over 2 years ago

  • % Done changed from 50 to 60

Code review passes, testing.

#7 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 60 to 70

features/encryption.feature features/torified_gnupg.feature pass for me once I apply the change I've pushed to the topic branch => please review and merge.

#8 Updated by anonym over 2 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 70 to 100

#9 Updated by anonym over 2 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#10 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF