Project

General

Profile

Bug #10950

Bring gnome-sound-recorder back

Added by intrigeri over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
09/04/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/10950-add-gnome-sound-recorder
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Description

It was installed on Tails/Wheezy, it's not in 2.0~rc1. Maybe it's fine this way, since we ship Audacity already?


Subtasks

Bug #11780: GNOME Sound Recorder unusable because of "invalid capture settings"Resolved

Feature #11791: Update documentation to mention GNOME Sound RecorderResolved

Associated revisions

Revision 473e8f05 (diff)
Added by intrigeri about 1 year ago

Drop useless comment.

We don't use comments in that file unless necessary. In this case, Git
history and changelog should point to the ticket, that should be enough
to document the reason why we ship gnome-sound-recorder.

Refs: #10950

Revision 87b34ee5
Added by intrigeri about 1 year ago

Merge remote-tracking branch 'origin/bugfix/10950-add-gnome-sound-recorder' into devel

Fix-committed: #10950

Revision fa20ec0b (diff)
Added by intrigeri about 1 year ago

Revert "Bring gnome-sound-recorder back": unusable in current default configuration, lacking user documentation.

refs: #11780, #10950

This reverts commits 4b9e40be686d1fa6de885e41622f6bf722f199f3
and 473e8f059e1bd059d466c4066326acdd3e3824fb.

Revision b7510465
Added by anonym 6 months ago

Merge remote-tracking branch 'hybridwipe/bugfix/10950-add-gnome-sound-recorder' into devel

Fix-committed: #10950

History

#1 Updated by emmapeel over 1 year ago

Gnome-sound-recorder has no advantages respect to Audacity... and we ship Audacity already

#2 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

emmapeel wrote:

Gnome-sound-recorder has no advantages respect to Audacity...

FTR I beg to disagree (a very simple UI is an advantage, compared to a daunting one with tons of buttons everywhere), but this may not be a strong enough reason to ship two pieces of software that address very similar use cases.

Anyway, the one we mention in our documentation is Audacity. On XMPP emmapeel and I agreed on: we stop shipping GNOME sound recorder, and re-add it if anyone asks for it in the 3 months after 2.0 is out.

#3 Updated by hybridwipe about 1 year ago

intrigeri wrote:

emmapeel wrote:

Gnome-sound-recorder has no advantages respect to Audacity...

FTR I beg to disagree (a very simple UI is an advantage, compared to a daunting one with tons of buttons everywhere), but this may not be a strong enough reason to ship two pieces of software that address very similar use cases.

+1 (and I think it is enough reason, at least in this case). If we don't want to include duplicate software, then there's no reason to include gedit if we also ship LibreOffice Writer, either ;).

Anyway, the one we mention in our documentation is Audacity. On XMPP emmapeel and I agreed on: we stop shipping GNOME sound recorder, and re-add it if anyone asks for it in the 3 months after 2.0 is out.

It's been 5-6, but someone has:
https://mailman.boum.org/pipermail/tails-dev/2016-June/010756.html

#4 Updated by hybridwipe about 1 year ago

  • Category set to Hardware support
  • Status changed from Resolved to In Progress
  • Target version changed from Tails_2.0 to Tails_2.5
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/10950-add-gnome-sound-recorder
  • Type of work changed from Discuss to Code

#5 Updated by BitingBird about 1 year ago

  • % Done changed from 100 to 50

The discussion should happen before the eview, probably.

#6 Updated by sajolida about 1 year ago

  • Assignee set to sajolida
  • Type of work changed from Code to Discuss

It seems like what we need is a discussion: https://mailman.boum.org/pipermail/tails-dev/2016-June/010759.html.

#7 Updated by sajolida about 1 year ago

I'll build this branch to know how much GNOME Recorder adds to the ISO image.

#8 Updated by sajolida about 1 year ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)
  • wget http://nightly.tails.boum.org/build_Tails_ISO_devel/lastSuccessful/archive/latest.iso gives me Length: 1151539200.
  • wget http://nightly.tails.boum.org/build_Tails_ISO_bugfix-10950-add-gnome-sound-recorder/lastSuccessful/archive/latest.iso also gives me Length: 1151539200.

I also downloaded both ISO images and checked their size and checksum and got the same result. It seems like the inclusion of gnome-sound-recorder has no impact whatsoever on the image size. Crazy. I didn't test the ISO images.

#9 Updated by hybridwipe about 1 year ago

sajolida wrote:

  • wget http://nightly.tails.boum.org/build_Tails_ISO_devel/lastSuccessful/archive/latest.iso gives me Length: 1151539200.
  • wget http://nightly.tails.boum.org/build_Tails_ISO_bugfix-10950-add-gnome-sound-recorder/lastSuccessful/archive/latest.iso also gives me Length: 1151539200.

I also downloaded both ISO images and checked their size and checksum and got the same result. It seems like the inclusion of gnome-sound-recorder has no impact whatsoever on the image size. Crazy. I didn't test the ISO images.

I didn't make them, can't say. But I can say that when I build an image locally with that change, I get gnome-sound-recorder in .packages, and a 'Sound Recorder' menu item under 'Sound & Video' that wasn't there before.

#10 Updated by intrigeri about 1 year ago

It seems like the inclusion of gnome-sound-recorder has no impact whatsoever on the image size. Crazy.

We pad ISO files, so the current practical impact may very well be 0 (still, it may have a strictly positive practical impact at any point in the future).

#11 Updated by muri about 1 year ago

  • QA Check set to Ready for QA
  • Type of work changed from Discuss to Code

We talked about that at the monthly meeting:

We decided to add gnome-sound-recorder back to tails.
If we had to decide between audacity and gnome-sound-recorder, we would ship
the latter, because its easier to use for inexpierenced users. The former could
be a case for the 'additional software packages', but we don't want a
regression and there are usecases for audacity on Tails. Also g-s-r is really
tiny. Thats why we ship both.

Setting the ticket to Ready for QA, as there is already a bugfix

#12 Updated by intrigeri about 1 year ago

  • Subject changed from Consider installing gnome-sound-recorder on Jessie to Bring gnome-sound-recorder back
  • Assignee set to anonym
  • Target version changed from Tails_2.5 to Tails_2.6

#13 Updated by intrigeri about 1 year ago

  • Assignee changed from anonym to hybridwipe
  • QA Check changed from Ready for QA to Dev Needed

Can you please also look into updating the corresponding doc? git grep -w -i audacity -- wiki/src/**/*.mdwn wiki/src/**/*.html should point you to the places that might need an update.

#14 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#15 Updated by sajolida about 1 year ago

  • Assignee changed from hybridwipe to sajolida

I'll have to take over the documentation work I guess...

#16 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to In Progress

#17 Updated by intrigeri about 1 year ago

FTR we'll have to revert this change unless #11780 is fixed + the doc is updated in the next 46 hours. I'm sorry for the time pressure, I probably merged this too hastily last month :/

#18 Updated by intrigeri about 1 year ago

  • Assignee changed from sajolida to hybridwipe
  • Target version changed from Tails_2.6 to Tails_2.9.1

I've reverted this change on the testing branch for 2.6, and created #11791 to track the doc update.

#19 Updated by sajolida about 1 year ago

The release notes snippet I wrote for this (and got removed) is:

-  - We installed again *GNOME Sound Recorder* to provide a very simple
-    application for recording sound in addition to the most complex *Audacity*.
XXX: Link to documentation (#11780)
XXX: Add screenshot

(I'll try to reuse it for when this will get merged.)

#20 Updated by anonym 9 months ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#21 Updated by intrigeri 8 months ago

  • Target version changed from Tails 2.10 to Tails_2.12

#22 Updated by hybridwipe 6 months ago

I've pushed a branch here that should fix this:
https://git-tails.immerda.ch/hybridwipe/tails/log/?h=bugfix/10950-add-gnome-sound-recorder
specifically:
https://git-tails.immerda.ch/hybridwipe/tails/commit/?h=bugfix/10950-add-gnome-sound-recorder&id=db8d34737e09026d156cc1e22edb9082cf0008ab

unfortunately I can't build at the moment, not sure why, and I've gotten no replies on the tails-dev mailing list.

If someone can build and test that, it would be lovely (the change does work on my Debian machine).

#23 Updated by intrigeri 6 months ago

Thanks! I don't think we should install the package from sid on Tails 2.x (based on Jessie): this brings too much instability for us, e.g. the sid package may start pulling a newer libc6 or other crazy stuff at any point. Instead, I recommend that we add gstreamer1.0-pulseaudio to our packages list, and then file a ticket for 3.0 about removing this line once we install gnome-sound-recorder >=3.21.92-2. What do you think?

#24 Updated by hybridwipe 6 months ago

intrigeri wrote:

Thanks! I don't think we should install the package from sid on Tails 2.x (based on Jessie): this brings too much instability for us, e.g. the sid package may start pulling a newer libc6 or other crazy stuff at any point. Instead, I recommend that we add gstreamer1.0-pulseaudio to our packages list, and then file a ticket for 3.0 about removing this line once we install gnome-sound-recorder >=3.21.92-2. What do you think?

Of course. You mentioned that in #11780, my fault for missing it.

https://git-tails.immerda.ch/hybridwipe/tails/commit/?h=bugfix/10950-add-gnome-sound-recorder&id=b931bf34d8d778b4ca96fecb70996d9d599d5a12

I've got a build going that I'll test tomorrow (bedtime).

#25 Updated by intrigeri 6 months ago

I've got a build going that I'll test tomorrow (bedtime).

\o/

#26 Updated by hybridwipe 6 months ago

intrigeri wrote:

I've got a build going that I'll test tomorrow (bedtime).

\o/

Works, tested recording myself and hearing my own voice played back.

#27 Updated by intrigeri 6 months ago

Works, tested recording myself and hearing my own voice played back.

Cool. Feel free to submit this branch for QA whenever you want :)
(https://tails.boum.org/contribute/merge_policy/)

#28 Updated by hybridwipe 6 months ago

  • Assignee deleted (hybridwipe)
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

Works, tested recording myself and hearing my own voice played back.

Cool. Feel free to submit this branch for QA whenever you want :)
(https://tails.boum.org/contribute/merge_policy/)

Thanks for reminder.

#29 Updated by intrigeri 6 months ago

  • Assignee set to anonym

(anonym is the release manager for 2.12 :)

#30 Updated by anonym 6 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

Thanks for the fix, hybridwipe! Merged!

#31 Updated by anonym 6 months ago

  • % Done changed from 0 to 100

#32 Updated by anonym 5 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF