Project

General

Profile

Bug #10958

Feature #14568: Additional Software Packages

Feature #14570: Implement Offline Mode for Additional Software Packages

Disable automatic removal of debs after install

Added by intrigeri about 2 years ago. Updated 12 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
Start date:
01/17/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/10958-disable-automatic-removal-of-debs
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

apt (1.2~exp1) experimental; urgency=medium

  [ Automatic removal of debs after install ]
  After packages are successfully installed by apt(8),
  the corresponding .deb package files will be
  removed from the /var/cache/apt/archives cache directory.

  This can be changed by setting the apt configuration option
    "APT::Keep-Downloaded-Packages" to "true". E.g:

  # echo 'APT::Keep-Downloaded-Packages "true";' \
      > /etc/apt/apt.conf.d/01keep-debs

  Please note that the behavior of apt-get is unchanged. The
  downloaded debs will be kept in the cache directory after they
  are installed.

Disabling this would be nice for users who use apt to preseed their persistent APT cache.

Associated revisions

Revision 55674b5d (diff)
Added by intrigeri over 1 year ago

Don't delete downloaded debs after install: apt(8) >= 1.2~exp1 deletes them, which is not nice for users who use it to preseed their persistent APT cache. (Closes: #10958)

Revision d4ffb850
Added by anonym about 2 months ago

Merge remote-tracking branch 'origin/bugfix/10958-disable-automatic-removal-of-debs' into stable

Fix-committed: #10958

History

#1 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10

Fixed locally, needs to be tested.

#2 Updated by intrigeri over 1 year ago

Works.

#3 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100

#4 Updated by sajolida about 2 months ago

  • Status changed from Resolved to In Progress
  • Target version changed from Tails_3.0 to Tails_3.5
  • % Done changed from 100 to 70
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/10958-disable-automatic-removal-of-debs

Since 3.0 I had trouble with this and finally got to debug it.

I think that the configuration changed since you pasted the Changelog for apt 1.2~expr1. See https://anonscm.debian.org/git/apt/apt.git/tree/debian/NEWS.

I prepared a branch. I tested the change locally but didn't built or test a full ISO.

I tested this by doing from Tails 3.3:

  • apt install sl (very important utility!)
  • ls -1 /var/cache/apt/archives/ | grep ^sl gives nothing
  • echo 'Binary::apt::APT::Keep-Downloaded-Packages "true";' > /etc/apt/apt.conf.d/14keep-debs
  • apt remove sl ; apt install sl
  • ls -1 /var/cache/apt/archives/ | grep ^sl gives sl_3.03-17+b2_amd64.deb

#5 Updated by intrigeri about 2 months ago

Thanks!

#6 Updated by intrigeri about 2 months ago

  • Assignee changed from intrigeri to anonym

(Reassigning to the current RM.)

#7 Updated by anonym about 2 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

In passing, I wonder if it wouldn't be nice to revert this perference (by removing this config file) when booting from DVD...

#8 Updated by intrigeri about 1 month ago

  • Affected tool set to Additional Software Packages

#9 Updated by intrigeri about 1 month ago

  • Parent task set to #14570

#10 Updated by intrigeri 17 days ago

  • Target version changed from Tails_3.5 to Tails_3.4

#11 Updated by anonym 12 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF