Bug #10965

Some printers cannot be added via GNOME

Added by anonym over 1 year ago. Updated about 1 year ago.

Status:ResolvedStart date:01/18/2016
Priority:ElevatedDue date:
Assignee:-% Done:

100%

Category:Hardware support
Target version:Tails_2.4
QA Check:Pass Blueprint:
Feature Branch:bugfix/10965-usb-printer-configuration Easy:
Type of work:Research Affected tool:

Description

While testing the fix for #10893 I noticed that printing still doesn't work for me: with a HP printer that worked fine for me on Debian Jessie (some months ago) and currently works fine on Debian Unstable, I get this in the journal when plugging it:

Jan 18 02:36:29 amnesia colord-sane[6910]: io/hpmud/musb.c 2075: Invalid usb_open: Permission denied

Two (!?) entries shows up in GNOME's Add Printer settings, and when I try to add any of them I get a generic failure pop-up, and I also see this in the journal:
Jan 18 02:39:31 amnesia gnome-control-center.desktop[5617]: (gnome-control-center:5617): printers-cc-panel-WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.fedoraproject.Config.Printing was not provided by any .service files


Related issues

Related to Tails - Bug #8443: Adding a new printer requires administration password Resolved 12/15/2014
Related to Tails - Bug #8505: Jessie: there is an unclear and useless Sundry category in Applications menu Resolved 12/31/2014 10/15/2015
Related to Tails - Feature #11505: Install system-config-printer-common instead of system-config-printer Resolved 06/02/2016

Associated revisions

Revision e3742bf3
Added by intrigeri about 1 year ago

Don't display system-config-printer in GNOME applications menu.

See #8505 and 84c0feb8 for the reasons why.

refs: #10965

Revision 637e6ed9
Added by intrigeri about 1 year ago

Torify the org.fedoraproject.Config.Printing D-Bus service.

Otherwise, it segfaults when our firewall blocks its connections
to openprinting.org, which breaks installation of some USB printers.

Note that we use torsocks' absolute path here, otherwise D-Bus doesn't
manage to spawn the service. Not sure why there wasn't the same problem
with org.gnome.seahorse.Application, but anyway, making things more
explicit cannot hurt :)

Also, note that I don't know if torifying scp-dbus-service is enough to
make it do anything useful, but at least it prevents it from
segfaulting, and allows me to configure one printer (known in the local
database) that I could not configure otherwise, so it's already progress.

refs: #10965

Revision 6232d76b
Added by intrigeri about 1 year ago

Install jessie-backports version of all binary packages built from src:hplip.

This adds support for quite a few new printers.

refs: #10965 (since it makes it more likely that a given printer will be
supported out-of-the-box, regardless of whether the online lookup works
or not; and at this point I cannot confirm that torifying
scp-dbus-service is enough to make it do anything useful for printers
that need the online lookup.)

Revision 30b9ebc4
Added by intrigeri about 1 year ago

Install printer-driver-postscript-hp.

It adds support for some more printers.

refs: #10965

Revision 97dbd2d5
Added by anonym about 1 year ago

Merge remote-tracking branch 'origin/bugfix/10965-usb-printer-configuration' into testing

Fix-committed: #10965

History

#2 Updated by anonym over 1 year ago

  • Assignee set to intrigeri

I'm optimistically assigning this to you intrigeri, since I suppose you have some sort of experience from the current printing situation in Tails after #10893.

#3 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#4 Updated by intrigeri over 1 year ago

anonym: does it work in Tails 1.8.2?

#5 Updated by intrigeri over 1 year ago

  • Category set to Hardware support

#6 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • Target version deleted (Tails_2.0)
  • QA Check set to Info Needed

Well, no, I'm not really familiar with the printing situation: so far I only fixed AppArmor profiles. I can have a look, but without access to the hardware it'll be hard. Sorry :/

Please set target version back to 2.0 and reassign to me so I try to fix it, if this is a regression against 1.x.

#7 Updated by anonym over 1 year ago

  • Assignee changed from anonym to intrigeri
  • Target version set to Tails_2.0
  • QA Check changed from Info Needed to Dev Needed

intrigeri wrote:

Well, no, I'm not really familiar with the printing situation: so far I only fixed AppArmor profiles. I can have a look, but without access to the hardware it'll be hard. Sorry :/

I would gladly help, if you have any idea what to test or where to look for more useful info.

Please set target version back to 2.0 and reassign to me so I try to fix it, if this is a regression against 1.x.

I can add the printer without issue in 1.8.2. I had to set an administration password, though, which I didn't in 2.0~rc1 (I know I set one but wasn't prompted).

#8 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_2.0 to Tails_2.2

I'll try to give it a look for 2.2. No promise, though. Help is welcome.

#9 Updated by goupille over 1 year ago

  • Subject changed from HP printers cannot be added via GNOME to some printers cannot be added via GNOME

a user report the same issue with an Epson printer. It worked well on 1.8.2, and I found the same warnings in the logs.

#10 Updated by elouann over 1 year ago

Good news, it's solved after the installation of system-config-printer.
Note that there were some good reasons to remove this package 5 monthes ago: https://labs.riseup.net/code/projects/tails/repository/revisions/84c0feb87eeb4f5472b60c4b04bf92291c49a2f6

#11 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to elouann
  • QA Check changed from Dev Needed to Info Needed

Please send/forward me a complete tails-debugging-info output captured after reproducing this bug. Thanks!

#12 Updated by elouann over 1 year ago

  • Assignee changed from elouann to intrigeri
  • Target version changed from Tails_2.2 to Tails_2.3
  • QA Check changed from Info Needed to Dev Needed

intrigeri wrote:

Please send/forward me a complete tails-debugging-info output captured after reproducing this bug. Thanks!

Done, reassigning to you, intrigeri, tell me if I should rather add you as 'Watcher'.
Cheers

#13 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_2.3 to Tails_2.4

Done, reassigning to you, intrigeri, tell me if I should rather add you as 'Watcher'.

Thanks. That's OK. The target version is very optimistic though, adjusting it (and even 2.4 feels optimistic, feel free to go find help elsewhere).

#14 Updated by mercedes508 over 1 year ago

Another user reported that issue with the following hardware:

Epson L220 and TX235

#15 Updated by emmapeel about 1 year ago

FWIW I can add an OKI printer connected to the local network (no USB)

#16 Updated by intrigeri about 1 year ago

  • Subject changed from some printers cannot be added via GNOME to Some printers cannot be added via GNOME
  • Priority changed from Normal to Elevated

#17 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress

Reproduced locally by plugging a printer via USB, but not when using it via the network, which is why I missed the problem when I worked on #8443 and friends. So, apparently for some printers system-config-printer is still needed:

#18 Updated by intrigeri about 1 year ago

  • Related to Bug #8443: Adding a new printer requires administration password added

#19 Updated by intrigeri about 1 year ago

  • Related to Bug #8505: Jessie: there is an unclear and useless Sundry category in Applications menu added

#20 Updated by intrigeri about 1 year ago

Installing system-config-printer allows GNOME printer config to go one step further ("Installing"), but:

  • if we install it, we need to drop its desktop file to avoid re-introducing #8505;
  • then, a few TCP packets to 140.211.169.27:443 (reverse DNS: openprinting2.linux-foundation.org) are blocked by our firewall, scp-dbus-service segfaults and the installation of the new printer fails; these packets are sent as the amnesia user, so we can't trivially transparently proxy them through Tor.

Note that the installation "succeeds" (although the correct driver is not selected) if I click "Cancel" in the "Searching for drivers" dialog.

Then, if I torify scp-dbus-service in /usr/share/dbus-1/services/org.fedoraproject.Config.Printing.service, I see connections to the aforementioned IP address in Onion Circuits, and the printer installation succeeds; however, the correct driver is not selected. I guess it's just because the printer I'm testing is not known neither locally, nor in the openprinting database; and indeed on sid, this works just fine, because my printer's PPD is shipped with newer hplip (same on Tails after installing from jessie-backports a bunch of packages: hplip printer-driver-hpcups libsane-hpaio libhpmud0 hplip-data hpijs-ppds printer-driver-postscript-hp).

At this point I cannot confirm that torifying scp-dbus-service is enough to make it do anything useful, but at least it prevents it from segfaulting, and allows me to configure one printer (known in the local database) that I could not configure otherwise, so it's already progress.

#21 Updated by intrigeri about 1 year ago

  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/10965-usb-printer-configuration

#22 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 30
  • QA Check changed from Dev Needed to Ready for QA

anonym: please review'n'merge.

frontdesk: please point bug reporters to the experimental ISO (I've just sent the link to your mailing list).

#23 Updated by anonym about 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 30 to 100

#24 Updated by anonym about 1 year ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

anonym: please review'n'merge.

Looks good! Now my printer works perfectly again! => Merged!

#25 Updated by intrigeri about 1 year ago

  • Related to Feature #11505: Install system-config-printer-common instead of system-config-printer added

#26 Updated by anonym about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF