Bug #11000

The Tor Browser's font fingerprinting protection does not work in Tails

Added by anonym over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:01/26/2016
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:Tails_2.0.1
QA Check: Blueprint:
Feature Branch: Easy:
Type of work:Code Affected tool:Browser

Description

As reported by Panopticlick during the manual test session for Tails 2.0.


Related issues

Related to Tails - Bug #11124: Update TorBrowserTailsRoadmap.png image Resolved 02/13/2016

Associated revisions

Revision 2af53484
Added by anonym over 1 year ago

Enable the Tor Browser's font fingerprinting protection.

Sadly this was missed so we won't have it in Tails 2.0.

Fix-committed: #11000

Revision 4bcd962d
Added by anonym over 1 year ago

Add step to synch with the start-tor-browser script.

So we won't repeat mistakes like #11000 again.

Refs: #11000

History

#1 Updated by anonym over 1 year ago

  • Status changed from Confirmed to Fix committed
  • % Done changed from 0 to 100

#2 Updated by anonym over 1 year ago

  • Assignee deleted (anonym)
  • QA Check set to Pass

bertagaz tested my fix.

#3 Updated by cypherpunks over 1 year ago

The Tails 2.0 release announcement says "Tor Browser 5.5 introduces protection against fingerprinting but due to an oversight it is not enabled in Tails 2.0."

While the full story might be apparent to advanced users who click through to this issue, to everyone else, this statement is alarming and misleading because most of Tor Browser's fingerprinting defenses are still enabled and should work fine. (I suggest s/introduces protection against/introduces new protection against font/ to make this statement accurate.)

Also, the Known Issues page says "There are currently no known differences between the fingerprints of Tor Browser inside and outside of Tails." which is inaccurate due to this issue and the fact that AdBlock plus is enabled by default.

thanks for Tails, HTH, HAND!

#4 Updated by sajolida over 1 year ago

I added this to the 'Known issues' page. We should revert f942b67 when release 2.2.

#5 Updated by intrigeri over 1 year ago

  • Status changed from Fix committed to In Progress
  • Assignee set to sajolida
  • % Done changed from 100 to 90
  • QA Check changed from Pass to Dev Needed

sajolida wrote:

I added this to the 'Known issues' page. We should revert f942b67 when release 2.2.

Any reason not to do that on the stable branch, so that we're done here and everything is automatically in order for next release (if it's an emergency one, we'll be happy not to have to think about such things at release time)?

#6 Updated by sajolida over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

That's smart! Done in 0ecf55a.

#7 Updated by bertagaz over 1 year ago

  • Status changed from Fix committed to Resolved
  • Target version changed from Tails_2.2 to Tails_2.0.1
  • % Done changed from 90 to 100

#8 Updated by bertagaz over 1 year ago

  • Related to Bug #11124: Update TorBrowserTailsRoadmap.png image added

Also available in: Atom PDF