Project

General

Profile

Bug #11006

Feature #12160: Upgrade all systems to Stretch

Reinstall Lizard's isobuilders from scratch

Added by bertagaz almost 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/27/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Easy:
No
Affected tool:

Description

As noted in #10772#note-8, our isobuilders have slight differences that may explain why we see sometimes different behaviors. When we'll port our build system to Jessie, we then should reinstall then from scratch rather than simply upgrade them, to get a more deterministic behavior.


Related issues

Blocked by Tails - Bug #9262: Port our ISO build system to Jessie Resolved 04/19/2015

Associated revisions

Revision 79b7f9ca
Added by bertagaz 6 months ago

Merge remote-tracking branch 'origin/wip/11972-use-vagrant-in-jenkins' into stable

Fix-committed: #11972, #11979, #11980, #11981, #11006

History

#1 Updated by bertagaz almost 2 years ago

  • Blocked by Bug #9262: Port our ISO build system to Jessie added

#2 Updated by bertagaz almost 2 years ago

  • Related to Bug #10772: Next ISO builds fail on Jenkins when a previous job was aborted uncleanly added

#3 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

(Blocked by something that's blocked by something that will be done very late in the 2.2 cycle, if I'm lucky.)

#4 Updated by intrigeri over 1 year ago

  • Related to deleted (Bug #10772: Next ISO builds fail on Jenkins when a previous job was aborted uncleanly)

#5 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_2.3 to Tails_2.4

#6 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_2.4 to Tails_2.5

#7 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_2.5 to Tails_2.6

#8 Updated by anonym about 1 year ago

  • Target version changed from Tails_2.6 to Tails_2.7

#9 Updated by bertagaz about 1 year ago

  • Target version changed from Tails_2.7 to Tails_2.9.1

#10 Updated by anonym 11 months ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#11 Updated by intrigeri 10 months ago

  • Target version changed from Tails 2.10 to Tails_2.12

#12 Updated by bertagaz 8 months ago

  • Target version changed from Tails_2.12 to Tails_3.0

#13 Updated by intrigeri 7 months ago

  • Parent task set to #12160

I've upgraded isobuilder1.sib to Stretch, adjusted our Puppet code to support this, and adjusted our build system (48498f40a9263fe068279f084c4e541cfee684e3). So please install Stretch on them so we don't have to go through upgrades :)

#14 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.0 to Tails_3.0~rc1

#15 Updated by bertagaz 7 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50

I'm reinstalling the isobuilders with #11972 since yesterday. isobuilder3 and isobuilder4 are done, doing isobuilder2 right now. Then I'll merge the #11972 branch.

#16 Updated by bertagaz 6 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#17 Updated by bertagaz 6 months ago

  • Status changed from Fix committed to In Progress
  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 100 to 80
  • QA Check changed from Dev Needed to Ready for QA

I've reinstalled all isobuilders with the same setup than what have been done on isobuilder1.lizard (which also means upgrading to Stretch). I've also unified the puppet manifests in our main Puppet repo (modules/local/manifests/node/isobuilder.pp), and updated the install notes in the sysadmins Git repo. Please have a look and close this ticket if happy. I'll tackle the remaining Puppet stuffs in #12505.

#18 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Looks great! I'll keep filing tickets for every resulting breakage or misbehavior I notice :)

Also available in: Atom PDF