Project

General

Profile

Bug #11024

Give a direct download link for the ISO image

Added by sajolida over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
01/29/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
web/11024-direct-download
Type of work:
Website
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

We don't have any right now and that's open for debate.

The idea behind having no direct link is to avoid making it super easy to download without verifying. Still this will annoy people, see https://twitter.com/FabulousBeasts/status/692751397679427584.

An alternative possibility would be to link to the Torrent file from the release notes for example, as BitTorrent provides the same level of verification than HTTPS.


Related issues

Related to Tails - Bug #10938: Decide if want to have a download only page on /install/download Resolved 01/14/2016
Related to Tails - Bug #11269: Consider linking to /install/download from /install Resolved 03/21/2016
Blocks Tails - Feature #11494: Add a direct download link under the Install button in the Tails sidebar Rejected 05/27/2016

History

#2 Updated by sajolida over 2 years ago

  • Related to Bug #10938: Decide if want to have a download only page on /install/download added

#3 Updated by sajolida over 2 years ago

  • Assignee set to sajolida

I don't want this discussion to happen without me :)

#4 Updated by emmapeel over 2 years ago

Already two emails on frontdesk ask about this feature. They are long time Tails users, never new users.

#6 Updated by sajolida over 2 years ago

We could provide a small link to
http://dl.amnesia.boum.org/tails/stable/ labeled as "Direct download
(unsafe!)".

Pointing to an HTTP folder might help making this looks scary and for
people who know what they are doing :)

#7 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to tchou
  • QA Check set to Ready for QA
  • Feature Branch set to web/11024-direct-download

I've got something ready in web/11024-direct-download. I'm not 100% sure we should do this but quite few people are complaining and this branch has some safeguards to prevent people from switching to this too frequently.

#8 Updated by goupille over 2 years ago

there are people complaining about this every day, I think it would be a good idea to review sajolida's changes quickly...

#9 Updated by intrigeri over 2 years ago

I think it would be a good idea to review sajolida's changes quickly...

Maybe consider doing a first round of review yourself? Sounds like it will make your life easier once it's done :)

#10 Updated by goupille over 2 years ago

  • Assignee changed from tchou to sajolida

so I reviewed it, and I think it would be better, to also display this link Tor Browser users with a low security level.

#11 Updated by londonsilver over 2 years ago

if it's about forcing the user to validate:
Why not integrate into Tails installer? iso and sig need to be in same dir and if sth is wrong it just doesn't install/upgrade/clone.

Way better than pushing users to even more unsafe locations like google search.
^^ one reason why a tiny link is not enough.

Besides it is not OK to treat users like children IMO.

#12 Updated by sajolida over 2 years ago

  • Priority changed from Normal to Elevated
  • QA Check changed from Ready for QA to Dev Needed

I'll do that.

#13 Updated by sajolida over 2 years ago

Why not integrate into Tails installer? iso and sig need to be in same dir and if sth is wrong it just doesn't install/upgrade/clone.

Yes, that's #9798 but it's harder and won't work for people on Mac or
Windows until we get #7544 which is even harder.

Besides it is not OK to treat users like children IMO.

UX research proves that people are lazy, with no judgment call! We're
trying to protect them from their laziness, and it has nothing to do
with childishness.

#15 Updated by sajolida over 2 years ago

  • Priority changed from Elevated to Normal

#16 Updated by u over 2 years ago

Hi,
please add to that link the "use-mirror-pool" class. Also see #11329. Thanks!

#17 Updated by sajolida over 2 years ago

Since goupille reviewed the first iteration of this, I'll do a first
merge but leave it open.

#18 Updated by sajolida over 2 years ago

  • Blocked by Bug #11209: DAVE and BitTorrent should be first presented with equal weight even in Firefox added

#19 Updated by sajolida over 2 years ago

I worked again on this as part of #9323, see for example fd86988. I'm still missing a like in the layout for Firefox with JS but that's blocked by the discussion in #11209.

#20 Updated by sajolida over 2 years ago

  • Subject changed from Consider giving a direct download link for the ISO image to Give a direct download link for the ISO image

#21 Updated by sajolida over 2 years ago

  • Type of work changed from Discuss to End-user documentation

The decision was made a while ago.

#22 Updated by sajolida over 2 years ago

  • Related to Bug #11269: Consider linking to /install/download from /install added

#23 Updated by sajolida about 2 years ago

Two months later, I think we should do something before #11209 is resolved even though this means extra work.

#24 Updated by sajolida about 2 years ago

  • Assignee deleted (sajolida)
  • QA Check changed from Dev Needed to Ready for QA
  • Type of work changed from End-user documentation to Website

So cc7b434 is a new commit to add a link to HTTP download with OpenPGP verification when in Firefox as well. Who wants to review it?

#25 Updated by sajolida about 2 years ago

  • Blocked by deleted (Bug #11209: DAVE and BitTorrent should be first presented with equal weight even in Firefox)

#26 Updated by goupille almost 2 years ago

  • Assignee set to emmapeel

#27 Updated by sajolida almost 2 years ago

  • Blocks Feature #11494: Add a direct download link under the Install button in the Tails sidebar added

#28 Updated by emmapeel almost 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (emmapeel)

Looks good!

Still some clicks away but not so difficult.

#29 Updated by intrigeri almost 2 years ago

  • Assignee set to sajolida

#30 Updated by sajolida almost 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

So I'm merging, thanks!

Also available in: Atom PDF