Project

General

Profile

Bug #11033

Can't add an optional PGP key in WhisperBack

Added by mercedes508 almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
01/31/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
WhisperBack

Description

In Tails 2.0, when clicking on 'optional PGP key' in WhisperBack a pop-up window offers to paste either the key-ID or the public key itself.

After either copying the key itslef or its ID, clicking on 'OK' to close that pop-up and proceed further doesn't do anything.

So users can't add their keys using that feature.

History

#1 Updated by intrigeri almost 2 years ago

  • Priority changed from Normal to Elevated
  • Target version set to Tails_2.2
  • Affected tool set to WhisperBack

So users can't add their keys using that feature.

Confirmed. Bumping priority and setting a target version, since it's a regression.

Alan, do you think you'll have time to work on this soonish?

#2 Updated by alant almost 2 years ago

  • Status changed from Confirmed to In Progress

I belive I fixed this bug in WhisperBack master.

#3 Updated by alant almost 2 years ago

  • Assignee changed from alant to anonym
  • QA Check set to Ready for QA

I tested this py patching a live Tails and it works. Please review.

#4 Updated by anonym almost 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

The fix works (I had to hack WhisperBack a bit to see what the message was before encrypting :)), thanks! It's part of WhisperBack 1.7.4, which will be in Tails 2.2~rc1.

#5 Updated by anonym almost 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF