Project

General

Profile

Feature #11147

Automatically save KeePassX database after every change by default

Added by segfault over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/20/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Discuss
Blueprint:
Easy:
Affected tool:
Password Manager

Description

By default, KeePassX doesn't save changes (including new password entries) until the database is saved by the user. If KeePassX is closed with unsaved changes, it asks the user if should save the changes before closing.

Because Tails' shutdown immediately kills all running applications and doesn't halt for the "Save modified file?" dialog, I propose that we add this option to the KeePassX settings file by default. While automatically saving changes might sound dangerous, because it could save accidental changes, I don't think this would be a problem because KeePassX creates backup entries after each change by default (in the "Backup" group).

We also modify other settings in the KeePassX settings file, see config/chroot_local-includes/etc/skel/.config/keepassx/config.ini.
I would prepare a patch if you think this feature is desirable.


Related issues

Related to Tails - Bug #10061: Shutdown the GNOME session properly Rejected 08/19/2015
Related to Tails - Bug #12544: KeePassX lost the auto-save setting in Tails/Stretch Resolved 05/16/2017

Associated revisions

Revision 39c7468c (diff)
Added by segfault over 1 year ago

Automatically save KeePassX database after every change by default

Refs: #11147

History

#1 Updated by intrigeri over 1 year ago

  • Assignee set to segfault

Sounds like a good idea to me.

#2 Updated by segfault over 1 year ago

  • Status changed from New to Confirmed
  • QA Check set to Ready for QA

#3 Updated by sajolida over 1 year ago

  • Related to Bug #10061: Shutdown the GNOME session properly added

#4 Updated by sajolida over 1 year ago

  • Assignee changed from segfault to anonym
  • Target version set to Tails_2.2

Sounds good to me to. I guess this can be put in 2.2, no? So marking as "Ready for QA" and assigned to anonym, the RM.

#5 Updated by anonym over 1 year ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

This seems like a very sane default to me, and one that I'm happy to diverge from upstream for. :)

I couldn't merge your branch as-is since it contains an unrelated commit, cb0ad0b -- please compare against devel in the future before sending pull requests! In this case it's no problem, of course, since the branch is so simple, so I just cherry-picked the intended commit. Thanks for you contribution!

#6 Updated by segfault over 1 year ago

I couldn't merge your branch as-is since it contains an unrelated commit, cb0ad0b

Oops, sorry. I must have branched from the wrong branch.

please compare against devel in the future before sending pull requests!

Will do.

Thanks for you contribution!

Thanks for merging it :)

#7 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

#8 Updated by sajolida 5 months ago

  • Related to Bug #12544: KeePassX lost the auto-save setting in Tails/Stretch added

#9 Updated by sajolida 5 months ago

  • Affected tool set to Password Manager

Also available in: Atom PDF