Project

General

Profile

Bug #11348

Test Etcher, a multiplatform USB stick burner

Added by sajolida over 1 year ago. Updated 25 days ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Start date:
04/14/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Test
Blueprint:
Easy:
Affected tool:

Description

Could this replace dd graphically and on multiple platforms?

http://www.etcher.io/

First we should test whether it works in the first place, then whether it modifies the ISO image in any way.

  1. Download and verify an ISO image
  2. Burn it on a USB stick using Etcher in Windows and Mac
  3. Report a few screenshot of the process to get an idea
  4. Start from this USB stick
  5. Try to understand if Etcher does a byte-to-byte copy (like dd) or something more fancy
  6. If it's like dd, try to compare the checksum of the ISO and the resulting USB stick
  7. If it's like something else, investigate what it does, compare the boot option, the boot loader, etc.

1.png View (563 KB) muri, 04/22/2016 03:38 AM

2.png View (861 KB) muri, 04/22/2016 03:38 AM

3.png View (704 KB) muri, 04/22/2016 03:38 AM

4.png View (581 KB) muri, 04/22/2016 03:38 AM

5.png View (895 KB) muri, 04/22/2016 03:38 AM

6.png View (654 KB) muri, 04/22/2016 03:38 AM


Related issues

Related to Tails - Feature #8802: Investigate graphical tools for manual installation on Mac Resolved 02/04/2015
Related to Tails - Feature #14447: Replace UUI with Win32 Disk Imager Confirmed 08/24/2017

History

#1 Updated by sajolida over 1 year ago

  • Related to Feature #8802: Investigate graphical tools for manual installation on Mac added

#2 Updated by sajolida over 1 year ago

  • Subject changed from Test Etcher, a multiplatform USB drive burner to Test Etcher, a multiplatform USB stick burner

#3 Updated by sajolida over 1 year ago

  • Description updated (diff)

#4 Updated by sajolida over 1 year ago

  • Description updated (diff)

#5 Updated by muri over 1 year ago

  • Assignee set to muri

#7 Updated by kaboum over 1 year ago

Hey,

I tested version v1.0.0-beta.3.

  • Windows (7 x64):
    1.You have to install the software
    2.When you launch the program it ask you for admin rights
    3. You select the image iso and it select automaticaly the USB key if there is only one
    4. You click on flash
    5. Burning starts
    6. It looks like it's verifying the integrity of the image.

Process is fast, it tooks me around 04:30 min with an USB 2.0 key.

  • Debian (Sid, x64):
    1.You don't have to install it, just untar the archive and launch the bin.
    2. If you don't run it with priviledged rights, it will show you an error and you will have to run it with sudo ./etcher, it is not user friendly but it should be fixed soon: https://github.com/resin-io/etcher/issues/277
    3. Same process than Windows, select the file, they key (if there is more than one), click flash and wait.

It is faster on Debian, it tooks around 03:00 with the same usb key.

The checksum is not the same than a device flashed with dd. I think it it due to the strange things it does to the partition table.
There is not fancy bootloader, the Tails booted seems legit.

#9 Updated by muri over 1 year ago

hi, i've attached screenshots of the 6 steps of going through the process of wrting tails to an usb stick on osx.

on osx, too, you're asked for admin permissions, it was pretty fast (~ 2 minutes). in osx too, the partition has another hash than the image.

the tweets elouann posted make me a bit skeptical. as far as i can see, etcher is a frontend for etcher-cli, which has the function to write to disk in:
https://github.com/resin-io/etcher-cli/blob/master/lib/writer.js, which again uses the resin-image-writer module, which has the write function on https://github.com/resin-io-modules/resin-image-write/blob/master/lib/write.coffee

#10 Updated by sajolida over 1 year ago

  • Related to deleted (Feature #8802: Investigate graphical tools for manual installation on Mac)

#11 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • Parent task set to #8802

Thanks for the screenshots, that's really useful! I like the interface because it's simple.

Still, I wonder why the result has a different hash than the ISO. It would be good to investigate where the difference comes from.

Elouann's tweets mention 130MB of download. I see ~50MB on the Etcher website which is still quite a lot for a simple app like this (UUI is 1.1MB). I tried to open the tar.gz but the content is too weird for me to understand. There are two big binaries: app.asar (34.0MiB) and etcher (21.4MiB).

Also, both projects are almost one-man shows and less than one year old:

So, my final take on this is that it's a cool initiative, it's super cool that it's multiplatform right from the start and it could replace UUI for Windows and dd for Mac but the project it too new and green for us to consider this as a replacement right now.

Thanks to everybody who did the tests for me!

#12 Updated by sajolida over 1 year ago

  • Parent task deleted (#8802)

#13 Updated by sajolida over 1 year ago

  • Related to Feature #8802: Investigate graphical tools for manual installation on Mac added

#14 Updated by sajolida about 2 months ago

#15 Updated by sajolida about 2 months ago

  • Status changed from Resolved to Confirmed

Etcher is two years old now and still active. Worth trying again!

Let's make sure there's no regression (like no UEFI boot if using new tools)

#16 Updated by anonym about 2 months ago

  • Assignee set to sajolida
  • Target version set to Tails_3.2

Assigning to you per your promise in the notes.

#17 Updated by anonym about 2 months ago

intrigeri's remark #14447#note-3 is also relevant here.

#18 Updated by sajolida 25 days ago

  • Target version changed from Tails_3.2 to Tails_3.3

Also available in: Atom PDF