Project

General

Profile

Bug #11550

Icedove account creation not fully functional

Added by u about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
06/27/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I've tried this today on Tails 2.4:

Add email configuration for openmailbox. I enter my configurations and then tThe test with the password works.
Now I click "ready" and I get this error:

Programming bug. Assertion failed, see log.

When i close the window, my account is correctly created though.

The log said this:


-- Exception object --
+ _message (string) 'Programming bug. Assertion failed, see log.'
+ stack (string) 702 chars
+ constructor (function) 5 lines
+ message (string) 'Programming bug. Assertion failed, see log.'
+ toString (function) 4 lines
*
-- Stack Trace --
Exception@chrome://messenger/content/accountcreation/util.js:132:5
NotReached@chrome://messenger/content/accountcreation/util.js:151:3
assert@chrome://messenger/content/accountcreation/util.js:23:1
SecurityWarningDialog.prototype.needed@chrome://messenger/content/accountcreation/emailWizard.js:1753:1
SecurityWarningDialog.prototype.open@chrome://messenger/content/accountcreation/emailWizard.js:1807:18
EmailConfigWizard.prototype.onCreate@chrome://messenger/content/accountcreation/emailWizard.js:1581:7
oncommand@chrome://messenger/content/accountcreation/emailWizard.xul:1:1
MsgAccountManager@chrome://messenger/content/accountUtils.js:255:1
oncommand@chrome://messenger/content/messenger.xul:1:1
mimeEncrypt.js: module initialized

I've seen one other person reporting this on #tails.

History

#1 Updated by anonym about 2 years ago

  • Status changed from New to Confirmed
  • Assignee changed from anonym to u
  • Priority changed from Normal to Elevated
  • Target version set to Tails_2.5
  • QA Check set to Info Needed
You did not provide enough information for me to reproduce this. Please provide exact steps. I tried this:
  • Email address:
  • Password:
  • Only use secure protocols: checked
    but the account was created without any error. Possibly it's different if a password is provided, but I have none and couldn't register one. Would it be possible for me to borrow your account (i.e. there's no sensitive info there) with a temporary password? Actually, you may first want to check if the problem persists with a recent stable build which has Icedove 45esr and several fixes to the secure account creation feature: http://nightly.tails.boum.org/build_Tails_ISO_stable/lastSuccessful/archive/build-artifacts/

#2 Updated by u about 2 years ago

sent credentials in private :)

and yes, secure protocols was checked.

#3 Updated by anonym about 2 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (u)
  • % Done changed from 0 to 100

Using the credentials u provided me privately in Tails 2.4 I don't see the error trace ("programming bug") but the "Checking password" step always fails. So I have to leave it blank to get the account created. Luckily this is not the case for me in a recent stable build, presumably thanks to the fixes in the patches. => Closing!

#6 Updated by intrigeri about 2 years ago

  • QA Check deleted (Info Needed)

#7 Updated by intrigeri about 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF