Bug #11839

After automatic upgrade from Tails 2.5 to 2.6, keyboard and mouse stop working

Added by emmapeel 11 months ago. Updated 4 months ago.

Status:RejectedStart date:09/24/2016
Priority:ElevatedDue date:
Assignee:-% Done:

10%

Category:-
Target version:-
QA Check:Info Needed Blueprint:
Feature Branch: Easy:
Type of work:Research Affected tool:Upgrader

Description

Reported by several users, some even from Tails 2.6rc~1. I could not reproduce:

Steps to reproduce

- Start Tails 2.5
- Update automatically
- Restart

Keyboard and mouse don't work when in Tails Greeter, so it is impossible to log in.

The problem can be solved doing a manual upgrade:

https://tails.boum.org/doc/first_steps/upgrade/#manual


Related issues

Related to Tails - Bug #8449: Tails Upgrader fails to install some IUKs Resolved 12/16/2014
Related to Tails - Bug #12523: After automatic upgrade, keyboard and mouse do not work Rejected 05/06/2017

Associated revisions

Revision f6b28013
Added by intrigeri 6 months ago

Import tentative fix from iuk.git (refs: #8449, #11839).

Taken from branch bugfix/8449-iuk-install-robustness at
commit c92bfd7362d4beccb3feb00a735773ad361f513a.

Revision 1ab43b9e
Added by anonym 6 months ago

Revert "Import tentative fix from iuk.git (refs: #8449, #11839)."

This reverts commit f6b280136fe8fc3e3bb26979661f7d64daa008b7.

A package new tails-iuk package (2.8) with the patch applied has now
been uploaded.

History

#1 Updated by emmapeel 11 months ago

One user claims to have seen messages of 'echo - tainted' and "this has been marked as dirty " while restarting when asked during upgrade, before the memory wipe.

Then user had to shut down with the power button, and then no keyboard nor mouse.

#2 Updated by intrigeri 11 months ago

  • Assignee set to emmapeel

Reported by several users,

Did anyone reported this without having done an automatic upgrade?

some even from Tails 2.6rc~1.

Did all the ones reporting this with 2.6~rc1 also do the automatic upgrade?

The problem can be solved doing a manual upgrade

Wow, this is seriously weird. It seems to indicate that something went wrong either in our IUK, or in the automatic upgrade process. To debug this further, I'll need to see files listing from such a faulty, automatically upgraded Tails 2.6, ideally with checksums for files under the live and syslinux directories, and the content of live/Tails.module.

#3 Updated by emmapeel 11 months ago

intrigeri wrote:

Reported by several users,

Did anyone reported this without having done an automatic upgrade?

Not the ones reporting after 2.6 release.

some even from Tails 2.6rc~1.

Did all the ones reporting this with 2.6~rc1 also do the automatic upgrade?

Not sure about this, I will ask user.

The problem can be solved doing a manual upgrade

Wow, this is seriously weird. It seems to indicate that something went wrong either in our IUK, or in the automatic upgrade process. To debug this further, I'll need to see files listing from such a faulty, automatically upgraded Tails 2.6, ideally with checksums for files under the live and syslinux directories

What is the preferred command to do that?

sha1sum /media/amnesia/Tails/live/* ?

, and the content of live/Tails.module.

Got a user!

#4 Updated by intrigeri 11 months ago

What is the preferred command to do that?

sha1sum /media/amnesia/Tails/live/* ?

Whatever hash will work. So yes, this command, of course after adjusting the path to the mountpoint :)

#5 Updated by wrwerdsfgvxzc 11 months ago

What hardware were the users using? Certain machines can't handle the automatic update.

#6 Updated by intrigeri 10 months ago

Any chance we see the info requested a month ago? Otherwise, feel free to close this ticket, as it is not very useful in its current shape.

#7 Updated by emmapeel 7 months ago

I keep receiving reports about this, not many but apparently still is happening with Tails 2.9.1 for example.

If any new user experiences this, please:

Can you:

- Start another Tails, and add an administration password.
- Start Disks from Applications > Utilities -> Disks
Plug your broken Tails
- Select it from the sidebar on Disks
- Select the partition called "Tails" (NOT the one called TailsData)
- Press the 'play' button to mount the partition.

Now that is mounted, you need to run some commands and send us the output:

- cat /media/amnesia/Tails/live/Tails.module
- sha256sum /media/amnesia/Tails/live/*

Once you have this output, mail it to us at with the
reference of this ticket

#8 Updated by emmapeel 7 months ago

  • Assignee changed from emmapeel to intrigeri

Ok one user sends us (after automatic update to Tails 2.10):

root@amnesia:/home/amnesia# cat /media/amnesia/Tails/live/Tails.module
filesystem.squashfs
root@amnesia:/home/amnesia# sha256sum /media/amnesia/Tails/live/*
cbeb110bb6edc7bcd4fdc390b82157ab516bb9f0ac5a18dff7a44ba4afe5177f
/media/amnesia/Tails/live/2.10.squashfs
3c06a607a0caf37f14a0331dfe719d0b90f5f0df8873643f4c9614935a983aed
/media/amnesia/Tails/live/filesystem.packages
3ffdfc4f2a5a09a7390a1741c343fc3ccaad49062ba65ec3ad73a4d3448ad324
/media/amnesia/Tails/live/filesystem.squashfs
84da94a3328f8668e51258604c2dbf510ba21cb2271596d5ebc0130dde207707
/media/amnesia/Tails/live/initrd2.img
e4d025b2950b63e46647e86dd71be4ad5f17d6d112ed060d12a6b3aabd070286
/media/amnesia/Tails/live/initrd.img
2e23dcf5b310900d298c33d3cfb2ea091e03193b69a7d4e0eb90dd1d905a6688
/media/amnesia/Tails/live/Tails.module
92de370cee9a3a4309ab8832cde2f80a3d86db613f9fbcd7f0329ec68eadbbc4
/media/amnesia/Tails/live/vmlinuz
be4a8ef0250aeb35b40dc1708919e9a751febfac3d02dfb5fc7720fe23438cdf
/media/amnesia/Tails/live/vmlinuz2

I can forward you the contact if you want

#9 Updated by intrigeri 7 months ago

  • Target version set to Tails_2.11
  • QA Check deleted (Info Needed)

Thanks! So, Tails.module is wrong, it lacks the 2.10 SquashFS delta. So the machine starts with the kernel from 2.10, but the SquashFS that's mounted has no modules for that kernel, which explains the breakage. I think that's a duplicate of #8449. Will try to have a look during this dev cycle.

Dear help desk: this user (and presumably other affected ones) could fix their Tails device by editing live/Tails.module, and appending to it the missing line. In this case, it would be 2.10.squashfs.

#10 Updated by intrigeri 7 months ago

  • Related to Bug #8449: Tails Upgrader fails to install some IUKs added

#11 Updated by intrigeri 6 months ago

Dear Help desk, please ask all affected users to give me not only:

  • cat /media/amnesia/Tails/live/Tails.module
  • sha256sum /media/amnesia/Tails/live/*

But also:

  • ls -l /media/amnesia/Tails/live/
  • df /media/amnesia/Tails/live/
  • the date/time when the upgrade was applied

... so I can check if Tails Upgraded wrote that file at all, and whether other files are corrupted or have the wrong size (the checksum for 2.10.squashfs reported above is wrong!).

#12 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to mercedes508
  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.11 to Tails_2.12
  • % Done changed from 0 to 10
  • QA Check set to Info Needed
  • Affected tool set to Upgrader

FTR I've submitted a branch on #8449 that should fix some of these problems: I'm confident it'll solve the "upgrade process does not update Tails.module" one, but only when that's the only problem. Assuming my work is merged in time for 2.11, we'll see how it goes for the 2.11 → 2.12 upgrade.

But for example, it probably won't solve anything for people whose upgrade process went so bad that not only Tails.module was not updated, but the installed 2.10.squashfs is corrupted (or not complete), so I still need our help desk to give me the info requested above from affected people => can a help desk member take ownership of this task and assign the ticket to them? Tentatively assigning to mercedes508, who is currently on help desk duty. Feel free to self-organize within your team and determine who's in the best position to find & relay the info I need.

There won't be automatic upgrades from 2.12 to 3.0, so the best we can do at this point is to gather data and fix the problem in time for 3.0, which will fix 3.0 → 3.1 upgrades.

Bumping priority as this seems to have affected a number of people recently, and bricking Tails sticks is a serious problem.

#13 Updated by segfault 6 months ago

Intrigeri said he would work on this during the contributors meeting.

#14 Updated by intrigeri 6 months ago

Intrigeri said he would work on this during the contributors meeting.

FTR that's been done already.

#15 Updated by intrigeri 5 months ago

intrigeri wrote:

[…] so I still need our help desk to give me the info requested above from affected people => can a help desk member take ownership of this task and assign the ticket to them?

Ping?

#16 Updated by mercedes508 5 months ago

  • Assignee changed from mercedes508 to emmapeel

I'm assigning it to emmapeel who already handled a user with this problem according to this ticket.

I didn't se reports about it lately si I can't help right now.

#17 Updated by intrigeri 5 months ago

I'm assigning it to emmapeel who already handled a user with this problem according to this ticket.

Thanks!

#18 Updated by emmapeel 5 months ago

  • Assignee changed from emmapeel to intrigeri

THe thing is that I haven't got new reports on this problem during upgrade to 2.11...

#19 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to emmapeel

Sorry if I've been unclear: I need info from any affected people, even if that's about an upgrade to a version older than 2.11.

#20 Updated by emmapeel 5 months ago

Yes, but this people has already fixed their system... I haven't got a new user with this problem anymore.

#21 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (emmapeel)

OK. I'm closing this ticket as there's nothing we can do about it without having more info, and it's apparently too late to gather that info. Please file a new ticket, with the requested info, next time you get a report about it. Thanks!

#22 Updated by vfguy 4 months ago

Hello, I'm having the same problem after upgrading from 2.11 to 2.12.

No mouse or keyboard at tails greeter either in normal boot or troubleshooting mode.

I would like to assist in troubleshooting/resolving this. Please let me know. Thanks.

#23 Updated by emmapeel 4 months ago

  • Related to Bug #12523: After automatic upgrade, keyboard and mouse do not work added

#24 Updated by emmapeel 4 months ago

  • Target version deleted (Tails_2.12)

vfguy wrote:

Hello, I'm having the same problem after upgrading from 2.11 to 2.12.

No mouse or keyboard at tails greeter either in normal boot or troubleshooting mode.

I would like to assist in troubleshooting/resolving this. Please let me know. Thanks.

Great! Please see #12523 for details on what we need

Also available in: Atom PDF