Project

General

Profile

Bug #11901

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Adjust test suite to take into account that MAT does not clean PDF files anymore

Added by bertagaz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
11/08/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
test/11901-mat-does-not-clean-PDF-anymore
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

During 2.7 release cycle, Mat has been upgraded to 0.5.2-3+deb8u1, which removes PDF support.

We have a scenario testing Mat with this kind of file in our test suite, so we need to adapt it. I guess switching to some image containing EXIF metadata would be much more stable.

Associated revisions

Revision c9680228 (diff)
Added by bertagaz almost 2 years ago

Mark Mat feature as fragile.

refs: #11901

Revision 89850f86 (diff)
Added by bertagaz almost 2 years ago

Revert "Mark Mat feature as fragile."

This reverts commit c96802284b544b14ddba23d573cc532b7dec1c9c.

refs: #11901

Revision 95c6e874 (diff)
Added by anonym almost 2 years ago

Switch MAT scenario from testing PDFs to PNGs.

Because MAT doesn't clean PDFs anymore. :_(

Will-fix: #11901

Revision 991bfb2f (diff)
Added by anonym almost 2 years ago

Add "external" anti-test and test to the MAT's PNG test.

I.e. the tests are done using a tool different from MAT, the tool
being tested here.

Refs: #11901

Revision 2b2435b8
Added by intrigeri almost 2 years ago

Merge remote-tracking branch 'origin/test/11901-mat-does-not-clean-PDF-anymore' into stable (Fix-committed: #11901)

History

#1 Updated by bertagaz almost 2 years ago

  • Target version set to Tails_2.9.1
  • Feature Branch set to test/11901-mat-does-not-clean-PDF-anymore

Tagging it as @fragile meanwhile.

#2 Updated by intrigeri almost 2 years ago

  • Subject changed from Mat does not clean PDF files anymore to Adjust test suite to take into account that MAT does not clean PDF files anymore
  • Assignee set to anonym

(As part of the test suite maintenance work, and I'll do the review, as planned.)

#3 Updated by anonym almost 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

I switched to testing PNGs instead.

IIRC it was decided that you would review this, intri, but feel free to postpone it to Tails 2.10.

#4 Updated by intrigeri almost 2 years ago

  • % Done changed from 50 to 60

Code review passes.

#5 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#6 Updated by intrigeri almost 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#7 Updated by anonym almost 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF