Project

General

Profile

Bug #11913

Switch default search engine to DuckDuckGo

Added by bertagaz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
11/15/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/11913-ddg-as-default-in-tor-browser
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

Upstream Tor Browser has done that, since disconnect.me keeps on redirecting to duckduckgo and users are annoyed/scared by that. We should switch our localization extension to use duckduckgo too.


Related issues

Duplicated by Tails - Bug #11845: Replace defunct search engines in torbrowser Duplicate 09/26/2016

Associated revisions

Revision 8e6d5bc6 (diff)
Added by anonym almost 2 years ago

Tor Browser: switch to DDG as the default search engine.

This is what Tor Browser has, and Disconnect.me has been re-directing to
DDG for some time, only confusing users.

Will-fix: #11913

Revision 48295b5d (diff)
Added by anonym almost 2 years ago

Tor Browser: drop the Disconnet.me search engine plugin.

It's re-directing to DDG, which is our default, so what is the point?

Refs: #11913

Revision 1545be36 (diff)
Added by anonym almost 2 years ago

Tor Browser: switch to DDG as the default search engine.

This is what Tor Browser has, and Disconnect.me has been re-directing to
DDG for some time, only confusing users.

Will-fix: #11913

Revision fef4c9d5 (diff)
Added by anonym almost 2 years ago

Tor Browser: drop the Disconnet.me search engine plugin.

It's re-directing to DDG, which is our default, so what is the point?

Refs: #11913

Revision c13641e1 (diff)
Added by anonym almost 2 years ago

Tor Browser: localize the DDG search engine plugin.

Refs: #11913

Revision 90f31a97
Added by anonym almost 2 years ago

Merge branch 'feature/11913-ddg-as-default-in-tor-browser' into stable

Fix-committed: #11913

History

#1 Updated by bertagaz almost 2 years ago

  • Affected tool set to Browser

Note that this also means reverting 6d9e5eaf68b8a0ab1708eee9e9bf41858a19e8de

#2 Updated by elouann almost 2 years ago

  • Duplicated by Bug #11845: Replace defunct search engines in torbrowser added

#3 Updated by anonym almost 2 years ago

  • % Done changed from 0 to 30
  • Feature Branch set to feature/11913-ddg-as-default-in-tor-browser

The current branch switches to DDG, but it's not localized.

#4 Updated by anonym almost 2 years ago

  • Status changed from Confirmed to In Progress

#5 Updated by anonym almost 2 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

Now we localize (the UI only) for DDG. This branch also sneaks in a few other search plugin-related changes, in particular that "unwanted" plugins also are purged from the langpacks -- apparently they were introduced there some time ago, and since then only English locales have had the cured set of search engines. Whoops!

intrigeri, will you review'n'merge?

#6 Updated by intrigeri almost 2 years ago

intrigeri, will you review'n'merge?

I can make some room for urgent stuff tomorrow if needed, but generally it's too late for me to review 2.9 stuff.

#7 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to anonym

(Reassigning to anonym so he gets a chance to find another reviewer if my own availability is not good enough.)

#8 Updated by intrigeri almost 2 years ago

  • Assignee changed from anonym to intrigeri

I'll try to do it.

#9 Updated by intrigeri almost 2 years ago

  • Subject changed from Switch default search engine to duckduckgo to Switch default search engine to DuckDuckGo

#10 Updated by intrigeri almost 2 years ago

  • % Done changed from 50 to 60

Code review passes.

#11 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to anonym

Is it on purpose that when logging in with a non-English locale, one gets only the localized DDG? If yes, feel free to merge after running the affected automated tests (I didn't do this and I think that Jenkins doesn't either). If not, merge as well but file a ticket about it :)

#12 Updated by anonym almost 2 years ago

intrigeri wrote:

Is it on purpose that when logging in with a non-English locale, one gets only the localized DDG?

Yes -- only the UI is localized, not search results, which I think is fine.

If yes, feel free to merge after running the affected automated tests (I didn't do this and I think that Jenkins doesn't either).

Ack, thanks!

#13 Updated by anonym almost 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri also reviewed the two extra commits (772c081 and 57fd3b3) I had to push. Merged!

#14 Updated by anonym almost 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF