Project

General

Profile

Feature #11981

Feature #5630: Reproducible builds

Delete the Vagrant VM used for an ISO build once it is finished

Added by intrigeri 10 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Build system
Target version:
Start date:
11/21/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
wip/11972-use-vagrant-in-jenkins
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Description

Given #11980, this is needed to avoid wasting lots of disk space.


Related issues

Blocked by Tails - Feature #11980: Create and provision a new Vagrant VM for every ISO build Resolved 11/21/2016

Associated revisions

Revision 5b2a3af4 (diff)
Added by anonym 6 months ago

Vagrant: provision a new Vagrant VM for every ISO build.

Well, at least when there are only successes; on failure the VM is
kept and a new `rake build` will start an immediate build, reusing the
cached wiki from last time. This should be a nice trade-off between
making it fast to rebuild a branch after a failure, and maintaining
the "staticness" and "up-to-dateness" of the build environment.

Will-fix: #11980, #11981

Revision a034125e (diff)
Added by anonym 6 months ago

Vagrant: add option to force VM clean up before/after build.

I suspect this will be welcome when deploying on Jenkins.

Refs: #11972
Will-fix: #11981

Revision 79b7f9ca
Added by bertagaz 5 months ago

Merge remote-tracking branch 'origin/wip/11972-use-vagrant-in-jenkins' into stable

Fix-committed: #11972, #11979, #11980, #11981, #11006

History

#1 Updated by intrigeri 10 months ago

  • Blocked by Feature #11980: Create and provision a new Vagrant VM for every ISO build added

#2 Updated by anonym 6 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to bertagaz
  • Target version set to Tails_2.12
  • % Done changed from 0 to 50
  • Feature Branch set to wip/feature/11980-per-branch-vagrant-build-vm

#3 Updated by anonym 6 months ago

  • QA Check set to Ready for QA
  • Feature Branch changed from wip/feature/11980-per-branch-vagrant-build-vm to feature/11980-static-build-env

#4 Updated by intrigeri 5 months ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.12 to Tails_3.0~rc1

(The plan is to complete this early in the 3.0 cycle, so it doesn't get in the way of 3.0~rc1 and 3.0 final.)

#5 Updated by bertagaz 5 months ago

  • Assignee changed from bertagaz to anonym
  • QA Check changed from Ready for QA to Info Needed

I've made some test of this feature (which was merged into wip/11972-use-vagrant-in-jenkins), and it seems that it's not working as I thought.

I've set up our vagrant isobuilder in Jenkins to use the forcecleanup option, and added rake basebox:clean_all (the last one just to test, as we can't use the basebox:clean_old way yet). It appears that in the libvirt default storage there still is a disk image for the basebox:

bertagaz@isobuilder1:~$ sudo virsh vol-list default
 Name                 Path                                    
------------------------------------------------------------------------------     
 tails-builder-amd64-jessie-2017042704-feature-11980_vagrant_box_image_0.img \
 /var/lib/libvirt/images/tails-builder-amd64-jessie-2017042704-feature-11980_vagrant_box_image_0.img

Same on my local isobuilder.

Was it intended?

#6 Updated by bertagaz 5 months ago

  • Feature Branch changed from feature/11980-static-build-env to wip/11972-use-vagrant-in-jenkins

#7 Updated by anonym 5 months ago

  • Assignee changed from anonym to bertagaz
  • QA Check deleted (Info Needed)

bertagaz wrote:

It appears that in the libvirt default storage there still is a disk image for the basebox:

Ah, tha was an oversight on my part! Should be fixed with 3e574431b5d2fe154f81ef1f304e04a438e211b4.

#8 Updated by bertagaz 5 months ago

  • % Done changed from 50 to 100
  • QA Check set to Pass

anonym wrote:

Ah, tha was an oversight on my part! Should be fixed with 3e574431b5d2fe154f81ef1f304e04a438e211b4.

Indeed works better. Well done!

#9 Updated by bertagaz 5 months ago

  • Status changed from In Progress to Fix committed

#10 Updated by bertagaz 4 months ago

  • Assignee deleted (bertagaz)

#11 Updated by intrigeri 4 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF