Project

General

Profile

Bug #12001

Document that Tails requires I/O APIC being enabled in the VirtualBox VM config

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Virtualization
Target version:
Start date:
11/27/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
doc/12001-virtualbox-needs-io-apic
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

The follow-ups to various bug reports about regressions against Tails 2.7 tell us that enabling I/O APIC in the guest's motherboard settings fixes the regression many people have reported.

Side-note: I've also seen recommandations to switch the VM to 64-bit. I trust it helps (apparently it somehow enables I/O APIC) but that's sub-optimal since Tails 2.x only support the guest utilities in 32-bit VMs (#11848).


Related issues

Related to Tails - Bug #11848: Clarify that VirtualBox guest utilities only work in 32-bit virtual machines Rejected 09/28/2016
Related to Tails - Bug #11965: Tails 2.7 won't start in Virtual Box Resolved 11/19/2016

Associated revisions

Revision 6de6748a (diff)
Added by anonym about 1 year ago

Document VirtualBox users to enable I/O APIC.

Otherwise Tails won't boot properly.

Will-fix: #12001

Revision 63e98101
Added by anonym about 1 year ago

Merge remote-tracking branch 'origin/doc/12001-virtualbox-needs-io-apic' into stable

Fix-committed: #12001

History

#1 Updated by intrigeri about 1 year ago

  • Related to Bug #11848: Clarify that VirtualBox guest utilities only work in 32-bit virtual machines added

#2 Updated by intrigeri about 1 year ago

  • Related to Bug #11965: Tails 2.7 won't start in Virtual Box added

#3 Updated by intrigeri about 1 year ago

  • Target version set to Tails_2.9.1

This seems to be a commonly reported regression in Tails 2.7, so it would be nice if our doc was updated promptly. sajolida, help desk, anyone up to it?

#4 Updated by emmapeel about 1 year ago

  • Assignee set to emmapeel

i take it!

#5 Updated by spriver about 1 year ago

With VirtualBox 5.1.8-dfsg-6~bpo8+2 on Debian 8 with enabled I/O APIC Tails 2.7 and 2.7.1 is not booting for me (halting after loading the guest additions while boot time).

#6 Updated by intrigeri about 1 year ago

spriver wrote:

With VirtualBox 5.1.8-dfsg-6~bpo8+2 on Debian 8 with enabled I/O APIC Tails 2.7 and 2.7.1 is not booting for me (halting after loading the guest additions while boot time).

Please report this on #11965: this ticket is about enabling I/O APIC, which solves part of the problem, while #11965 is about finding out what else is needed to solve the problem entirely. You'll want to try adding modprobe.blacklist=vboxvideo to the kernel command-line.

#7 Updated by nikograus about 1 year ago

Don't waste your breath with poking around VirtualBox guest additions, it's not the issue. The proposed workaround of enabling the I/O APIC is perfectly right. This is purely a Linux 4.7 bug, and it's tracked here: https://patchwork.kernel.org/patch/9357253/

You'll notice that there's not a single mention of VirtualBox in that ticket, because the very same issue happens with real PCs which don't have an I/O APIC.

Please update the Known Issues page at https://tails.boum.org/support/known_issues/ accordingly so that your users know what to do if 32-bit Tails 2.7 hangs with a black screen in VirtualBox. There is only a very small performance hit by enabling this setting, which clearly is outweighed by the benefits of being able to run Tails without trouble.

#8 Updated by anonym about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from emmapeel to sajolida
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to doc/12001-virtualbox-needs-io-apic

Thanks for the explanation, nikograus!

Please review'n'merge the feature branch into the master branch. sajolida, will you take it?

#9 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to anonym

Here you go!

#10 Updated by anonym about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#11 Updated by anonym about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF