Project

General

Profile

Feature #12017

Feature #5630: Reproducible builds

Feature #11972: Switch our Jenkins ISO build system to vagrant-libvirt

Update our Vagrant ISO build basebox wrt. vagrant-libvirt

Added by intrigeri 10 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
12/04/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/11980-static-build-env
Type of work:
Sysadmin
Blueprint:
Easy:
Affected tool:

Description

If we merged #11972 as is, the builds on Jenkins would last about 20% (~17 minutes) longer. It seems that ~5 minutes, from the added build time, comes from upgrading the basebox. Let's please not do that on every ISO build on Jenkins => let's please update the basebox before we deploy #11972.

Associated revisions

Revision 6a637631 (diff)
Added by anonym 6 months ago

Vagrant: update basebox to tails-builder-amd64-jessie-2017011203+feature-11980.

This box is prepared for the wip/feature/11980-per-branch-vagrant-build-vm
Git branch.

Refs: #11980
Will-fix: #12017

History

#1 Updated by intrigeri 10 months ago

  • Target version changed from Tails_2.9.1 to Tails 2.10
  • Parent task deleted (#11972)

If this really Unparenting from #11972, that's bertagaz' current bet for solving #12009 (I don't understand why it would solve it, but if it does, fine!): slower builds would be better than broken builds. Postponing accordingly, since bertagaz has quite a bunch of high prio stuff on his 2.9 plate already.

#2 Updated by intrigeri 10 months ago

  • Parent task set to #5630

#3 Updated by intrigeri 8 months ago

  • Subject changed from Update our Vagrant ISO build basebox (2016Q4 edition) to Update our Vagrant ISO build basebox wrt. vagrant-libvirt
  • Target version changed from Tails 2.10 to Tails_2.12

#4 Updated by anonym 6 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by anonym 6 months ago

  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/11980-static-build-env

The feature branch imports such a base box.

#6 Updated by bertagaz 6 months ago

  • Target version changed from Tails_2.12 to Tails_3.0

#7 Updated by intrigeri 6 months ago

  • Parent task changed from #5630 to #11972

#8 Updated by intrigeri 5 months ago

  • Target version changed from Tails_3.0 to Tails_3.0~rc1

#9 Updated by bertagaz 5 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

There's been a basebox serial update since then while working on #11972, and #12409 will avoid the upload of a new one. Considering anonym even uploaded previously a newer basebox, let's consider this ticket as resolved.

#10 Updated by intrigeri 5 months ago

  • QA Check deleted (Pass)

https://labs.riseup.net/code/issues/12409#change-68370 says "I pushed a commit adding it, so this is fixed when we generate the next base box". I guess this doesn't change anything wrt. the outcome of this ticket, but you might want to double-check :)

#11 Updated by bertagaz 5 months ago

  • QA Check set to Pass

intrigeri wrote:

https://labs.riseup.net/code/issues/12409#change-68370 says "I pushed a commit adding it, so this is fixed when we generate the next base box". I guess this doesn't change anything wrt. the outcome of this ticket, but you might want to double-check :)

It doesn't, the error has gone in the last builds, lsof is installed.

#12 Updated by intrigeri 4 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF