Project

General

Profile

Bug #12091

torsocks prints "Failed to get capabilities of file" to stderr

Added by segfault 10 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
12/27/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Description

In 3.0~alpha1, torsocks always prints "Failed to get capabilities of file" to stderr, when used to execute a file on the FAT partition. This includes the programs we use a torsocks wrapper for, like git and wget. This can be quite annoying, especially when you want to use tab completion with git, which also results in the error message being printed.

The reason is that since torsocks 2.2.0, which is the version in Stretch, torsocks calls `getcap` on the file to be executed [1]. FAT does not support file capabilties, thus the error message.

[1] https://github.com/dgoulet/torsocks/blob/master/src/bin/torsocks.in#L147


Related issues

Blocks Tails - Bug #12205: Confusing error message when (successfully) cloning Git repos over HTTPS Resolved 02/01/2017

History

#1 Updated by intrigeri 10 months ago

  • Assignee set to segfault
  • Target version set to Tails_3.0

The reason is that since torsocks 2.2.0, which is the version in Stretch, torsocks calls `getcap` on the file to be executed [1]. FAT does not support file capabilties, thus the error message.

Care to report this upstream? If there's no good reason to forward this message to the user, maybe it should be hidden?

#2 Updated by segfault 10 months ago

  • Assignee deleted (segfault)
  • Target version deleted (Tails_3.0)

Care to report this upstream? If there's no good reason to forward this message to the user, maybe it should be hidden?

Done. Upstream ticket: https://trac.torproject.org/projects/tor/ticket/21088

#3 Updated by intrigeri 10 months ago

  • Assignee set to intrigeri
  • Target version set to Tails_3.0

Care to report this upstream? If there's no good reason to forward this message to the user, maybe it should be hidden?

Done. Upstream ticket: https://trac.torproject.org/projects/tor/ticket/21088

Thanks! I'll take care of it from now on (unless you prefer to do it yourself, in which case please reassign the ticket to you :)

#4 Updated by intrigeri 10 months ago

  • Status changed from New to Confirmed

#5 Updated by emmapeel 9 months ago

I get this error message:

Failed to get capabilities of file `/usr/lib/wget/wget' (Operation not supported)

running wget with Tails 2.10~rc1

#6 Updated by intrigeri 9 months ago

BTW I suspect the ticket description is slightly wrong: our root filesystem is SquashFS, not FAT.

#7 Updated by emmapeel 8 months ago

  • Duplicated by Bug #12205: Confusing error message when (successfully) cloning Git repos over HTTPS added

#8 Updated by u 7 months ago

  • Assignee changed from intrigeri to u

#9 Updated by u 7 months ago

  • Status changed from Confirmed to Resolved

This is now fixed by our own package.
Tested wget, git clone and git tab completion in Tails3.0beta3-feature-stretch.
https://deb.tails.boum.org/pool/main/t/torsocks/ version 2.2.0-1.0tails1.dsc

It has been git branched and tagged in the Debian repository, branch tails/master.
This branch and package can be removed as soon as there is a new version available in Debian.

#10 Updated by intrigeri 7 months ago

  • Duplicated by deleted (Bug #12205: Confusing error message when (successfully) cloning Git repos over HTTPS)

#11 Updated by intrigeri 7 months ago

  • Blocks Bug #12205: Confusing error message when (successfully) cloning Git repos over HTTPS added

Also available in: Atom PDF