Project

General

Profile

Feature #12160

Upgrade all systems to Stretch

Added by intrigeri over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
01/27/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

  • buse
  • ecours
  • *.lizard
  • lizard
  • sib

I'll probably use sib as a dev/testing platform for this project, at least for the services it runs.

In theory this effort can very well be spread from now to ~2019 or even 2020, and we may decide to stick to Jessie LTS on some systems (if that's an option with Puppet 4), but we have plenty of good reasons to want to run current Debian on most of our systems.


Subtasks

Bug #11006: Reinstall Lizard's isobuilders from scratchResolved

Feature #11739: Upgrade our isotesters to StretchResolved

Bug #12256: puppet-nfs tries to start nfs-common.service which is masked on StretchResolved

Bug #12258: Jenkins is not creating jobs for new branchesResolved

Bug #12463: MariaDB backups on buse, ecours and puppet-git.lizard trigger useless/noisy email notifications since the upgrade to StretchResolvedintrigeri

Feature #12468: Rebase isotesters' custom QEMU on 1:2.8+dfsg-4Resolved

Bug #12589: Enabling LUKS-backed PVs on lizard takes ages in the initramfsResolvedintrigeri

Bug #13138: Cucumber segfaults on Jenkins isotestersResolved

Feature #13528: Upgrade buse to StretchResolvedintrigeri

Feature #13529: Upgrade puppet-git.lizard to StretchResolvedintrigeri


Related issues

Blocks Tails - Feature #13284: Core work 2017Q2→2019Q1: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress

Upgraded a few VMs, will do more today.

#2 Updated by intrigeri over 1 year ago

Left to do:

  • buse: should be straightforward, modulo MySQL → MariaDB
  • ecours: should be straightforward, modulo MySQL → MariaDB
  • lizard: should be straightforward
  • isobuilderN.lizard: should be trivial, tracked on #11006
  • isotesterN.lizard
  • puppet-git.lizard
  • whisperback.lizard: it seems that Postfix multi-instances support has changed a bit on Stretch

#3 Updated by intrigeri about 1 year ago

Upgraded lizard.

#4 Updated by bertagaz about 1 year ago

intrigeri wrote:

Upgraded lizard.

Woot, congrats!

#5 Updated by intrigeri about 1 year ago

One more done, left to do:

  • buse: should be straightforward, modulo MySQL → MariaDB
  • puppet-git.lizard

#6 Updated by intrigeri about 1 year ago

  • Target version changed from 2017 to Tails_3.2

#7 Updated by intrigeri about 1 year ago

I want this to be done by the end of September, and ideally end of July, so I can start focussing on #11680 soon.

#8 Updated by intrigeri about 1 year ago

  • Blocks Feature #13284: Core work 2017Q2→2019Q1: Sysadmin (Adapt our infrastructure) added

#9 Updated by intrigeri 12 months ago

Tentatively scheduled a sprint to complete this: September 6-7.

#10 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Resolved

Completed :)

Also available in: Atom PDF