Bug #12217

GNOME freezes with Intel GM965/GL960 Integrated Graphics

Added by goupille about 2 months ago. Updated 19 days ago.

Status:ResolvedStart date:02/08/2017
Priority:ElevatedDue date:
Assignee:-% Done:

100%

Category:Hardware support
Target version:Tails_2.11
QA Check:Pass Blueprint:
Feature Branch:bugfix/12217-linux-4.8.15 Easy:
Type of work:Code Affected tool:

Description

a user reported this problem :

since upgrading to 2.10, after enabling persistence gnome doesn't start and the computer freeze. if the persistence is ot enabled, there are no issue.
the user reproduced the error after reconfiguring the persistent volume, and with a brand new installation, and with a brand new USB stick.
the user managed to get some debugging info before the freeze and I found that in the logs :

localhost.localdomain kernel: [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:26:pipe A] flip_done timed out

a bug report with the same error message was posted here :

https://bugzilla.redhat.com/show_bug.cgi?id=1398424

Associated revisions

Revision e4ceebcf
Added by anonym 24 days ago

Enable the bugfix-12217-linux-4.8.15 APT overlay.

Will-fix: #12217

Revision d484e036
Added by anonym 24 days ago

Freeze exception: install Linux 4.8.15 from our repo.

Will-fix: #12217

Revision f95a8ea0
Added by intrigeri 23 days ago

Merge remote-tracking branch 'origin/bugfix/12217-linux-4.8.15' into stable (fix-committed: #12217)

Revision 12c31a71
Added by intrigeri 20 days ago

Document known issue and its workaround (refs: #12217).

History

#1 Updated by intrigeri about 2 months ago

  • Category set to Hardware support
  • Status changed from New to Confirmed
  • Target version set to Tails_2.11
  • Type of work changed from Research to Code

According to that Red Hat bug report, this is fixed in Linux 4.8.13. Tails 2.10 ships 4.8.11, but jessie-backports now has 4.8.15. I think we should upgrade to the latest 4.8 kernel from jessie-backports, via our freeze exception process, in Tails 2.11 (if we don't go for 4.9 i.e. #12122, of course, but that's unlikely so IMO we should not block on it). anonym, what do you think?

#2 Updated by intrigeri about 2 months ago

  • Priority changed from Normal to Elevated

(Regression on hardware that was previously supported.)

#3 Updated by intrigeri 25 days ago

  • Subject changed from Gnome freezes with Intel GM965/GL960 Integrated Graphics to GNOME freezes with Intel GM965/GL960 Integrated Graphics

#4 Updated by intrigeri 25 days ago

I gave up on #12122 for Tails 2.11 so IMO we should upgrade to the latest 4.8.x that's ever been in jessie-backports, as I proposed above. However, jessie-backports does not carry 4.8.x anymore, so we need to import it either from our APT snapshots (if it's still somewhere in there) or from snapshots.d.o.

anonym, can you take care of this? If you want me to handle it, please let me know ASAP (ideally I would have wanted to know weeks ago, but I can still make some room for it over the week-end).

#5 Updated by anonym 25 days ago

I take it!

#6 Updated by anonym 24 days ago

  • Status changed from Confirmed to In Progress

#7 Updated by anonym 23 days ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12217-linux-4.8.15

Sadly all Jenkins test runs so far errored out before even starting due to #12259. I did build a "pre-2.11" branch that included all 2.11 branches not merged yet, including this one, and I saw no problems while using it (although I was mostly rebooting to test the issue with the "Learn more" button in our notifications).

#8 Updated by intrigeri 23 days ago

  • % Done changed from 50 to 60

Code review passes.

#9 Updated by intrigeri 23 days ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#10 Updated by intrigeri 23 days ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Yeah!

#11 Updated by cypherpunks 20 days ago

This bug is still present in Tails 2.11.
It is not fixed. Please reopen the bug.

Without persistence configured, the startup
and login is still slower, and freezes occur
when starting GNOME control center or Totem.
Many users with GM965/GL960 GPU affected.

More information:
https://bugzilla.kernel.org/show_bug.cgi?id=187001
https://bbs.archlinux.org/viewtopic.php?id=218581

Adding "video=SVIDEO-1:d" to the startup options
works around the bug, everything works then.
However, this will make the SVIDEO port unusable.
I think the SVIDEO port is hardly useful in the
context of Tails, so this may be a reasonable workaround
until a fixed kernel is released (none exists yet).
This work around is taken from the second link above.

#12 Updated by intrigeri 20 days ago

Adding "video=SVIDEO-1:d" to the startup options works around the bug, everything works then.

Documented this on the "known issues" page, thanks!

I'm not reopening this ticket as the problem is well tracked upstream already, and it's definitely not something we're going to fix ourselves.

#13 Updated by anonym 19 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF