Project

General

Profile

Feature #12242

Adjust to Icedove → Thunderbird

Added by intrigeri about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
02/16/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
tails:feature/11712-thunderbird t-p-s:master
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

https://lists.debian.org/debian-devel-announce/2017/02/msg00004.html has the details. We probably need to at least:

  • drop the Claws Mail migration stuff that's going to complicate things too much
  • move and adjust any existing persistent ~/.icedove in live-persist, reusing code from the /usr/bin/thunderbird wrapper
  • convert any existing persistent setting for ~/.icedove in live-persist
  • adjust everything that's about icedove in our config tree
  • adjust our doc, including: rename pages, add redirects, mention the rename
  • adjust our test suite
  • mention the rename in the release notes

Beware, the packaging the config folder layout will change again


Related issues

Related to Tails - Bug #12734: Thunderbird doesn't start if ~/.icedove exists and is empty Resolved 06/19/2017

Associated revisions

Revision e0b8ef9f (diff)
Added by anonym 11 months ago

Enable the feature-11712-thunderbird APT overlay.

This will install thunderbird 1:45.8.0-3+tails2 built for amd64 on
Debian Stretch. Naturally it is a first step for the Icedove →
Thunderbird migration as well. And this package contains an AppArmor
profile (unlike the Debian Jessie package).

Refs: #12242
Will-fix: #11712, #11973

These packages also has the patch from the following upstream ticket
applied:

https://bugzilla.mozilla.org/show_bug.cgi?id=1281959

We enable browser.download.forbid_open_with so the "Open with..."
option is hidden in the attachment download dialog, since
Thunderbird's AppArmor profile does not allow starting applications in
Tails.

Refs: #11964

Revision c38eb0f0 (diff)
Added by anonym 11 months ago

Do most of the Icedove → Thunderbird migration.

This is just a massive 's/Icedove/Thunderbird/' both in terms of
content and filenames. No logic is changed, which should ease
reviewing of this massive commit.

Will-fix: #12242

Revision f5e45ff0 (diff)
Added by anonym 11 months ago

Test suite: deal with Icedove → Thunderbird migration.

Note that we now need secrets for "Thunderbird".

Will-fix: #12242

Revision a1d8826e (diff)
Added by anonym 11 months ago

Thunderbird: migrate Icedove persistent data to Thunderbird.

Also, tails-persistence-setup 1.1.8-1 has been uploaded to our APT
repo, which has adjusted for this migration.

Will-fix: #12242

Revision cc3b16ea (diff)
Added by intrigeri 11 months ago

Disable the Thunderbird AppArmor profile (refs: #11712, #12242, #11973, #11964).

The corresponding documentation is missing and I haven't seen this coordinated
with our tech writers:

I'd rather not break parts of the UX without a clear plan to explain
it to our users.

Revision bd903d7e
Added by intrigeri 11 months ago

Merge branch 'feature/11712-thunderbird' into feature/stretch (Fix-committed: #11712, #12242)

History

#1 Updated by intrigeri about 1 year ago

  • Description updated (diff)

#2 Updated by intrigeri about 1 year ago

thunderbird 1:45.8.0-2 made it into testing.

#3 Updated by intrigeri about 1 year ago

  • Assignee set to anonym
  • Target version changed from Tails_3.0 to Tails_3.0~rc1

Wanna take it?

#4 Updated by sajolida 12 months ago

Then reassign it to me so I can update the doc but it should be quick.

#5 Updated by anonym 11 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to tails:feature/11712-thunderbird t-p-s:master

I believe all migrations (code, use docs, design docs, release process, persistence) is fixed now.

#6 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Info Needed

Thanks! I see that #11964 has the same topic branch. So, just to clarify: is #12242 blocked by #11964 in any way?

#7 Updated by intrigeri 11 months ago

  • QA Check changed from Info Needed to Ready for QA

#8 Updated by intrigeri 11 months ago

  • Assignee changed from anonym to intrigeri

in

#9 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed

I see no change in t-p-s:master. Forgot to push?

#10 Updated by anonym 11 months ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

I see no change in t-p-s:master. Forgot to push?

Yes, sorry! Now pushed!

#11 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Ready for QA to Dev Needed
  • There's still a link to https://tails.boum.org/doc/anonymous_internet/claws_mail_to_icedove. Rename and add redirect?
  • I see 'Note that we now need secrets for "Thunderbird"'; please file a sysadmin ticket for me to adjust our infra accordinly… or keep supporting the old name?
  • wrt. b3abf4e5f57d31f59ad34c4f71188fb57879b65f: this only works well if there's at least one persistence.conf, which is why we used ls previously. I expect the updated code will still work, but will spit errors to STDERR when persistence is disabled, correct? I'm no big fan of this change.
  • Given the AppArmor "open attachments" thing is not ready, is Apparmor-hide-open-attachment.patch. the right thing to do?
  • Care to rewrite or comment sed -i "\_^$(escape '._' "${PRESET}")\s_d" "${CONFIG}"? I gave up trying to understand it :/

Other than than, code review passes at 5d848fb956b4628ee79006a2a994d212b69fca48 :)

#12 Updated by anonym 11 months ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 50 to 60
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

We agreed off-band to simply drop the migration from Claws Mail (we dropped it almost 1½ years ago).

  • I see 'Note that we now need secrets for "Thunderbird"'; please file a sysadmin ticket for me to adjust our infra accordinly… or keep supporting the old name?

Both are supported at the same time. If you keep your checkout of our shared secrets repo up-to-date you already have the new secrets. Is our infra not automatically doing that?

  • wrt. b3abf4e5f57d31f59ad34c4f71188fb57879b65f: this only works well if there's at least one persistence.conf, which is why we used ls previously. I expect the updated code will still work, but will spit errors to STDERR when persistence is disabled, correct? I'm no big fan of this change.

Argh, of course. Reverted!

  • Given the AppArmor "open attachments" thing is not ready, is Apparmor-hide-open-attachment.patch. the right thing to do?

Well, it will make it easier to test whatever is cooked up for #11964 since no new thunderbird must be built (so it can be tested live on e.g. 3.0~rc1). Also, note that the patch result is the current upstream code, and it doesn't seem to have broken neither Thunderbird nor Firefox.

  • Care to rewrite or comment sed -i "\_^$(escape '._' "${PRESET}")\s_d" "${CONFIG}"? I gave up trying to understand it :/

See 225730198e.

Other than than, code review passes at 5d848fb956b4628ee79006a2a994d212b69fca48 :)

Thanks for the review!

#13 Updated by anonym 11 months ago

anonym wrote:

intrigeri wrote:

  • I see 'Note that we now need secrets for "Thunderbird"'; please file a sysadmin ticket for me to adjust our infra accordinly… or keep supporting the old name?

Both are supported at the same time. If you keep your checkout of our shared secrets repo up-to-date you already have the new secrets. Is our infra not automatically doing that?

Tests on Jenkins are failing because we don't do this there, it seems. Filed #12559.

#14 Updated by intrigeri 11 months ago

Code review passes at d7ec23d7215204036bf8cb79f9bf18a535c22131. Will now build and test!

#15 Updated by intrigeri 11 months ago

Passes thunderbird.feature locally. Will now exercise the AppArmor profile a bit, with and without persistence.

#16 Updated by intrigeri 11 months ago

I'll merge this with the AppArmor profile disabled.

#17 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#18 Updated by intrigeri 11 months ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#19 Updated by intrigeri 11 months ago

  • Status changed from Fix committed to Resolved

#20 Updated by intrigeri 4 months ago

  • Related to Bug #12734: Thunderbird doesn't start if ~/.icedove exists and is empty added

Also available in: Atom PDF