Project

General

Profile

Feature #12263

Remove I2P

Added by anonym 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/25/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/12263-remove-i2p
Type of work:
Code
Blueprint:
Easy:
Affected tool:
I2P

Related issues

Related to Tails - Bug #11276: Decide what to do wrt. I2P Resolved 03/23/2016
Related to Tails - Feature #12265: Publicly announce the removal of I2P Resolved 02/28/2017

Associated revisions

Revision e9d02049 (diff)
Added by anonym 7 months ago

Completely remove I2P.

We have decided to remove I2P (Refs: #11276) due to our failure of
finding someone interested in maintaining it in Tails.

Will-fix: #12263

Revision 7f786cb5 (diff)
Added by intrigeri 7 months ago

Drop the "I2P will be removed in Tails 2.12" notification (refs: #12263).

Revision dce7bf4e (diff)
Added by anonym 6 months ago

Test suite: mark i2p.feature as @fragile to disable it.

One test is failing and polluting our cucumber results needlessly
since I2P will not be in Tails 3.0 (refs: #12263).

Revision 28cf4852
Added by intrigeri 6 months ago

Merge remote-tracking branch 'origin/feature/12263-remove-i2p' into feature/stretch (refs: #12263).

Revision 1e23450f
Added by anonym 6 months ago

Merge remote-tracking branch 'origin/feature/12263-remove-i2p' into devel

Fix-committed: #12263

History

#1 Updated by anonym 7 months ago

  • Related to Bug #11276: Decide what to do wrt. I2P added

#2 Updated by anonym 7 months ago

  • Related to Feature #12265: Publicly announce the removal of I2P added

#3 Updated by anonym 7 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 40
  • QA Check set to Info Needed
  • Feature Branch set to feature/12264-remove-i2p

Let's see what Jenkins thinks.

#4 Updated by anonym 7 months ago

  • Feature Branch changed from feature/12264-remove-i2p to feature/12263-remove-i2p

Whoops, I had named the branch incorrectly. Pushed a correctly named one and deleted the old one.

#5 Updated by anonym 7 months ago

  • QA Check changed from Info Needed to Ready for QA

#6 Updated by intrigeri 6 months ago

  • % Done changed from 40 to 50

Fixed the branch, now running a few builds & tests. Can I merge myself if Jenkins is happy?

#7 Updated by anonym 6 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Your fixups look good to me! Bye bye I2P!

#8 Updated by anonym 5 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF