Project

General

Profile

Bug #12269

"Tor is not ready" should not pop up when opening local documentation

Added by sajolida 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/27/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/12271-i2p-removal-notification
Type of work:
Code
Blueprint:
Easy:
Affected tool:
Browser

Related issues

Related to Tails - Feature #12251: Clarify error message when the Unsafe Browser was launch without network connection Confirmed 02/18/2017
Related to Tails - Bug #8061: Remove "Tor is not ready" popup when launching the Tor Browser Confirmed 10/11/2014
Blocks Tails - Feature #12193: Notify the user when their 32-bit computer won't work with Tails 3.0 Resolved 01/30/2017

Associated revisions

Revision a9b7daa7 (diff)
Added by anonym 7 months ago

Tor Browser: don't show offline warning when opening local documentation.

Will-fix: #12269

Revision 00acdc47 (diff)
Added by anonym 7 months ago

Avoid full Tor bootstraps in two scenarios that can be offline.

IIRC the reason we plugged the network in these scenarios was to avoid
the "Tor is not ready" prompt, but (refs: #12269) is now fixed, so it
will not be shown.

Revision d21e11ae
Added by intrigeri 7 months ago

Merge remote-tracking branch 'origin/feature/12271-i2p-removal-notification' into stable (Fix-committed: #12271, #12269).

History

#1 Updated by intrigeri 7 months ago

  • Related to Feature #12251: Clarify error message when the Unsafe Browser was launch without network connection added

#2 Updated by intrigeri 7 months ago

  • Related to Bug #8061: Remove "Tor is not ready" popup when launching the Tor Browser added

#3 Updated by intrigeri 7 months ago

This is almost a duplicate (or rather a subset) of #8061. Can you please merge them somehow?

#4 Updated by anonym 7 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to anonym
  • Target version set to Tails_2.11
  • % Done changed from 0 to 40
  • QA Check set to Info Needed
  • Feature Branch set to feature/12271-i2p-removal-notification

intrigeri wrote:

This is almost a duplicate (or rather a subset) of #8061. Can you please merge them somehow?

I want this fixed in Tails 2.11 (due to #12271 and #12193) and have already implemented a fix in the feature branch. I won't look further into #8061, however, so I think it's best if we treat them separately.

Let's see what Jenkins thinks.

#5 Updated by anonym 7 months ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 40 to 50
  • QA Check changed from Info Needed to Ready for QA
  • Type of work changed from Research to Code

Only unrelated issues on Jenkins.

#6 Updated by intrigeri 7 months ago

  • Blocks Feature #12193: Notify the user when their 32-bit computer won't work with Tails 3.0 added

#7 Updated by intrigeri 7 months ago

  • % Done changed from 50 to 60

Code review passes.

#8 Updated by intrigeri 7 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#9 Updated by intrigeri 7 months ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#10 Updated by anonym 7 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF