Bug #12298

Can't build the devel branch due to virtualbox-guest-dkms incompatibility with Linux 4.9

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:ResolvedStart date:03/05/2017
Priority:HighDue date:
Assignee:-% Done:

100%

Category:Virtualization
Target version:Tails_2.12
QA Check: Blueprint:
Feature Branch: Easy:
Type of work:Code Affected tool:

Description

I'll see if pulling vbox-dkms from sid is enough. if not, I'll disable the vbox dkms hook for now. and then we have a full cycle to decide what we do for 2.12 (https://tails.boum.org/contribute/meetings/201703/#index4h2 might help), between a) prepare a custom backport; and b) give up.


Related issues

Related to Tails - Bug #12307: devel branch lacks virtualbox-guest-x11 Resolved 03/08/2017
Blocks Tails - Feature #12089: Enable the kernel page allocator poisoning Resolved 12/27/2016
Blocks Tails - Bug #12218: AMD graphics regression since Tails 2.10 Resolved 02/09/2017

Associated revisions

Revision 1123e45a
Added by intrigeri 5 months ago

Install virtualbox-guest-* from sid (refs: #12298).

The version currently in jessie-backports is not compatible with Linux 4.9,
and there's basically no chance that it gets updated (the maintainer
asked for them to be removed from jessie-backports).

Revision 1fe3bb4b
Added by intrigeri 5 months ago

Don't install virtualbox-guest-x11 (refs: #12298).

None of our two options work:

  • virtualbox-guest-x11 5.1.14 from sid depends on a newer xserver-xorg-core
    than what we have in jessie(-backports)
  • virtualbox-guest-x11 5.1.8 from jessie-backports is not co-installable with
    virtualbox-guest-utils (5.1.14) from sid, that we need to install
    virtualbox-guest-dkms (5.1.14) from sid, that we need to run Linux 4.9.

Presumably, a custom backport of src:virtualbox could address all this. At this
point it's unclear whether we can/should/want to commit to maintain that: see
"Decide whether we can drop DKMS modules support" in
https://tails.boum.org/contribute/meetings/201703/

Revision 81e66236
Added by intrigeri 4 months ago

Revert "Don't install virtualbox-guest-x11 (refs: #12298)."

This reverts commit 1fe3bb4bbcefbc2308b716247b2971f3b8b7fb4f.

History

#1 Updated by intrigeri 5 months ago

  • Blocks Feature #12089: Enable the kernel page allocator poisoning added

#2 Updated by intrigeri 5 months ago

  • Blocks Bug #12218: AMD graphics regression since Tails 2.10 added

#3 Updated by intrigeri 5 months ago

  • Priority changed from Elevated to High

#4 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Fixed the FTBFS but I had to drop virtualbox-guest-x11. Next step is to test what's the impact for VirtualBox guests (iirc this should not harm 32-bit ones that have the kernel modules, but it might be that 64-bit guests can't start X anymore).

#6 Updated by intrigeri 5 months ago

  • % Done changed from 10 to 50

intrigeri wrote:

Fixed the FTBFS but I had to drop virtualbox-guest-x11. Next step is to test what's the impact for VirtualBox guests (iirc this should not harm 32-bit ones that have the kernel modules, but it might be that 64-bit guests can't start X anymore).

Both 32-bit and 64-bit guests work for me, but display is limited to 1024x768. If it were broken more severely I would look into a backport, but given it mostly works I'll document this known issue and move on, if anonym agrees.

#7 Updated by intrigeri 5 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Info Needed

intrigeri wrote:

Both 32-bit and 64-bit guests work for me, but display is limited to 1024x768. If it were broken more severely I would look into a backport, but given it mostly works I'll document this known issue and move on, if anonym agrees.

Do you?

#8 Updated by anonym 5 months ago

intrigeri wrote:

intrigeri wrote:

Fixed the FTBFS but I had to drop virtualbox-guest-x11. Next step is to test what's the impact for VirtualBox guests (iirc this should not harm 32-bit ones that have the kernel modules, but it might be that 64-bit guests can't start X anymore).

Both 32-bit and 64-bit guests work for me, but display is limited to 1024x768. If it were broken more severely I would look into a backport, but given it mostly works I'll document this known issue and move on, if anonym agrees.

I think it's ok, but I think we should at least do a low-effort try with the backports to get the x11 drivers before we release.

#9 Updated by intrigeri 5 months ago

  • Assignee changed from anonym to intrigeri
  • QA Check deleted (Info Needed)

anonym wrote:

I think it's ok, but I think we should at least do a low-effort try with the backports to get the x11 drivers before we release.

OK. Asked the maintainer to push his backport to the packaging Git repo. Will file another ticket to track this, as what this one is about has been fixed.

#10 Updated by intrigeri 5 months ago

  • Related to Bug #12307: devel branch lacks virtualbox-guest-x11 added

#11 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

#12 Updated by intrigeri 5 months ago

#12307 tracks the follow-ups.

Also available in: Atom PDF