Project

General

Profile

Feature #12348

Feature #5630: Reproducible builds

Review'n'merge the reproducible builds branch into feature/stretch

Added by intrigeri about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/15/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/5630-deterministic-builds
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #11983: Check if the test suite has more failures on the reproducible ISO Resolved 11/21/2016

Associated revisions

Revision a829b391
Added by anonym 11 months ago

Merge remote-tracking branch 'origin/bugfix/11971-fontconfig-cache-in-iso' into feature/stretch

Fix-committed: #11971, #12348

History

#1 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 20
  • Feature Branch set to feature/5630-deterministic-builds

I'm happy with the current state of the branch at bdacff0e351646086685e623ab6b32fd329cb967. Please review'n'merge into feature/stretch if happy with it too :)

#2 Updated by intrigeri about 1 year ago

It would probably be a good idea to have a look at #11983#note-4 first though: we don't want to break the test suite on feature/stretch right now.

#3 Updated by intrigeri about 1 year ago

  • Blocked by Feature #11983: Check if the test suite has more failures on the reproducible ISO added

#4 Updated by intrigeri about 1 year ago

I would love to merge this in time for Tails 3.0~beta4, that I intend to build around April 16-17. Now, we need to take care of #11983 first (and possibly adjust our isotesters' setup accordingly). Does it sound realistic to you?

#5 Updated by anonym about 1 year ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 20 to 50

Code review passes! I pushed an untested commit that should repair offline mode building vs the dependency on NTP. Not sure if that breaks the use of TAILS_DATE_OFFSET in offline mode, bit I guess there was a reason for introducing NTP in the same commit?

#6 Updated by intrigeri about 1 year ago

Code review passes!

:)

I might merge this into feature/stretch today or tomorrow, depending on the outcome of #11983. We'll see!

I pushed an untested commit that should repair offline mode building vs the dependency on NTP.

Looks good.

Not sure if that breaks the use of TAILS_DATE_OFFSET in offline mode,

I don't think it will break it. We'll see.

I guess there was a reason for introducing NTP in the same commit?

Yes, when introducing stuff about the build time, I wanted to ensure that the build really happens with the expected time, i.e. the correct current time (when TAILS_DATE_OFFSET is not set) or something based on the correct current time (when TAILS_DATE_OFFSET is set), instead of "whatever time the VM believes it is" :)

#7 Updated by intrigeri 11 months ago

  • Target version set to Tails_3.0~rc1

The current plan for 3.0~rc1 is to merge bugfix/11971-fontconfig-cache-in-iso, which won't produce reproducible ISOs due to #12567, but would be a great step forward.

#8 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to anonym

Please review'n'merge the branch for #11971 and then mark this ticket as fix committed. We'll use other tickets for other related stuff we want to merge in 3.0 final.

#9 Updated by anonym 11 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#10 Updated by intrigeri 11 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF