Project

General

Profile

Bug #12405

DAVE: bump the mirrors.json size limit

Added by intrigeri over 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
Start date:
03/28/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
mirror-pool-dispatcher:bugfix/11735-mirror-pool-size
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Verification Extension

Description

As seen on #11735#note-13 the size limit is too low. This problem was temporarily workaround'ed, but it'll come up again. mirror-pool-dispatcher:bugfix/11735-mirror-pool-size fixes this. Once this is merged we need a new DAVE release with the embedded copy of m-p-d updated.


Related issues

Blocked by Tails - Bug #11735: Tails-Upgrader "cannot choose a download server" Resolved 08/26/2016

Associated revisions

Revision f40b7e0a (diff)
Added by intrigeri 8 months ago

mirror-pool-dispatcher: bump maximum expected mirrors.json size to 32 KiB (refs: #12405)

This is supposed to have been done in
94f7a2318e03ab9d16102992f0e87050e62a53a3 already
but apparently the merge c5eeb2b480463b15a56f9753a3472b73322dc223
dropped this change for some reason.

History

#1 Updated by intrigeri over 1 year ago

  • Blocked by Bug #11735: Tails-Upgrader "cannot choose a download server" added

#2 Updated by anonym over 1 year ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check set to Pass

Forgot to close this one when closing #11735.

#3 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

#4 Updated by intrigeri over 1 year ago

  • Status changed from Resolved to Confirmed
  • Assignee set to anonym
  • Target version changed from Tails_2.12 to Tails_3.0~rc1
  • % Done changed from 100 to 0
  • QA Check deleted (Pass)

Wait, was a new DAVE released?

#5 Updated by anonym over 1 year ago

intrigeri wrote:

Wait, was a new DAVE released?

Nope! Note that I have no idea of how these things are connected yet and apparently I was too hasty on this one. Sorry!

#6 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_3.0~rc1 to Tails_3.0

#7 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.0 to Tails_3.1

#8 Updated by anonym about 1 year ago

  • Target version changed from Tails_3.1 to Tails_3.2

#9 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.2 to Tails_3.3

I suggest you ignore DAVE until the 3.2 release and then put it on your list of top priorities for the 3.3 cycle.

#10 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.3 to Tails_3.5

(making anonym's plate lighter; this can wait a bit more)

#11 Updated by intrigeri 10 months ago

  • Affected tool changed from Download and Verification Extension to Verification Extension

#12 Updated by anonym 9 months ago

  • Assignee changed from anonym to sajolida

#13 Updated by sajolida 8 months ago

  • Parent task set to #12328

#14 Updated by u 8 months ago

intrigeri wrote:

As seen on #11735#note-13 the size limit is too low. This problem was temporarily workaround'ed, but it'll come up again. mirror-pool-dispatcher:bugfix/11735-mirror-pool-size fixes this. Once this is merged we need a new DAVE release with the embedded copy of m-p-d updated.

The new DAVE does not use an embedded copy of the mirror-pool-dispatcher anymore as far as I know.
Thus, it would be sufficient to merge this change and push it to our website, which the new extension relies upon. Has somebody reviewed this code? If not, let's try to assign this ticket to somebody who can review it? Foundations Team?

#15 Updated by intrigeri 8 months ago

  • Assignee changed from sajolida to u

Thus, it would be sufficient to merge this change and push it to our website, which the new extension relies upon.

ACK

Has somebody reviewed this code? If not, let's try to assign this ticket to somebody who can review it? Foundations Team?

I think you're the best person to review this (tiny) change to code we wrote together; worst case my FT team-mate could do it but I doubt he knows this codebase.

FWIW the proposed branch merely bumps a hard-coded "8" to "32". The commit message is longer than the diff :)

#16 Updated by u 8 months ago

  • QA Check set to Ready for QA

ack! I'll do the review then.

#17 Updated by sajolida 8 months ago

  • Parent task deleted (#12328)

#18 Updated by u 8 months ago

  • Status changed from Confirmed to Resolved
  • QA Check changed from Ready for QA to Pass

This change was already merged by anonym.

#19 Updated by intrigeri 8 months ago

  • Status changed from Resolved to In Progress
  • Target version changed from Tails_3.5 to Tails_3.6
  • % Done changed from 0 to 80

u wrote:

This change was already merged by anonym.

Alas, it's a tad more complicated than that. anonym did merge this branch into the public mirror for m-p-d (:mirror-pool-dispatcher.git) on April 3 last year, but that's mostly a no-op and will be overwritten next time someone pushes changes to the master repo (:mirror-pool-dispatcher.git). To make these changes effective we also need to:

  1. push the changes to the master repo so the change is deployed on our website
  2. in tails.git, update the corresponding submodule so the change is used by Tails Upgrader

If you prefer I can handle this.

#20 Updated by u 8 months ago

  • Assignee changed from u to intrigeri

intrigeri wrote:

u wrote:

This change was already merged by anonym.

Alas, it's a tad more complicated than that. anonym did merge this branch into the public mirror for m-p-d (:mirror-pool-dispatcher.git) on April 3 last year, but that's mostly a no-op and will be overwritten next time someone pushes changes to the master repo (:mirror-pool-dispatcher.git). To make these changes effective we also need to:

  1. push the changes to the master repo so the change is deployed on our website

looks like I don't have this set up, maybe I don't have access to it actually.

  1. in tails.git, update the corresponding submodule so the change is used by Tails Upgrader

If you prefer I can handle this.

Go ahead.

#21 Updated by intrigeri 8 months ago

  1. push the changes to the master repo so the change is deployed on our website

looks like I don't have this set up, maybe I don't have access to it actually.

IIRC access to it comes automatically with access to the master tails.git, so I'm pretty sure you have access to it but need to add the Git remote.

If you prefer I can handle this.

Go ahead.

OK!

#22 Updated by intrigeri 8 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 80 to 100

All done and pushed to devel.

#23 Updated by intrigeri 8 months ago

  • Assignee deleted (intrigeri)

#24 Updated by bertagaz 6 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF