Project

General

Profile

Feature #12448

Propose to delete data from deactivated persistent features

Added by sajolida over 1 year ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/14/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:

Description

In #12109 we are working on a documentation patch to explain people how to delete the files corresponding to deactivated persistent features. Still, we shouldn't rely on having people ready the doc so much...

Instead what about asking people whether they want to delete the corresponding data when we detect that some features have been deactivated?

If we agree on this, I could draft a UI.


Related issues

Related to Tails - Bug #12109: Warn the users that removing a persistent feature doesn't erase any data Resolved 01/02/2017
Duplicates Tails - Feature #8447: Propose to delete data from a persistence feature when it is deactivated Confirmed 12/16/2014

History

#1 Updated by sajolida over 1 year ago

  • Related to Bug #12109: Warn the users that removing a persistent feature doesn't erase any data added

#2 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida

It surely is feasible, but not entirely straightforward. Do you expect from me a time estimate, or anything else?

Cost put aside, how important do you rank this compared to other work we want to do on the persistence assistant? (Rationale: even estimating costs has a cost, and I'd rather not spend 1h on it if the whole thing ends up being an unassigned low prio ticket for years.)

#3 Updated by sajolida over 1 year ago

  • Status changed from New to Confirmed
  • QA Check deleted (Info Needed)

I have no data to know how important this is. I think that at that point I only wanted you first impression on this being further investigated. Now I have it (thanks!) and I'm fine keeping this ticket assign to me for me research (on the important and on a first UI maybe) without you spending time on evaluating implementation costs yet.

Maybe we'll get more hints on how to priotize different improvements on this UI if we do the work on additional software.

Unfortunately, such ticket looks like the kind of work that we have the hardest time to fund as it's neither core work neither fancy enough for grants. Oh well...

#4 Updated by u 9 months ago

  • Related to Feature #8447: Propose to delete data from a persistence feature when it is deactivated added

#5 Updated by u 9 months ago

@sajolida, you already drafted something here: https://labs.riseup.net/code/issues/8447#note-4

#6 Updated by u 2 months ago

I would be in favor of such a feature.

#7 Updated by sajolida 2 months ago

  • Related to deleted (Feature #8447: Propose to delete data from a persistence feature when it is deactivated)

#8 Updated by sajolida 2 months ago

  • Duplicates Feature #8447: Propose to delete data from a persistence feature when it is deactivated added

#9 Updated by sajolida 2 months ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (sajolida)

Oops... I'm so good at coming up with the same ideas over and over again :)

#10 Updated by u 2 months ago

sajolida wrote:

Oops... I'm so good at coming up with the same ideas over and over again :)

huhuhu :))

Also available in: Atom PDF