Project

General

Profile

Bug #12453

Feature #5630: Reproducible builds

Invalid MBR ID passed to isohybrid

Added by intrigeri 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
04/17/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
feature/5630-deterministic-builds
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Symptoms: #11983#note-7. Once I've made isohybrid more verbose I saw "isohybrid: invalid id: `'1490015021''". So passing --id $SOURCE_DATE_EPOCH to isohybrid made the ISO reproducible… because it's an invalid ID and so we stopped hybriding the ISO.

Associated revisions

Revision 7bfcaecc (diff)
Added by intrigeri 10 months ago

Pass a fixed and valid ID to isohybrid's --id parameter (refs: #12453).

Due to a mistake I did wrt. shell quoting in
6fcb23230c782b878c66019e4101ad3ec8632f25, we were actually passing "--id
'1490015021'" (with the single quotes), which is an invalid ID. So isohybrid
was aborting. As a result isohybrid stopped creating non-reproducible ISOs,
but the resulting ISO images were not hybrid'ed.

Let's not bother passing $SOURCE_DATE_EPOCH, and just pass a fixed value.

Revision d992401b (diff)
Added by intrigeri 10 months ago

Make isohybrid failures fatal (refs: #12453).

So that issues such as #12453 don't go unnoticed anymore.

History

#1 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

These tests now pass.

Also available in: Atom PDF