Bug #12457

Executing Video player Totem freezes the system

Added by emmapeel 2 months ago. Updated about 1 month ago.

Status:ResolvedStart date:05/03/2017
Priority:NormalDue date:
Assignee:emmapeel% Done:

100%

Category:-
Target version:Tails_3.0
QA Check: Blueprint:
Feature Branch: Easy:
Type of work:Research Affected tool:

Description

reported by user on Tails 2.11, reproduced by me on Tails 2.12

Steps to reproduce
------------------

- Start Tails
- Open Totem (from the menu or from console with totem)

System eventually freezes.

(There are some error messages when starting from console, about GTK window warnings or something. But they look like the usual spammy log messages, maybe not related to the problem.)

If I install vlc this problem goes away.


Subtasks

Feature #12502: Add Totem problem to known issues 2.12Resolved


Related issues

Duplicated by Tails - Bug #12465: Tails 2.12 Duplicate 04/21/2017

History

#1 Updated by emmapeel 2 months ago

#2 Updated by Anonymous 2 months ago

I can not reproduce this is 2.11 nor 2.12?
What does it rely on that causes the freezing?
The only error messages when you open it in terminal are but no crash or freeze:

amnesia@amnesia:~$ totem
Failed to get capabilities of file `/usr/bin/totem' (Operation not supported)

(totem:17230): dconf-WARNING **: Unable to open /etc/dconf/profile/user: Permission denied
libGL error: MESA-LOADER: failed to retrieve device information
MESA-LOADER: failed to retrieve device information
MESA-LOADER: failed to retrieve device information

(totem:17230): GLib-GObject-WARNING **: g_object_set_valist: object class 'GstPlayBin' has no property named 'p\xfdMW\u0002'

(totem:17230): Grilo-WARNING **: [dleyna] grl-dleyna-servers-manager.c:138: Unable to fetch the list of available servers: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name com.intel.dleyna-server was not provided by any .service files

#3 Updated by emmapeel about 2 months ago

  • Feature Branch set to emmapeel:totem-crash

This issue has been reported several times. Please review my branch to add the issue to the known issues section of the release.

#4 Updated by emmapeel about 2 months ago

  • Assignee set to anonym
  • Priority changed from Elevated to Normal

#5 Updated by emmapeel about 2 months ago

Another user sent a report. This user's system does not crash, however the Video player does not play any video.

The good thing is, I have a log!

On the log of the user looks like libGL is having problems, or maybe it is an AppArmor problem.

#6 Updated by emmapeel about 2 months ago

As per the suggestion of yet another user, I installed vlc and now, even Totem will play videos without a problem!

I noticed that the installation of vlc downgraded `libgl1-mesa-glx` and `libglapi-mesa`

#7 Updated by emmapeel about 2 months ago

  • Description updated (diff)

#8 Updated by emmapeel about 2 months ago

  • Assignee deleted (anonym)
  • QA Check set to Dev Needed
  • Feature Branch changed from emmapeel:totem-crash to emmapeel:doc/12457-workaround

Please review the new branch with the workaround for the known issues section:

- Install vlc

#9 Updated by intrigeri about 2 months ago

  • Assignee set to emmapeel

Please split this ticket into one about documenting the workaround (that should be ready for QA I guess) and one about working on the actual bug (this can be this very ticket, assigned to me as I'm the de factor foundations team person who deals with issues in the graphics stack, even if that's never really been a choice nor a formalized decision).

#10 Updated by intrigeri about 2 months ago

  • % Done changed from 100 to 0
  • QA Check changed from Dev Needed to Info Needed

Also, please:

  • try to reproduce on the latest 3.0 pre-release
  • if you can't reproduce there, case closed as there won't be another 2.x release
  • if you can reproduce there, I'll need logs and hardware details, so please write down here the ID of the WhisperBack bug reports you've forwarded us.

#11 Updated by emmapeel about 2 months ago

  • Feature Branch deleted (emmapeel:doc/12457-workaround)
  • Type of work changed from Code to Research

OK, waiting for more reports.

#12 Updated by emmapeel about 2 months ago

  • Subject changed from Executing Totem freezes the system to Executing Video player Totem freezes the system

#13 Updated by emmapeel about 2 months ago

  • Status changed from Confirmed to Resolved
  • Target version set to Tails_3.0
  • QA Check deleted (Info Needed)

I could not reproduce this issue on Tails3.0 with a

VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

(I can reproduce with this same laptop in Tails 2.12)

So I mark it as resolved for Tails 3.0

#14 Updated by intrigeri about 2 months ago

I could not reproduce this issue on Tails3.0 with a

Thanks a lot for testing!

Also available in: Atom PDF