Project

General

Profile

Feature #12554

Bump APT snapshots for 3.0~rc1

Added by intrigeri 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
05/16/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocks Tails - Bug #12542: Consider installing xserver-xorg-legacy Resolved 05/16/2017
Blocks Tails - Bug #12354: Fix shutdown and memory wipe regressions on 3.0~betaN Resolved 03/20/2017

Associated revisions

Revision e4b9c58a (diff)
Added by intrigeri 8 months ago

Disable Tor's Sandbox, to workaround a Tor bug (refs: #12554).

https://trac.torproject.org/projects/tor/ticket/21943

Revision 80eccbb5 (diff)
Added by intrigeri 8 months ago

Bump APT snapshots serials for the Debian and TorProject archives to 2017051803.

Closes: #12554

History

#1 Updated by intrigeri 8 months ago

  • Blocked by Bug #12412: Adjust to Tor 0.3.x logging to syslog added

#2 Updated by intrigeri 8 months ago

All online tests currently fail there due to #12412.

#3 Updated by intrigeri 8 months ago

intrigeri wrote:

All online tests currently fail there due to #12412.

Scratch that: they're broken but I don't know why.

#4 Updated by intrigeri 8 months ago

  • Blocked by deleted (Bug #12412: Adjust to Tor 0.3.x logging to syslog)

#5 Updated by intrigeri 8 months ago

May 17 05:47:59.000 [notice] Tor 0.2.9.10 (git-e28303bcf90b842d) opening log file.
May 17 05:47:59.940 [notice] Tor 0.2.9.10 (git-e28303bcf90b842d) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.1.0e and Zlib 1.2.8.
May 17 05:47:59.940 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
May 17 05:47:59.940 [notice] Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
May 17 05:47:59.940 [notice] Read configuration file "/etc/tor/torrc".
May 17 05:47:59.940 [warn] The ControlListenAddress option is deprecated, and will most likely be removed in a future version of Tor. Use ControlPort instead. (If you think this is a mistake, please let us know!)
May 17 05:47:59.940 [warn] The TransListenAddress option is deprecated, and will most likely be removed in a future version of Tor. Use TransPort instead. (If you think this is a mistake, please let us know!)
May 17 05:47:59.940 [warn] The WarnUnsafeSocks option is deprecated, and will most likely be removed in a future version of Tor. Changing this option makes it easier for you to accidentally lose your anonymity by leaking DNS information (If you think this is a mistake, please let us know!)
May 17 05:47:59.940 [notice] Opening Socks listener on 127.0.0.1:9050
May 17 05:47:59.940 [notice] Opening Socks listener on 127.0.0.1:9061
May 17 05:47:59.940 [notice] Opening Socks listener on 127.0.0.1:9062
May 17 05:47:59.940 [notice] Opening Socks listener on 127.0.0.1:9150
May 17 05:47:59.940 [notice] Opening DNS listener on 127.0.0.1:5353
May 17 05:47:59.940 [notice] Opening Transparent pf/netfilter listener on 127.0.0.1:9040
May 17 05:47:59.940 [notice] Opening Control listener on 127.0.0.1:9052
May 17 05:47:59.000 [notice] Parsing GEOIP IPv4 file /usr/share/tor/geoip.
May 17 05:48:00.000 [notice] Parsing GEOIP IPv6 file /usr/share/tor/geoip6.

============================================================ T= 1495000080
(Sandbox) Caught a bad syscall attempt (syscall getpid)
/usr/bin/tor(+0x16146a)[0x55a68999546a]
/lib/x86_64-linux-gnu/libc.so.6(getpid+0x7)[0x7f0ef2903d87]
/lib/x86_64-linux-gnu/libc.so.6(getpid+0x7)[0x7f0ef2903d87]
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.1(+0x18ca17)[0x7f0ef33dba17]
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.1(+0xc7471)[0x7f0ef3316471]
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.1(BN_generate_prime_ex+0x4f7)[0x7f0ef3315577]
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.1(RSA_generate_key_ex+0x177)[0x7f0ef33e2e97]
/usr/bin/tor(crypto_pk_generate_key_with_bits+0xb5)[0x55a68999be15]
/usr/bin/tor(init_keys_client+0x39)[0x55a6898b7ef9]
/usr/bin/tor(init_keys+0x3c)[0x55a6898bc38c]
/usr/bin/tor(do_main_loop+0x4f)[0x55a68987767f]
/usr/bin/tor(tor_main+0x1c25)[0x55a68987b295]
/usr/bin/tor(main+0x19)[0x55a6898732a9]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1)[0x7f0ef286b2b1]
/usr/bin/tor(_start+0x2a)[0x55a6898732fa]

#6 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Seems to be https://trac.torproject.org/projects/tor/ticket/21943 that's fixed in tor 0.3.0.7 (not packaged yet, except nightly builds from Git) and in the maint-0.2.9 branch (so it will be fixed in 0.2.9.11 that's not out yet). IMO we should disable the Sandbox, bump APT snapshots, and file a ticket to re-enable the Sandbox.

#7 Updated by intrigeri 8 months ago

  • Blocks Bug #12542: Consider installing xserver-xorg-legacy added

#8 Updated by intrigeri 8 months ago

  • % Done changed from 10 to 20

Test results on Jenkins show a number of failures, likely false positives, and nothing too scary. I'll compare with results on feature/stretch and will bump snapshots if happy enough.

#9 Updated by intrigeri 8 months ago

  • Blocks Bug #12354: Fix shutdown and memory wipe regressions on 3.0~betaN added

#10 Updated by intrigeri 8 months ago

After analyzing the last test suite runs, I will test locally if the persistent Tor Browser directory is correctly created, and if I can't reproduce the problem here I'll bump the APT snapshots.

#11 Updated by intrigeri 8 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

#12 Updated by intrigeri 8 months ago

  • Status changed from Resolved to Fix committed
  • Assignee deleted (intrigeri)

#13 Updated by intrigeri 8 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF