Project

General

Profile

Bug #12561

The persistent Tor Browser directory and the GNOME bookmarks for persistence are not always created

Added by intrigeri about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Persistence
Target version:
Start date:
05/18/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/12561-persistence-config, greeter:bugfix/12561-persistence-config
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Browser

Description

I've noticed that on feature/stretch-unfrozen but forgot about it and indirectly did #12554 (by merging a branch based on feature/stretch-unfrozen). I at least want to investigate for 3.0~rc1 and try to come up with a fix. Worst case, document on known issues and fix in 3.0 final.

Associated revisions

Revision ada06bf5 (diff)
Added by intrigeri about 1 year ago

Enable the bugfix-12561-persistence-config APT overlay (refs: #12561).

Revision d22b1c4b (diff)
Added by intrigeri about 1 year ago

Grant GDM (and thus Tails Greeter) write access to /var/lib/live/config/ (refs: #12561).

Tails Greeter now creates the tails.persistence file directly in there, to avoid
race conditions between the PostLogin script and services run in the systemd
user session that depend on PostLogin.

See commit 7c6a763fd0ea12007f24483d3fe4cce0d25f359c in greeter.git
for details.

Revision 400b26a5
Added by anonym about 1 year ago

Merge remote-tracking branch 'origin/bugfix/12561-persistence-config' into feature/stretch

Fix-committed: #12561

History

#1 Updated by intrigeri about 1 year ago

  • Subject changed from The persistent Tor Browser directory is not always created to The persistent Tor Browser directory and the GNOME bookmarks for persistence are not always created

#2 Updated by intrigeri about 1 year ago

/usr/local/lib/create-tor-browser-directories uses /usr/local/lib/tails-shell-library/tails-greeter.sh that looks in /var/lib/live/config/tails.persistence, which is copied from /var/lib/gdm3/tails.persistence in the PostLogin file shipped by Tails Greeter. I don't think we have a guarantee that PostLogin has finished running when we start the systemd user session and run /usr/local/lib/create-tor-browser-directories. I'll try having Tails Greeter write directly to /var/lib/live/config/tails.persistence and see if it helps.

#3 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/12561-persistence-config, greeter:bugfix/12561-persistence-config

#4 Updated by intrigeri about 1 year ago

  • % Done changed from 10 to 20

My fix seems to work while testing on bare metal. Will run the corresponding automated tests locally before sending for QA.

#5 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 20 to 50
  • QA Check set to Ready for QA

I saw "Scenario: The persistent Tor Browser directory is usable" pass locally so I'm now confident I understood and fixed the root cause of the problem. We'll see if it reappears.

#6 Updated by anonym about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

I had this branch merged when I tested something unrelated, but I ran the The persistent Tor Browser directory is usable scenario which runs the steps:

    Then the persistent Tor Browser directory exists
    And there is a GNOME bookmark for the persistent Tor Browser directory

which seems to cover this. And the code looks good (a definite improvement because of reduced code complexity)! => Merged!

#7 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF