Project

General

Profile

Bug #12565

Feature #5630: Reproducible builds

Test failures on Jenkins due to lack of disk space

Added by intrigeri 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
05/19/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
bugfix/12565-reorder-features
Type of work:
Sysadmin
Blueprint:
Easy:
Affected tool:

Description

The branches based on the reproducible builds one fail some tests: https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-11971-fontconfig-cache-in-iso/3/cucumberTestReport/. I think I got the snapshots (re-)ordering wrong when working on #12354. anonym, could you please take a look and fix it? The same tests pass on feature/stretch.


Related issues

Blocks Tails - Feature #13232: Core work 2017Q2: Sysadmin (Maintain our already existing services) Resolved 06/29/2017

Associated revisions

Revision 67c0c882 (diff)
Added by intrigeri 4 months ago

Test suite: run emergency_shutdown.feature after usb_*.feature (refs: #12565).

Otherwise it eats so much storage that usb_*.feature fail to create their
temporary disks.

Revision 41e3ba23
Added by intrigeri 4 months ago

Merge remote-tracking branch 'origin/bugfix/12565-reorder-features' into feature/stretch

Closes: #12565

History

#1 Updated by intrigeri 4 months ago

  • Blocks Feature #11983: Check if the test suite has more failures on the reproducible ISO added

#2 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 10
  • Type of work changed from Code to Sysadmin

When the first failure happens (Scenario: Tails erases memory and shuts down on USB boot medium removal: persistent data), ~14G are used, mostly due to:

  • no-network-logged-in-snapshot.memstate: 1.9G
  • tails-greeter-snapshot.memstate: 1.5G
  • with-network-logged-in-snapshot.memstate: 2.0G
  • __internal disk: 8.1G

And there's only 1.2G free in /tmp/TailsToaster, which is not enough to dump the memory. Reordering features might help other scenarios pass but the scenario I'm discussing here will always require all these snapshots and disks to be available, so it cannot be fixed by reordering => I see no other choice than giving isotesters a bit more space in /tmp/TailsToaster. I'll do it right away.

#3 Updated by intrigeri 4 months ago

  • % Done changed from 10 to 20

intrigeri wrote:

I see no other choice than giving isotesters a bit more space in /tmp/TailsToaster. I'll do it right away.

Done, let's see how it goes.

#4 Updated by intrigeri 4 months ago

It's still not enough, and actually tests fail on feature/stretch as well (only a bit later).

#5 Updated by intrigeri 4 months ago

  • Feature Branch changed from feature/5630-deterministic-builds to bugfix/12565-reorder-features

#6 Updated by intrigeri 4 months ago

  • % Done changed from 20 to 30

Grown the ramdisk to 18G: I've just realized that we have no tests (on feature/stretch) that use a VM with 8GB of RAM, so we can give more space to TailsToaster without allocating more RAM to isotesters. Hopefully that'll be enough!

#7 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 30 to 100

https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-stretch/4/console has passed the features I would expect to fail due to disk space reasons. Let's reopen if the problem reappears, and forget about the topic branch.

#8 Updated by intrigeri 4 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to intrigeri
  • Target version changed from Tails_3.0~rc1 to Tails_3.0
  • % Done changed from 100 to 50

#9 Updated by intrigeri 4 months ago

If https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-12565-reorder-features/1/console fixes this problem I'll merge that branch, otherwise I'll grow the tmpfs again.

#10 Updated by intrigeri 4 months ago

  • Blocks deleted (Feature #11983: Check if the test suite has more failures on the reproducible ISO)

#11 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#12 Updated by intrigeri 4 months ago

  • Assignee deleted (intrigeri)

Merged!

#13 Updated by intrigeri 3 months ago

  • Blocks Feature #13232: Core work 2017Q2: Sysadmin (Maintain our already existing services) added

Also available in: Atom PDF