Project

General

Profile

Bug #12575

Feature #5630: Reproducible builds

Fix basebox:clean_old

Added by intrigeri 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Build system
Target version:
Start date:
05/22/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Description

See parent ticket for details.


Related issues

Blocks Tails - Feature #12576: Have Jenkins use basebox:clean_old instead of basebox:clean_all In Progress 05/22/2017

Associated revisions

Revision d0f0179e (diff)
Added by anonym 4 months ago

Rakefile: fix basebox date comparison.

Array#sort! wants a <=>-comparison (i.e. -1, 0, 1), not a boolean one.

Will-fix: #12575

Revision fc1bba10 (diff)
Added by bertagaz 4 months ago

Rakefile: lower to 4 months the age to which baseboxes gets deleted by basebox:clean_old.

Refs: #12575, #12531, #12576

History

#1 Updated by intrigeri 4 months ago

  • Blocks Feature #12576: Have Jenkins use basebox:clean_old instead of basebox:clean_all added

#2 Updated by anonym 4 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to bertagaz
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Since we don't run this code anywhere I pushed the fix straight to feature/stretch: see d0f0179e2738703090bf246653b665c1d2977b99.

#3 Updated by intrigeri 4 months ago

  • Blocks deleted (Feature #12576: Have Jenkins use basebox:clean_old instead of basebox:clean_all)

#4 Updated by intrigeri 4 months ago

  • Parent task deleted (#12531)

#5 Updated by intrigeri 4 months ago

  • Parent task set to #5630

#6 Updated by intrigeri 4 months ago

  • Blocks Feature #12576: Have Jenkins use basebox:clean_old instead of basebox:clean_all added

#7 Updated by intrigeri 4 months ago

  • Priority changed from High to Elevated

(Same rationale as #12576.)

#8 Updated by bertagaz 4 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

anonym wrote:

Since we don't run this code anywhere I pushed the fix straight to feature/stretch: see d0f0179e2738703090bf246653b665c1d2977b99.

Works better now indeed. I've also pushed a commit on top (see fc1bba108640e6057bcd0a34f052de1aebab5461) that lowers the cleaning of baseboxes to those that are older than 4 months, as we discussed in #12531#note-20.

#9 Updated by bertagaz 4 months ago

  • Status changed from Fix committed to In Progress

#10 Updated by intrigeri 4 months ago

  • Assignee set to bertagaz

Shouldn't this be "fix committed"?

#11 Updated by bertagaz 4 months ago

  • Status changed from In Progress to Fix committed

intrigeri wrote:

Shouldn't this be "fix committed"?

Right, the commit did change it back after I put it the right way.

#12 Updated by bertagaz 4 months ago

  • Assignee deleted (bertagaz)

#13 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF