Project

General

Profile

Bug #12578

Feature #5630: Reproducible builds

Bug #12531: ISO builds on Jenkins are fragile since the migration to vagrant-libvirt

Abort if Vagrant create_box fails

Added by intrigeri 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Build system
Target version:
Start date:
05/22/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/12531-make-create-box-more-robust
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Description

See parent ticket where this originated from, and then was kinda lost in the middle of other related issues.

History

#1 Updated by bertagaz 4 months ago

  • Assignee changed from bertagaz to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

anonym wrote:

Also, note that this error is ignored, and the build process proceeds with trying to import this corrupt .box, since create_box.sh doesn't check error statuses or set -e. While we're at it we could force set -e ourselves

So this branch had some run in Jenkins, and didn't lead to reveal unexpected behaviors or to break anything. I've made create_box.sh fails in this build by filling artificially filling the partition space when the script is ran and as shown by the logs it now makes the build fail as expected when it does itself. So I think we can merge this branch by now.

#2 Updated by anonym 4 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#3 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF