Project

General

Profile

Bug #12613

Document Debian testing live image for debugging

Added by sajolida 12 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/29/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
doc/12613-debian-live-images
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

Debian testing live images are now built weekly:

This addresses one problem we've been wanting to solve for years
(#6349): very often we would like to ask bug reporters "can you
reproduce this on current Debian testing/unstable?". Now we can!

I believe that the unofficial GNOME image that includes non-free
firmware is the one we want to point users to in most cases:
http://get.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/debian-live-testing-amd64-gnome+nonfree.iso
(signed hashes available in the parent directory).

So:

  • dear help desk & foundations team: please add these links to some
    place where you can find them when needed, and please start
    pointing users to them when relevant.
  • dear doc writers: please consider whether we should link to these
    images from some place in our troubleshooting doc.

Related issues

Related to Tails - Feature #6349: Have a live Debian sid desktop ISO image available for download Resolved 10/09/2013
Related to Tails - Bug #12474: Document troubleshooting tips for more failure scenarios throughout installation assistant Confirmed 04/25/2017
Blocks Tails - Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing Resolved 09/17/2017

Associated revisions

Revision 8d411350
Added by intrigeri 3 months ago

Merge remote-tracking branch 'origin/doc/12613-debian-live-images' (refs: #12613)

Revision 1f9d167f
Added by intrigeri about 2 months ago

Merge remote-tracking branch 'origin/doc/12613-debian-live-images' (refs: #12613)

Revision 9b81ca4e (diff)
Added by intrigeri about 2 months ago

Fix typos (refs: #12613)

History

#1 Updated by sajolida 12 months ago

  • Related to Feature #6349: Have a live Debian sid desktop ISO image available for download added

#2 Updated by sajolida 12 months ago

  • Assignee set to elouann

We're in a very grey zone concerning who should feel responsible to document. I'm assigning it to the current help desk because:

  • I'm already clear overtime on technical writing for this quarter so I want to limit myself to reviews.
  • This documentation seems to be more in the field of help desk than general purpose documentation.
  • Help desk also have some paid time to do documentation tasks that will make the frontdesk job's easier in the future and, according to they clocking data, they usually have more margin than I do.
  • I will anyway have to work on this to review and correct the language.

So please, dear help desk, share your plans with me before writing anything: propose roughly where this should be mentionned on our website, linked from, etc.

Then I'll be happy to comment on your plans before you write a draft.

#3 Updated by u 11 months ago

  • Related to Bug #12474: Document troubleshooting tips for more failure scenarios throughout installation assistant added

#4 Updated by u 11 months ago

dear doc writers: please consider whether we should link to these images from some place in our troubleshooting doc.

I'd propose to add this here: https://tails.boum.org/doc/first_steps/bug_reporting/ after "check if the bug is already known" -> "try to reproduce this in Debian Live".

Added help desk as watchers, so one of you can take over.

Furthermore, help desk should put this information somewhere in their internal help desk documents I believe.

#5 Updated by mercedes508 4 months ago

  • Assignee changed from elouann to sajolida

Help Desk is not responsible for doc writing anymore, so re-assigning it to sajolida.

Moreover it's already documented in our git, to point users to these images.

#6 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to doc/12613-debian-live-images

intrigieri: What do you meant by "the one we want to point users to in most cases"? In which cases would we want to point to a different image?

Assuming that it's not worth documenting different images, here is a draft. Please check whether what I'm saying makes sense.

I put it in a dedicated section at the bottom of /doc/first_steps/bug_reporting because:

  • It's more "bug reporting" than "troubleshooting".
  • It's not realistic to put this forward as a prerequisite for people to report a bug. It's a 2.5 GB download! Before 6a4621ac43 we were also asking them to go through a list of >1000 Redmine tickets :)

So maybe it's more like a useful link for Help desk.

But I'm not really convinced either...

#7 Updated by sajolida 3 months ago

  • Blocks Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing added

#8 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed
  • Type of work changed from Contributors documentation to End-user documentation

sajolida wrote:

intrigieri: What do you meant by "the one we want to point users to in most cases"?

I mean the ISO image I'm linking to after the text you're quoting followed by ":" i.e. http://get.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/debian-live-testing-amd64-gnome+nonfree.iso.

In which cases would we want to point to a different image?

E.g. to try to find out if a problem is GNOME-specific, one might want to point to a non-GNOME image. Or to try to find out if a problem is caused by a buggy proprietary firmware, one might want to point to the free software image.

Assuming that it's not worth documenting different images, here is a draft. Please check whether what I'm saying makes sense.

It looks good! I've merged it already because it's clearly better than not having it at all. But I have one concern about how this Debian testing Live image is introduced. There are two major ways to help troubleshoot a Tails bug on Debian:

  1. test on current Debian stable, to know if the problem is specific to Tails
  2. test on current Debian testing, to know if the problem has been fixed in Debian testing already (ideally we would ask to test a nightly build of feature/buster, so we know if it's fixed in a Debian testing-based Tails, but it's broken too often)

Our Help Desk (and myself) asks users to do either one, depending on the case. The way I understand it, your introduction text ("to know if your bug only affects Tails") suggests the new section is about the first case, while it's really about the second case. When I've opened this ticket, I was assuming we were already documenting the first case so I was suggesting we document the second case too, but I was mistaken: we don't document the first case anywhere I could find. I think the section added by this branch should/could document both but I don't know how the text should be structured, you're the boss!

#9 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Info Needed

To download images of the current Debian I found that:

https://cdimage.debian.org/cdimage/release/current-live/amd64/iso-hybrid/

But no static link that would keep on working across Debian version. Do you know any?

NB: I'm still not convinced that this is something useful to document in our documentation, I mean outside of people already interacting with Help desk or the Foundation team. So every bit of added complexity or every special cases brings me closer to thinking that if it cannot be simple, it shouldn't be documented at all...

#10 Updated by sajolida 3 months ago

Or if it's not about helping people (as in /support) but about helping Tails, then it should be in /contribute.

#11 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Info Needed to Dev Needed

To download images of the current Debian I found that:
https://cdimage.debian.org/cdimage/release/current-live/amd64/iso-hybrid/

FYI that's the 100% free software one. I believe that in most cases that one will be more useful: https://get.debian.org/cdimage/unofficial/non-free/cd-including-firmware/current-live/amd64/iso-hybrid/

But no static link that would keep on working across Debian version. Do you know any?

I could not find any stable link to the latest ISO, sorry :/

NB: I'm still not convinced that this is something useful to document in our documentation, I mean outside of people already interacting with Help desk or the Foundation team. So every bit of added complexity or every special cases brings me closer to thinking that if it cannot be simple, it shouldn't be documented at all...

Your call.

#12 Updated by intrigeri 3 months ago

Or if it's not about helping people (as in /support) but about helping Tails, then it should be in /contribute.

Well, it's about helping people help us help them i.e. "give us the info we need to fix your problem" :)

I have no strong opinion about where that documentation should live, and about whether it should be exposed as part of the regular support path, but regardless: that doc will be more useful for me (with my Foundations Team hat on) if the target audience is Tails end-users, so I can refer bug reporters to it.

#13 Updated by sajolida about 2 months ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Sorry for the mess in Git. I tried a bit harder and came up with two more commits that should solve your concerns (and mine).

#14 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Resolved
  • Target version set to Tails_3.7

I tried a bit harder and came up with two more commits that should solve your concerns (and mine).

Great! I've fixed a few typos in 9b81ca4e302f01157fc89707830049116a8596a7 and merged.

#15 Updated by intrigeri about 2 months ago

  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF