Project

General

Profile

Feature #12626

Feature #5630: Reproducible builds

Report back to the reproducible builds community about how we did it

Added by intrigeri 5 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/31/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Communicate

Description

Anything that's not related to Jenkins (already covered by #12616) on https://tails.boum.org/blueprint/reproducible_builds/ should probably be moved somewhere under contribute/design.


Related issues

Related to Tails - Feature #12630: Document how users can verify a reproducibly built ISO/IUK Resolved 06/02/2017
Related to Tails - Bug #11795: Document Git repo of ISO archive In Progress 09/14/2016
Related to Tails - Feature #12356: Communicate about reproducible builds to users via a blog post In Progress 03/17/2017
Blocks Tails - Feature #14757: Final report for SponsorT 2016 Confirmed 10/02/2017

Associated revisions

Revision 62a2a59d (diff)
Added by intrigeri 16 days ago

Add draft report to the RB community (refs: #12626).

History

#1 Updated by u 4 months ago

  • Related to Feature #12630: Document how users can verify a reproducibly built ISO/IUK added

#2 Updated by u 4 months ago

  • Related to Bug #11795: Document Git repo of ISO archive added

#3 Updated by intrigeri about 2 months ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

I'll clarify what this is about.

#4 Updated by intrigeri about 2 months ago

  • Subject changed from Design doc for reproducible builds to Report back to the reproducible builds community about how we did it
  • Target version changed from Tails_3.2 to Tails_3.3
  • QA Check deleted (Info Needed)
  • Type of work changed from Contributors documentation to Communicate

Actually this is not part of the deliverables we've promised => dropping the "deliverable for" field and repurposing this ticket. Still, I would like us to report back to the reproducible builds community about the problems we've met and our strategy/techniques to address them. Format = 1 single email. I'll try to do this by the end of the year, and if I don't manage to I'll drop this idea. Help and suggestions are welcome :)

#5 Updated by intrigeri 16 days ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20
  • Feature Branch set to https://tails.boum.org/blueprint/reproducible_builds/report_to_RB_community/

Drafted something.

#6 Updated by intrigeri 16 days ago

  • Feature Branch deleted (https://tails.boum.org/blueprint/reproducible_builds/report_to_RB_community/)
  • Blueprint set to https://tails.boum.org/blueprint/reproducible_builds/report_to_RB_community/

#7 Updated by intrigeri 16 days ago

  • Assignee changed from intrigeri to u
  • QA Check set to Ready for QA

anonym, lamby, u: I would welcome your feedback on https://tails.boum.org/blueprint/reproducible_builds/report_to_RB_community/ before I send this to the reproducible builds mailing list. You can edit & improve it with Git or directly via the web interface, as you wish.

My goal is to send it by October 22 so people have time to digest this and get ready to hammer us with questions at the RB world summit ;) If my draft doesn't get enough seconds in due time, I'll simply add a "speaking for myself blah" disclaimer and send it anyway, as long as there are no strong objections of course.

#8 Updated by intrigeri 16 days ago

#9 Updated by lamby 16 days ago

We have tried to avoid big hammer approaches with side-effects that are hard to control, such as faketime.

we have fixed reproducibility problems at the root

"At the cause" or "at the upstream." When I saw "root" I immediately think of uid zero. :)

diffoscope

Could you make this a link to https://diffoscope.org/ ?

Chris Lamb

Could you make this a link to https://chris-lamb.co.uk/ ?

SOURCE_DATE_EPOCH

Could you make this a link to https://reproducible-builds.org/specs/source-date-epoch/ ?

Apart from those tiny nitpicks I really like this report. Thank you for working on it :)

#10 Updated by intrigeri 16 days ago

Could you […]?

Done all three and applied your phrasing improvement suggestion.

Apart from those tiny nitpicks I really like this report. Thank you for working on it :)

Cool :)

I've also edited a bit the "Future plans" section that anonym has added.

anonym, u: please state explicitly here once you think this is ready to be sent. I've seen edits by anonym + edits on the web interface (by u I guess) but I don't know if you're done yet.

#11 Updated by u 14 days ago

  • Assignee changed from u to intrigeri
  • QA Check changed from Ready for QA to Pass

anonym, u: please state explicitly here once you think this is ready to be sent. I've seen edits by anonym + edits on the web interface (by u I guess) but I don't know if you're done yet.

Yes, that was me through the web interface.

I've done a last round of proofreading, and I think the email can be sent. Will you take care of it?
Do we also want to publish this on planet.debian.org?

#12 Updated by u 14 days ago

@intrigeri, will the blueprint stay on the page or will you move it somewhere else? I'd like to link to it, that's why..

#13 Updated by intrigeri 14 days ago

I've done a last round of proofreading, and I think the email can be sent. Will you take care of it?

I will.

Do we also want to publish this on planet.debian.org?

I think I'll do it once we release something that nobody manages to build non-reproducibly.

#14 Updated by intrigeri 14 days ago

:

@intrigeri, will the blueprint stay on the page or will you move it somewhere else? I'd like to link to it, that's why..

I don't plan to move/delete it but it's a wiki page and will likely be updated, so if you need to reference the content that's in there right now, that might not work very well.

#15 Updated by anonym 14 days ago

intrigeri wrote:

anonym, u: please state explicitly here once you think this is ready to be sent. I've seen edits by anonym + edits on the web interface (by u I guess) but I don't know if you're done yet.

I'm extremely convinced you have solved #14767, so I've rephrased the bits about that to something more optimistic in commit:fddb1fab8c88cb7bd7b488ad100a50eb75d9366d.

#16 Updated by anonym 14 days ago

... and with that I think the report is ready!

#17 Updated by lamby 14 days ago

anonym wrote:

... and with that I think the report is ready!

Again, stellar work folks!

#18 Updated by u 5 days ago

  • Related to Feature #12356: Communicate about reproducible builds to users via a blog post added

#19 Updated by intrigeri 3 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

Also available in: Atom PDF