Project

General

Profile

Feature #12705

Update the size of the system partition to >= 4 GiB

Added by intrigeri 11 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
06/15/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
feature/12705-bump-system-partition-size, installer:feature/12705-bump-system-partition-size
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

This is the parent ticket to implement what we've discussed on #11627. The plan we settled with is #11627#note-18, i.e.:

  • document that a 8 GiB stick is required
  • bump the default system partition size for newly installed Tails to 4 GiB on 8 GiB sticks, and to 8 GiB on sticks of 16 GiB or larger
  • refuse installing a new Tails on a stick smaller than 8 GiB
  • allow upgrading (by cloning) a legacy stick with a smaller (1.5 or 2.5 GiB) system partition when feasible; note that feasibility is a function of the size of data currently present on the source USB stick, and not of the size of its system partition
  • provide useful messages when upgrade by cloning is impossible; we can mention the several available options, along with their pros/cons, i.e. "upgrade from ISO" (easier but has to be done every time) and "migrate to a new USB stick with a larger system partition and copy your persistent data" (painful, but then you're done with it and get incremental upgrades for a while)
  • follow-up bonus, if time allows: have Tails Upgrader mention the "migrate to a new USB stick with a larger system partition" too when incremental upgrade is impossible due to a too small system partition; would be nice, but I don't want to block on that; it can be handled on #11628.

The corresponding work will be tracked as subtasks.


Subtasks

Feature #12706: Adjust the documentation wrt. updated system partition sizeResolved

Feature #12707: Bump the size of the system partition created by Tails InstallerResolved


Related issues

Related to Tails - Feature #11627: Consider updating the default system partition's size Resolved 08/10/2016
Related to Tails - Bug #11628: Error message on not-enough-free-space in Tails Upgrader is confusing In Progress 08/10/2016
Related to Tails - Feature #11679: Rethink the installation process and upgrade process Resolved 08/20/2016
Related to Tails - Feature #5301: Clone or backup system for the persistent volume Confirmed 01/27/2015
Related to Tails - Feature #12214: Document a way to manually backup persistent data In Progress 02/06/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017
Blocks Tails - Bug #14622: Have the Installer detect when "Clone the current Tails" won't fit in the destination partition before deleting anything Resolved 09/11/2017
Blocks Tails - Feature #13424: Core work 2017Q3: User experience Resolved 07/05/2017

Associated revisions

Revision c04c7ff8 (diff)
Added by intrigeri 8 months ago

Enable the feature-12705-bump-system-partition-size APT overlay (refs: #12705).

Revision 433c1a7b
Added by anonym 8 months ago

Merge remote-tracking branch 'origin/feature/12705-bump-system-partition-size' into devel

Fix-committed: #12705

History

#1 Updated by intrigeri 11 months ago

  • Related to Feature #11627: Consider updating the default system partition's size added

#2 Updated by intrigeri 11 months ago

  • Related to Bug #11628: Error message on not-enough-free-space in Tails Upgrader is confusing added

#3 Updated by intrigeri 11 months ago

  • Related to Feature #11679: Rethink the installation process and upgrade process added

#4 Updated by intrigeri 11 months ago

  • Related to Feature #5301: Clone or backup system for the persistent volume added

#5 Updated by intrigeri 11 months ago

  • Related to Feature #12214: Document a way to manually backup persistent data added

#6 Updated by intrigeri 11 months ago

#7 Updated by intrigeri 8 months ago

  • Blocks Bug #14622: Have the Installer detect when "Clone the current Tails" won't fit in the destination partition before deleting anything added

#8 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/12705-bump-system-partition-size

#9 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA
  • Feature Branch changed from feature/12705-bump-system-partition-size to feature/12705-bump-system-partition-size, installer:feature/12705-bump-system-partition-size

#10 Updated by intrigeri 8 months ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

This was merged into devel already but I forgot one thing. Testing my fix.

#11 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Dev Needed to Ready for QA

Actually I can't test it, apparently because the test suite has been broken by the merge of #8859:

  Scenario: Booting Tails from a USB drive without a persistent partition and creating one                                                 # features/usb_install.feature:46
    Given I have started Tails without network from a USB drive without a persistent partition and stopped at Tails Greeter's login screen # features/step_definitions/snapshots.rb:172
      The Dogtail script raised: SearchError: child of [desktop frame | main]: "tails-installer" application (RuntimeError)
      ./features/support/helpers/dogtail.rb:81:in `run'
      ./features/support/helpers/dogtail.rb:70:in `initialize'
      ./features/step_definitions/usb.rb:95:in `new'
      ./features/step_definitions/usb.rb:95:in `/^I start Tails Installer$/'
      ./features/step_definitions/usb.rb:137:in `/^I (install|upgrade) Tails (?:to|on) USB drive "([^"]+)" (by cloning|from an ISO)$/'
      ./features/step_definitions/snapshots.rb:154:in `block in reach_checkpoint'
      ./features/step_definitions/snapshots.rb:152:in `each'
      ./features/step_definitions/snapshots.rb:152:in `reach_checkpoint'
      ./features/step_definitions/snapshots.rb:173:in `/^I\ have\ started\ Tails\ without\ network\ from\ a\ USB\ drive\ without\ a\ persistent\ partition\ and\ stopped\ at\ Tails\ Greeter's\ login\ screen$/'
      features/usb_install.feature:47:in `Given I have started Tails without network from a USB drive without a persistent partition and stopped at Tails Greeter's login screen'

But my last change should be safe (famous last words!) as it "just" does the same as I have already done in a number of other scenarios. So please test & merge it once the test suite is repaired, or reassign to me once it's repaired if you prefer.

#12 Updated by anonym 8 months ago

  • Assignee changed from anonym to sajolida

intrigeri wrote:

Actually I can't test it, apparently because the test suite has been broken by the merge of #8859:

[...]

But my last change should be safe (famous last words!) as it "just" does the same as I have already done in a number of other scenarios. So please test & merge it once the test suite is repaired, or reassign to me once it's repaired if you prefer.

Everything passes now, except things broken for unrelated reasons (#8860).

Reassigning to sajolida who has the only subtask of this ticket.

#13 Updated by intrigeri 8 months ago

  • Assignee changed from sajolida to anonym

anonym wrote:

Everything passes now, except things broken for unrelated reasons (#8860).

Well, these "things broken for unrelated reasons" are precisely what my commit is about.

#14 Updated by anonym 8 months ago

  • Assignee changed from anonym to sajolida

intrigeri wrote:

anonym wrote:

Everything passes now, except things broken for unrelated reasons (#8860).

Well, these "things broken for unrelated reasons" are precisely what my commit is about.

Merged now!

#15 Updated by anonym 8 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 75 to 100

#16 Updated by intrigeri 8 months ago

  • Status changed from Fix committed to In Progress

#17 Updated by sajolida 8 months ago

  • Status changed from In Progress to Fix committed
  • QA Check deleted (Ready for QA)

#18 Updated by sajolida 8 months ago

  • Assignee deleted (sajolida)

#19 Updated by anonym 8 months ago

  • Status changed from Fix committed to Resolved

#20 Updated by sajolida 8 months ago

#21 Updated by adamantium 3 months ago

A suggestion: on a 16gb usb, perhaps 8gb (half the storage) is more than is desirable for the system partition. It might be preferable to set this to 4gb just like for an 8gb stick. Also, is there a manual way to adjust the size of the system partition for those who would like to adjust this?

Also available in: Atom PDF