Project

General

Profile

Bug #12734

Thunderbird doesn't start if ~/.icedove exists and is empty

Added by goupille over 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Persistence
Target version:
Start date:
06/19/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/12734-claws-persistence-breaks-thunderbird
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Email Client

Description

as a workaround, set up an administrator password in the greeter, then after Tails has started, open a terminal and type

sudo sed -i '/icedove/d' /live/persistence/TailsData_unlocked/persistence.conf

and enter.


Related issues

Related to Tails - Feature #12242: Adjust to Icedove → Thunderbird Resolved 02/16/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

Associated revisions

Revision 29f6b785 (diff)
Added by intrigeri 10 months ago

Drop Claws Mail persistence setting migration (refs: #12734).

Whenever persistent Claws Mail setting is enabled, this creates an empty
~/.icedove/ directory, that prevents Thunderbird from starting.

Revision a4e155f6
Added by anonym 9 months ago

Merge remote-tracking branch 'origin/bugfix/12734-claws-persistence-breaks-thunderbird' into stable

Fix-committed: #12734

History

#1 Updated by goupille over 1 year ago

a user affected by this issue reported that deleting the icedove line from /live/persistence/TailsData_unlocked/persistence.conf doesn't fix the issue because during Tails startup a script add the line to persistence.conf and /live/persistence/TailsData_unlocked/icedove is created again

#2 Updated by u over 1 year ago

  • Category set to Persistence

#3 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Low
  • Target version set to Tails_3.2
  • Affected tool set to Email Client

4-5 affected users reported this bug, but they've all migrated successfully now. So at the help desk / foundations team meeting today, we deemed this ticket as low-priority. FWIW I've seen another similar report on XMPP today. Please don't spend too much time on it: if the fix is trivial, or a workaround can be documented easily, do so; if it's any harder, reject.

#4 Updated by anonym over 1 year ago

#5 Updated by anonym over 1 year ago

Hypothesis: the affected users once migrated from Claws Mail. The code we still have for the Claws -> Icedove migration in live-persist creates the empty icedove folder which causes this problem.

#6 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

(Given how anonym's plate for 3.2 looks like, I doubt this should be prioritized for this release. And it's not worth our time to do it later as most affected users should have bypassed this limitation already, so rejecting.)

#7 Updated by anonym about 1 year ago

  • Target version changed from Tails_3.2 to Tails_3.3

#8 Updated by anonym about 1 year ago

  • Target version changed from Tails_3.3 to Tails_3.2

#9 Updated by goupille 10 months ago

  • Assignee set to anonym

a user reported this issue with Tails 3.3, the workaround provided solved the problem... I don't know if that worth documenting it in the known issues list though.

#10 Updated by intrigeri 10 months ago

  • Status changed from Rejected to In Progress
  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_3.2 to Tails_3.5
  • Feature Branch set to bugfix/12734-claws-persistence-breaks-thunderbird

intrigeri wrote:

most affected users should have bypassed this limitation already, so rejecting.

Apparently not. It seems trivial to avoid creating more instances of this problem, let's do it.

#11 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

(Disclaimer: I've not even bothered building an ISO given this change feels as non-risky as it can possibly be.)

#12 Updated by intrigeri 10 months ago

And FWIW we had agreed on #12242#note-12 to do this but apparently we forgot.

#13 Updated by intrigeri 10 months ago

#14 Updated by anonym 9 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Verified that the fix works => merged.

#15 Updated by anonym 9 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF