Project

General

Profile

Feature #13232

Feature #13246: Core work

Feature #13247: Core work 2017Q2

Core work 2017Q2: Sysadmin (Maintain our already existing services)

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
06/29/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Easy:
Affected tool:

Description

2017Q2 is almost over, so this is meant to be an example (similar to #12431 & #12432) to feed the discussion about how we handle time-based core work.

Note: this was reverse-engineered from Puppet Git logs, so it probably lacks lots of work that was done.


Related issues

Related to Tails - Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services) Resolved 06/29/2017
Blocked by Tails - Feature #11523: Check if no packages are left unupgraded Resolved 06/10/2016
Blocked by Tails - Bug #13134: The Debian mirror used as upstream for our time-based snapshots is buggy Resolved 06/24/2017
Blocked by Tails - Bug #12414: Fix for forcing Puppet 3.x is incomplete Resolved 04/01/2017
Blocked by Tails - Bug #13138: Cucumber segfaults on Jenkins isotesters Resolved 06/26/2017
Blocked by Tails - Bug #12565: Test failures on Jenkins due to lack of disk space Resolved 05/19/2017
Blocked by Tails - Bug #12097: Don't run Puppet via cron on isotesters Resolved 12/29/2016
Blocked by Tails - Bug #12422: Broken Puppet status on (at least) ecours and puppet-git.lizard Resolved 04/02/2017
Blocked by Tails - Bug #12425: www.lizard's system partition is too full Resolved 04/03/2017
Blocked by Tails - Bug #13177: Sort out the bitcoin-disk partition situation on lizard Resolved 06/27/2017

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Description updated (diff)

#4 Updated by intrigeri 5 months ago

  • Blocked by Feature #11523: Check if no packages are left unupgraded added

#5 Updated by intrigeri 5 months ago

  • Blocked by Bug #13134: The Debian mirror used as upstream for our time-based snapshots is buggy added

#6 Updated by intrigeri 5 months ago

  • Blocked by Feature #5894: APT repository: notify incoming added

#7 Updated by intrigeri 5 months ago

  • Blocked by Bug #12414: Fix for forcing Puppet 3.x is incomplete added

#9 Updated by intrigeri 5 months ago

  • Blocked by Bug #13138: Cucumber segfaults on Jenkins isotesters added

#10 Updated by intrigeri 5 months ago

  • Blocked by Feature #11179: Enable automatic NUMA balancing on lizard added

#11 Updated by intrigeri 5 months ago

  • Blocked by Bug #12565: Test failures on Jenkins due to lack of disk space added

#12 Updated by intrigeri 5 months ago

  • Blocked by Bug #12097: Don't run Puppet via cron on isotesters added

#13 Updated by intrigeri 5 months ago

  • Blocked by Bug #12422: Broken Puppet status on (at least) ecours and puppet-git.lizard added

#14 Updated by intrigeri 5 months ago

  • Blocked by Bug #12425: www.lizard's system partition is too full added

#15 Updated by intrigeri 5 months ago

  • Assignee deleted (intrigeri)

#16 Updated by intrigeri 5 months ago

  • Blocked by Bug #12463: MariaDB backups on buse, ecours and puppet-git.lizard trigger useless/noisy email notifications since the upgrade to Stretch added

#17 Updated by intrigeri 5 months ago

  • Blocked by Bug #12506: Ticket accidentally deleted #11395 added

#18 Updated by intrigeri 5 months ago

  • Related to Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services) added

#19 Updated by intrigeri 5 months ago

  • Parent task set to #13247

#20 Updated by intrigeri 5 months ago

  • Description updated (diff)
  • Assignee set to intrigeri

#21 Updated by intrigeri 5 months ago

  • Related to deleted (Feature #12432: Technical writing core work 2017Q2)

#22 Updated by intrigeri 5 months ago

#23 Updated by intrigeri 5 months ago

  • Blocked by deleted (Feature #11179: Enable automatic NUMA balancing on lizard)

#24 Updated by intrigeri 5 months ago

  • Blocked by Bug #13177: Sort out the bitcoin-disk partition situation on lizard added

#25 Updated by intrigeri 5 months ago

  • Blocked by deleted (Feature #5894: APT repository: notify incoming)

#26 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12463: MariaDB backups on buse, ecours and puppet-git.lizard trigger useless/noisy email notifications since the upgrade to Stretch)

#27 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12506: Ticket accidentally deleted #11395)

#28 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

Q2 is over.

Also available in: Atom PDF