Project

General

Profile

Feature #13234

Feature #13246: Core work

Feature #13248: Core work 2017Q3

Core work 2017Q3: Foundations Team

Added by intrigeri 12 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/29/2017
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #13178: Upgrade to Stretch 9.1 in Tails 3.1 Resolved 07/22/2017
Blocked by Tails - Feature #12634: Drop the old Greeter support infrastructure once we don't ship it anymore Resolved 06/03/2017
Blocked by Tails - Bug #13000: Behaviour of power button in the Greeter is not consistent with the one in the regular GNOME session Resolved 06/23/2017
Blocked by Tails - Bug #12733: Seahorse fails to import private PGP keys: pinentry-gtk-2 passphrase prompt not displayed Resolved 06/19/2017
Blocked by Tails - Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations Resolved 04/10/2017
Blocked by Tails - Feature #12310: Re-enable torproject-obfs4proxy APT sources once they have packages newer than Stretch's ones Rejected 03/08/2017
Blocked by Tails - Feature #12732: Upgrade Linux to 4.12 Resolved 06/18/2017
Blocked by Tails - Bug #12034: When running Nautilus from a Root Terminal, start it silently and immediately give the prompt back Resolved 12/14/2016
Blocked by Tails - Feature #12705: Update the size of the system partition to >= 4 GiB Resolved 06/15/2017
Blocked by Tails - Feature #12707: Bump the size of the system partition created by Tails Installer Resolved 06/15/2017
Blocked by Tails - Feature #12706: Adjust the documentation wrt. updated system partition size Resolved 06/15/2017
Blocked by Tails - Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard Resolved 11/20/2014
Blocked by Tails - Feature #11840: Increase mmap randomization to the maximum supported value Resolved 09/25/2016
Blocked by Tails - Bug #12730: Laptop screen with lid closed is configured as the primary display Resolved 06/17/2017
Blocked by Tails - Bug #8917: Spurious "permission denied" error when trying to upload files from Tor Browser Resolved 02/18/2015
Blocked by Tails - Bug #12655: Build instructions are broken on Jessie Resolved 06/08/2017
Blocked by Tails - Feature #12639: Upgrade Thunderbird to 52.x Resolved 06/05/2017
Blocked by Tails - Bug #12658: Verify that automatic Tor Browser updates are disabled with 7.0 Resolved 06/09/2017
Blocked by Tails - Bug #12684: Update config/build-manifest-extra-packages.yml Resolved 06/12/2017
Blocked by Tails - Bug #12685: Drop obsolete functions from tails-shell-library/*.sh Resolved 06/12/2017
Blocked by Tails - Bug #12686: Re-introduce the BookletImposer PDF imposition toolkit Resolved 06/12/2017
Blocked by Tails - Bug #12687: Install a lighter version of Vim Resolved 06/12/2017
Blocked by Tails - Bug #12680: Persistent Thunderbird blocks future 0000tails.js prefs changes Resolved 06/10/2017
Blocked by Tails - Feature #11399: Audit Icedove and TorBirdy as feed reader in Tails Duplicate 05/05/2016
Blocked by Tails - Bug #12734: Thunderbird doesn't start if ~/.icedove exists and is empty Resolved 06/19/2017
Blocked by Tails - Bug #13416: Restore APT pinning of deb.tp.o Resolved 07/04/2017
Blocked by Tails - Bug #13253: Upgrade Tor to 0.3.0.9 Resolved 06/30/2017
Blocked by Tails - Bug #13462: Memory erasure on boot medium removal is fragile Resolved 07/12/2017
Blocked by Tails - Bug #13449: German language missing from Greeter in Tails 3.0.1 Rejected 07/10/2017
Blocked by Tails - Bug #13456: Running Tails 3.01 with Language German has a serious bug Rejected 07/12/2017
Blocked by Tails - Bug #13340: Thunderbird stores temporary files (included decrypted attachements) indefinitely Resolved 07/01/2017
Blocked by Tails - Feature #13513: Replace syslinux:i386 with syslinux:amd64 in the ISO9660 filesystem Resolved 07/25/2017
Blocked by Tails - Bug #13530: ISO builds are broken by weird enigmail situation Resolved 07/29/2017
Blocked by Tails - Feature #14485: Distribute shares of our updated signing key Resolved 08/28/2017
Blocked by Tails - Feature #11747: Update our OpenPGP keys in 2017 Resolved 08/30/2016
Blocked by Tails - Feature #14483: Include the new signing subkeys & publish them on keyservers Resolved 08/28/2017
Blocked by Tails - Feature #14514: Porting Tails to Buster: organize first code + test suite sprint Resolved 08/30/2017
Blocked by Tails - Feature #14577: Porting Tails to Buster: organize second code + test suite sprint Resolved 08/30/2017
Blocked by Tails - Bug #14459: Some branches fail to build an ISO because we merge their base branch too late Resolved 08/28/2017
Blocked by Tails - Bug #14602: devel branch FTBFS since torbrowser-launcher 0.2.8-1 made it into Debian Resolved 09/05/2017
Blocked by Tails - Bug #14606: Silence AppArmor logs for Tor Browser Resolved 09/07/2017
Blocked by Tails - Bug #14612: Pidgin exposes everything through its D-Bus service Resolved 09/07/2017
Blocked by Tails - Bug #14623: Tor Browser sandbox breakout via X11 testing extensions Confirmed 09/12/2017
Blocked by Tails - Bug #14655: Ensure Tails is not affected by BlueBorne Resolved 09/14/2017
Blocked by Tails - Feature #14696: Install Tor Browser 7.0.6 Resolved 09/21/2017
Blocked by Tails - Bug #14712: Display backlight brightness regressions in 3.2~rc1 Resolved 09/24/2017
Blocked by Tails - Bug #14735: stable branch FTBFS since the 3.2 release Resolved 09/29/2017

History

#1 Updated by intrigeri 12 months ago

  • Blocked by Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in added

#2 Updated by intrigeri 12 months ago

  • Blocked by Feature #13178: Upgrade to Stretch 9.1 in Tails 3.1 added

#3 Updated by intrigeri 12 months ago

  • Blocked by Feature #12634: Drop the old Greeter support infrastructure once we don't ship it anymore added

#4 Updated by intrigeri 12 months ago

  • Blocked by Bug #12460: Thunderbird doesn't use its dedicated SocksPort added

#5 Updated by intrigeri 12 months ago

  • Blocked by Bug #13000: Behaviour of power button in the Greeter is not consistent with the one in the regular GNOME session added

#6 Updated by intrigeri 12 months ago

  • Blocked by Bug #12733: Seahorse fails to import private PGP keys: pinentry-gtk-2 passphrase prompt not displayed added

#7 Updated by intrigeri 12 months ago

  • Blocked by Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations added

#8 Updated by intrigeri 12 months ago

  • Blocked by Feature #12310: Re-enable torproject-obfs4proxy APT sources once they have packages newer than Stretch's ones added

#9 Updated by intrigeri 12 months ago

  • Blocked by Feature #12615: Consider basing Tails on quarterly snapshots of Debian testing added

#10 Updated by intrigeri 12 months ago

  • Blocked by Bug #12679: Sandbox Tor Browser's content renderer processes more strictly added

#11 Updated by intrigeri 12 months ago

#12 Updated by intrigeri 12 months ago

  • Blocked by Bug #12034: When running Nautilus from a Root Terminal, start it silently and immediately give the prompt back added

#13 Updated by intrigeri 12 months ago

  • Blocked by Feature #12605: APT snapshots: drop i386 architecture added

#14 Updated by intrigeri 12 months ago

  • Blocked by Feature #12705: Update the size of the system partition to >= 4 GiB added

#15 Updated by intrigeri 12 months ago

  • Blocked by Feature #12707: Bump the size of the system partition created by Tails Installer added

#16 Updated by intrigeri 12 months ago

  • Blocked by Feature #12706: Adjust the documentation wrt. updated system partition size added

#17 Updated by intrigeri 12 months ago

  • Blocked by Feature #8281: Consider replacing Florence with GNOME's own on-screen keyboard added

#18 Updated by intrigeri 12 months ago

  • Blocked by Feature #11840: Increase mmap randomization to the maximum supported value added

#19 Updated by intrigeri 12 months ago

  • Blocked by Bug #12730: Laptop screen with lid closed is configured as the primary display added

#20 Updated by intrigeri 12 months ago

  • Blocked by Feature #11753: Port complex shell scripts shipped in /usr/local to Python added

#21 Updated by intrigeri 12 months ago

  • Blocked by Bug #12372: Get software-properties-gtk starting added

#22 Updated by intrigeri 12 months ago

  • Blocked by Bug #8917: Spurious "permission denied" error when trying to upload files from Tor Browser added

#23 Updated by intrigeri 12 months ago

  • Blocked by Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons added

#24 Updated by intrigeri 12 months ago

  • Blocked by Bug #12152: Update tails-installer release process added

#25 Updated by intrigeri 12 months ago

  • Blocked by Bug #12655: Build instructions are broken on Jessie added

#26 Updated by intrigeri 12 months ago

  • Blocked by Bug #11964: Discuss if Thunderbird AppArmor profile should prevent users from opening attachments added

#27 Updated by intrigeri 12 months ago

  • Blocked by Bug #11973: Confine Thunderbird with AppArmor added

#28 Updated by intrigeri 12 months ago

#29 Updated by intrigeri 12 months ago

  • Blocked by Bug #12658: Verify that automatic Tor Browser updates are disabled with 7.0 added

#30 Updated by intrigeri 12 months ago

  • Blocked by Bug #12684: Update config/build-manifest-extra-packages.yml added

#31 Updated by intrigeri 12 months ago

  • Blocked by Bug #12685: Drop obsolete functions from tails-shell-library/*.sh added

#32 Updated by intrigeri 12 months ago

  • Blocked by Bug #12686: Re-introduce the BookletImposer PDF imposition toolkit added

#33 Updated by intrigeri 12 months ago

  • Blocked by Bug #12687: Install a lighter version of Vim added

#34 Updated by intrigeri 12 months ago

#35 Updated by intrigeri 12 months ago

  • Blocked by Bug #12680: Persistent Thunderbird blocks future 0000tails.js prefs changes added

#36 Updated by intrigeri 12 months ago

  • Blocked by Bug #12123: Use aa-status --json instead of manual parsing of /proc/PID/attr/current in onion-grater added

#37 Updated by intrigeri 12 months ago

  • Blocked by Feature #7626: Investigate using Thunderbird & TorBirdy as the RSS reader added

#38 Updated by intrigeri 12 months ago

  • Blocked by Feature #11399: Audit Icedove and TorBirdy as feed reader in Tails added

#39 Updated by u 12 months ago

  • Assignee set to intrigeri

Adding intrigeri as assignee just for tracking.

#40 Updated by anonym 12 months ago

  • Blocked by Bug #12151: Get Thunderbird's test suite running and test our patches added

#41 Updated by anonym 12 months ago

  • Blocked by Feature #12690: Gather & analyze data about the Stretch cycle: test suite added

#42 Updated by anonym 12 months ago

  • Blocked by Bug #12734: Thunderbird doesn't start if ~/.icedove exists and is empty added

#43 Updated by intrigeri 12 months ago

  • Parent task set to #13248

#44 Updated by anonym 12 months ago

  • Blocked by Feature #12545: Install Electrum >= 2.8.0 for Digital Bitbox hardware wallet support added

#45 Updated by anonym 12 months ago

  • Blocked by Bug #11411: Vagrant build doc should tell what filesystem permissions must be granted to the libvirt-qemu user added

#46 Updated by anonym 12 months ago

  • Blocked by Feature #7526: Fix Vagrant situation or replace it added

#47 Updated by anonym 12 months ago

  • Blocked by deleted (Feature #12690: Gather & analyze data about the Stretch cycle: test suite)

#48 Updated by anonym 12 months ago

  • Blocked by Bug #12557: The mergebasebranch option does the base branch merge too late added

#49 Updated by anonym 12 months ago

  • Blocked by deleted (Bug #12151: Get Thunderbird's test suite running and test our patches)

#50 Updated by anonym 12 months ago

  • Blocked by deleted (Feature #12545: Install Electrum >= 2.8.0 for Digital Bitbox hardware wallet support)

#51 Updated by intrigeri 12 months ago

  • Blocked by Bug #13416: Restore APT pinning of deb.tp.o added

#52 Updated by intrigeri 12 months ago

  • Blocked by Bug #13253: Upgrade Tor to 0.3.0.9 added

#53 Updated by intrigeri 11 months ago

  • Blocked by Bug #13462: Memory erasure on boot medium removal is fragile added

#54 Updated by intrigeri 11 months ago

  • Blocked by Bug #13449: German language missing from Greeter in Tails 3.0.1 added

#55 Updated by intrigeri 11 months ago

  • Blocked by Bug #13456: Running Tails 3.01 with Language German has a serious bug added

#56 Updated by intrigeri 11 months ago

  • Blocked by Bug #13437: Translations of notifications about clock and Tor are not applied added

#57 Updated by intrigeri 11 months ago

  • Blocked by Bug #13403: Can't print to file from Tor Browser when Tails session not in English added

#58 Updated by intrigeri 11 months ago

  • Blocked by Bug #13340: Thunderbird stores temporary files (included decrypted attachements) indefinitely added

#59 Updated by intrigeri 11 months ago

  • Blocked by Bug #12724: Virtualbox shared folders are not automatically mounted in Tails 3.0 added

#60 Updated by intrigeri 11 months ago

  • Blocked by Feature #13513: Replace syslinux:i386 with syslinux:amd64 in the ISO9660 filesystem added

#61 Updated by intrigeri 11 months ago

  • Blocked by deleted (Feature #12605: APT snapshots: drop i386 architecture)

#62 Updated by intrigeri 11 months ago

  • Blocked by Bug #13530: ISO builds are broken by weird enigmail situation added

#63 Updated by intrigeri 10 months ago

  • Blocked by Feature #14485: Distribute shares of our updated signing key added

#64 Updated by intrigeri 10 months ago

#65 Updated by intrigeri 10 months ago

  • Blocked by Feature #14483: Include the new signing subkeys & publish them on keyservers added

#66 Updated by intrigeri 10 months ago

  • Blocked by Feature #14514: Porting Tails to Buster: organize first code + test suite sprint added

#67 Updated by intrigeri 10 months ago

  • Blocked by Feature #14577: Porting Tails to Buster: organize second code + test suite sprint added

#68 Updated by intrigeri 10 months ago

  • Blocked by Feature #14578: Decide when we want to release Tails based on Debian Buster added

#69 Updated by intrigeri 10 months ago

  • Blocked by Feature #14579: Tell the Technical Writers what part of our doc needs to be updated for Buster added

#71 Updated by intrigeri 10 months ago

  • Blocked by Bug #14459: Some branches fail to build an ISO because we merge their base branch too late added

#72 Updated by intrigeri 10 months ago

  • Blocked by Bug #14602: devel branch FTBFS since torbrowser-launcher 0.2.8-1 made it into Debian added

#73 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #7526: Fix Vagrant situation or replace it)

#74 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #11411: Vagrant build doc should tell what filesystem permissions must be granted to the libvirt-qemu user)

#75 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #7626: Investigate using Thunderbird & TorBirdy as the RSS reader)

#76 Updated by intrigeri 9 months ago

  • Blocked by Bug #14606: Silence AppArmor logs for Tor Browser added

#77 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12460: Thunderbird doesn't use its dedicated SocksPort)

#78 Updated by intrigeri 9 months ago

  • Blocked by Bug #14612: Pidgin exposes everything through its D-Bus service added

#79 Updated by intrigeri 9 months ago

  • Blocked by Bug #14623: Tor Browser sandbox breakout via X11 testing extensions added

#80 Updated by intrigeri 9 months ago

  • Blocked by Bug #14655: Ensure Tails is not affected by BlueBorne added

#81 Updated by intrigeri 9 months ago

#82 Updated by intrigeri 9 months ago

  • Blocked by Bug #14712: Display backlight brightness regressions in 3.2~rc1 added

#83 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14579: Tell the Technical Writers what part of our doc needs to be updated for Buster)

#84 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14578: Decide when we want to release Tails based on Debian Buster)

#85 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #11082: Replace Liferea)

#86 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12123: Use aa-status --json instead of manual parsing of /proc/PID/attr/current in onion-grater)

#87 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #13403: Can't print to file from Tor Browser when Tails session not in English)

#88 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12679: Sandbox Tor Browser's content renderer processes more strictly)

#89 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #12615: Consider basing Tails on quarterly snapshots of Debian testing)

#90 Updated by intrigeri 9 months ago

  • Blocked by Bug #14735: stable branch FTBFS since the 3.2 release added

#91 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12724: Virtualbox shared folders are not automatically mounted in Tails 3.0)

#92 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons)

#93 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12557: The mergebasebranch option does the base branch merge too late)

#94 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12152: Update tails-installer release process)

#95 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #13437: Translations of notifications about clock and Tor are not applied)

#96 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in)

#97 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12372: Get software-properties-gtk starting)

#98 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #11964: Discuss if Thunderbird AppArmor profile should prevent users from opening attachments)

#99 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #11973: Confine Thunderbird with AppArmor)

#100 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #11753: Port complex shell scripts shipped in /usr/local to Python)

#101 Updated by intrigeri 9 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

Postponed the remaining tickets.

Also available in: Atom PDF