Project

General

Profile

Feature #13239

Feature #13246: Core work

Feature #13248: Core work 2017Q3

Core work 2017Q3: Test suite maintenance

Added by intrigeri 6 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
06/29/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Feature #13240: Core work 2017Q4: Test suite maintenance Confirmed 06/29/2017
Related to Tails - Feature #13241: Core work 2018Q1: Test suite maintenance Confirmed 06/29/2017
Blocked by Tails - Bug #12299: Make up our mind wrt. what old ISO our test suite should use on Jenkins Resolved 03/05/2017
Blocked by Tails - Feature #12288: Deal with May 2017 false positive scenarios Resolved 05/05/2017 06/05/2017
Blocked by Tails - Bug #12371: Current method of obtaining the configured GnuPG keyserver is broken on Stretch Resolved 03/18/2017
Blocked by Tails - Feature #12690: Gather & analyze data about the Stretch cycle: test suite Rejected 06/13/2017
Blocked by Tails - Bug #14654: Test suite bits that use assert_raise fail on sid Resolved 09/13/2017
Blocked by Tails - Bug #14586: Test suite: take into account that click-to-play is not required anymore for WebM videos in Tor Browser Resolved 09/02/2017

History

#1 Updated by intrigeri 6 months ago

  • Related to Feature #13240: Core work 2017Q4: Test suite maintenance added

#2 Updated by intrigeri 6 months ago

  • Related to Feature #13241: Core work 2018Q1: Test suite maintenance added

#3 Updated by intrigeri 6 months ago

  • Parent task set to #13248

#4 Updated by anonym 6 months ago

  • Blocked by Bug #12299: Make up our mind wrt. what old ISO our test suite should use on Jenkins added

#5 Updated by anonym 6 months ago

  • Blocked by Feature #12288: Deal with May 2017 false positive scenarios added

#6 Updated by anonym 6 months ago

  • Blocked by Bug #11521: The check_tor_leaks hook is fragile added

#7 Updated by anonym 6 months ago

  • Blocked by Feature #12019: Test Totem's "Add local video" action added

#8 Updated by anonym 6 months ago

  • Blocked by Bug #12142: The nec-xhci virtual USB controller + tails-persistence-setup causes a VM freeze on Debian Stretch or newer hosts added

#9 Updated by anonym 6 months ago

  • Blocked by Bug #12371: Current method of obtaining the configured GnuPG keyserver is broken on Stretch added

#10 Updated by anonym 6 months ago

  • Blocked by Bug #12461: Test suite fails to enable persistence in "Persistent browser bookmarks" added

#11 Updated by anonym 6 months ago

  • Blocked by Bug #12621: The 'Tor is ready' step fails when any systemd service fails added

#12 Updated by anonym 6 months ago

  • Blocked by Feature #12652: Improve the 'I start ... via GNOME Activities Overview' step added

#13 Updated by anonym 6 months ago

  • Blocked by Bug #11892: Sometimes the remote shell doesn't start because of missing initial Space when modifying the kernel cmdline added

#14 Updated by anonym 6 months ago

  • Blocked by Bug #12557: The mergebasebranch option does the base branch merge too late added

#15 Updated by anonym 6 months ago

  • Blocked by Feature #10261: Test that the correct keyboard layout is set added

#16 Updated by anonym 6 months ago

  • Blocked by Feature #10265: Test that DDG is the default search engine in Tor Browser added

#17 Updated by anonym 6 months ago

  • Blocked by Feature #10277: Automatically test that Tails has booted correctly and without errors added

#18 Updated by anonym 6 months ago

  • Blocked by Feature #10278: Automatically test that services that we disable are not started added

#19 Updated by anonym 6 months ago

  • Blocked by Bug #11106: Improve test suite thanks to upstream Firefox fix for feedback when access to a local file is denied added

#20 Updated by anonym 6 months ago

  • Blocked by Bug #11457: "I close the Unsafe Browser" step is fragile added

#21 Updated by anonym 6 months ago

  • Blocked by Bug #11890: Checking credentials in Icedove autoconfig wizard sometimes fails in the test suite added

#22 Updated by anonym 6 months ago

#23 Updated by anonym 6 months ago

  • Blocked by Bug #11755: Dogtail does not work for X applications running as non-amnesia users added

#24 Updated by anonym 6 months ago

  • Blocked by Feature #12292: Deal with September 2017 false positive scenarios added

#25 Updated by anonym 6 months ago

  • Blocked by Feature #12690: Gather & analyze data about the Stretch cycle: test suite added

#26 Updated by anonym 6 months ago

  • Blocked by deleted (Bug #12557: The mergebasebranch option does the base branch merge too late)

#27 Updated by intrigeri 5 months ago

  • Blocked by Bug #12649: Deal with August 2017 false positive CI notifications added

#28 Updated by intrigeri 5 months ago

  • Blocked by Bug #12650: Deal with September 2017 false positive CI notifications added

#29 Updated by intrigeri 5 months ago

  • Blocked by Bug #12647: Deal with June 2107 false positive CI notifications added

#30 Updated by intrigeri 5 months ago

  • Blocked by Bug #12648: Deal with July 2017 false positive CI notifications added

#31 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12647: Deal with June 2107 false positive CI notifications)

#32 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12648: Deal with July 2017 false positive CI notifications)

#33 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12649: Deal with August 2017 false positive CI notifications)

#34 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #12650: Deal with September 2017 false positive CI notifications)

#35 Updated by intrigeri 3 months ago

  • Blocked by Bug #14654: Test suite bits that use assert_raise fail on sid added

#36 Updated by intrigeri 3 months ago

  • Blocked by Bug #14586: Test suite: take into account that click-to-play is not required anymore for WebM videos in Tor Browser added

#37 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #10261: Test that the correct keyboard layout is set )

#38 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #10278: Automatically test that services that we disable are not started)

#39 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #10277: Automatically test that Tails has booted correctly and without errors)

#40 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #10265: Test that DDG is the default search engine in Tor Browser)

#41 Updated by intrigeri 3 months ago

  • Blocked by deleted (Feature #12652: Improve the 'I start ... via GNOME Activities Overview' step)

#42 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #12621: The 'Tor is ready' step fails when any systemd service fails)

#43 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #12461: Test suite fails to enable persistence in "Persistent browser bookmarks")

#44 Updated by intrigeri 2 months ago

  • Blocked by deleted (Feature #12292: Deal with September 2017 false positive scenarios)

#45 Updated by intrigeri 2 months ago

#46 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11892: Sometimes the remote shell doesn't start because of missing initial Space when modifying the kernel cmdline)

#47 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11890: Checking credentials in Icedove autoconfig wizard sometimes fails in the test suite)

#48 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11521: The check_tor_leaks hook is fragile)

#49 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11106: Improve test suite thanks to upstream Firefox fix for feedback when access to a local file is denied)

#50 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #12142: The nec-xhci virtual USB controller + tails-persistence-setup causes a VM freeze on Debian Stretch or newer hosts)

#51 Updated by intrigeri 2 months ago

  • Blocked by deleted (Feature #12019: Test Totem's "Add local video" action)

#52 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11755: Dogtail does not work for X applications running as non-amnesia users)

#53 Updated by intrigeri 2 months ago

  • Blocked by deleted (Bug #11457: "I close the Unsafe Browser" step is fragile)

#54 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)

Also available in: Atom PDF