Project

General

Profile

Feature #13240

Feature #13246: Core work

Feature #13249: Core work 2017Q4

Core work 2017Q4: Test suite maintenance

Added by intrigeri 8 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Test suite
Target version:
Start date:
06/29/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Feature #13239: Core work 2017Q3: Test suite maintenance Resolved 06/29/2017
Related to Tails - Feature #13241: Core work 2018Q1: Test suite maintenance Confirmed 06/29/2017
Blocked by Tails - Bug #14719: Test suite fails to attach virtual USB disk with QEMU 2.10 and AppArmor enabled Resolved 09/25/2017
Blocked by Tails - Bug #12142: The nec-xhci virtual USB controller + tails-persistence-setup causes a VM freeze on Debian Stretch or newer hosts Rejected 01/13/2017
Blocked by Tails - Feature #12291: Deal with August 2017 false positive scenarios Resolved 08/05/2017 09/05/2017
Blocked by Tails - Feature #12290: Deal with July 2017 false positive scenarios Resolved 07/05/2017 08/05/2017
Blocked by Tails - Bug #14772: Test suite reports incomplete (and thus useless) info when systemctl is-system-running fails Resolved 10/04/2017
Blocked by Tails - Bug #14819: The "I hotplug a network device" step is broken in some environments Resolved 10/09/2017
Blocked by Tails - Feature #14814: Analyze test suite results on Buster: 2017-10 sprint Rejected 10/09/2017
Blocked by Tails - Feature #14817: Test suite improvements from buster sprint 1 Resolved 10/22/2017
Blocked by Tails - Bug #14874: "Failing to add a certificate to Pidgin" test scenario always fails on devel since Sikuli fuzzy matching was implemented Resolved 10/22/2017
Blocked by Tails - Bug #14929: 'I can view a file stored in "~/Tor Browser" but not in ~/.gnupg' scenario is broken Resolved 11/07/2017
Blocked by Tails - Bug #15007: "Pidgin's D-Bus interface is not available" test suite step fails Resolved 11/29/2017

History

#1 Updated by intrigeri 8 months ago

  • Related to Feature #13239: Core work 2017Q3: Test suite maintenance added

#2 Updated by intrigeri 8 months ago

  • Related to Feature #13241: Core work 2018Q1: Test suite maintenance added

#3 Updated by intrigeri 8 months ago

  • Parent task set to #13249

#4 Updated by intrigeri 6 months ago

  • Blocked by Bug #14586: Test suite: take into account that click-to-play is not required anymore for WebM videos in Tor Browser added

#5 Updated by intrigeri 5 months ago

  • Blocked by deleted (Bug #14586: Test suite: take into account that click-to-play is not required anymore for WebM videos in Tor Browser)

#6 Updated by intrigeri 5 months ago

  • Blocked by Bug #14719: Test suite fails to attach virtual USB disk with QEMU 2.10 and AppArmor enabled added

#7 Updated by intrigeri 5 months ago

  • Blocked by Bug #12621: The 'Tor is ready' step fails when any systemd service fails added

#8 Updated by intrigeri 5 months ago

  • Blocked by Bug #12461: Test suite fails to enable persistence in "Persistent browser bookmarks" added

#9 Updated by intrigeri 5 months ago

  • Blocked by Feature #12292: Deal with September 2017 false positive scenarios added

#10 Updated by intrigeri 5 months ago

#11 Updated by intrigeri 5 months ago

  • Blocked by Bug #11892: Sometimes the remote shell doesn't start because of missing initial Space when modifying the kernel cmdline added

#12 Updated by intrigeri 5 months ago

  • Blocked by Bug #11890: Checking credentials in Icedove autoconfig wizard sometimes fails in the test suite added

#13 Updated by intrigeri 5 months ago

  • Blocked by Bug #11521: The check_tor_leaks hook is fragile added

#14 Updated by intrigeri 5 months ago

  • Blocked by Bug #11106: Improve test suite thanks to upstream Firefox fix for feedback when access to a local file is denied added

#15 Updated by intrigeri 5 months ago

  • Blocked by Bug #12142: The nec-xhci virtual USB controller + tails-persistence-setup causes a VM freeze on Debian Stretch or newer hosts added

#16 Updated by intrigeri 5 months ago

  • Blocked by Feature #12019: Test Totem's "Add local video" action added

#17 Updated by intrigeri 5 months ago

  • Blocked by Bug #11755: Dogtail does not work for X applications running as non-amnesia users added

#18 Updated by intrigeri 5 months ago

  • Blocked by Bug #11457: "I close the Unsafe Browser" step is fragile added

#19 Updated by intrigeri 5 months ago

  • Blocked by Feature #12291: Deal with August 2017 false positive scenarios added

#20 Updated by intrigeri 5 months ago

  • Blocked by Feature #12290: Deal with July 2017 false positive scenarios added

#21 Updated by anonym 5 months ago

  • Blocked by Feature #14585: Investigate Dogtail's long-term viability added

#22 Updated by intrigeri 5 months ago

  • Blocked by Bug #14772: Test suite reports incomplete (and thus useless) info when systemctl is-system-running fails added

#23 Updated by intrigeri 4 months ago

  • Blocked by Bug #14819: The "I hotplug a network device" step is broken in some environments added

#24 Updated by intrigeri 4 months ago

  • Blocked by Feature #14814: Analyze test suite results on Buster: 2017-10 sprint added

#25 Updated by intrigeri 4 months ago

  • Blocked by Feature #14817: Test suite improvements from buster sprint 1 added

#26 Updated by intrigeri 4 months ago

  • Blocked by Bug #14874: "Failing to add a certificate to Pidgin" test scenario always fails on devel since Sikuli fuzzy matching was implemented added

#27 Updated by intrigeri 3 months ago

  • Blocked by Bug #14929: 'I can view a file stored in "~/Tor Browser" but not in ~/.gnupg' scenario is broken added

#28 Updated by intrigeri 3 months ago

  • Blocked by Bug #14935: Future-proof the test suite vs future fundraising campaign headers added

#29 Updated by intrigeri 3 months ago

  • Blocked by Bug #15006: Test suite regression: "I successfully start the Unsafe Browser" fails since Tails 3.3 added

#30 Updated by intrigeri 3 months ago

  • Blocked by Bug #15007: "Pidgin's D-Bus interface is not available" test suite step fails added

#31 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #14935: Future-proof the test suite vs future fundraising campaign headers)

#32 Updated by intrigeri about 2 months ago

  • Blocked by Bug #14935: Future-proof the test suite vs future fundraising campaign headers added

#33 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #12621: The 'Tor is ready' step fails when any systemd service fails)

#34 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #12461: Test suite fails to enable persistence in "Persistent browser bookmarks")

#35 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #14935: Future-proof the test suite vs future fundraising campaign headers)

#36 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Feature #12292: Deal with September 2017 false positive scenarios)

#37 Updated by intrigeri about 2 months ago

#38 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11521: The check_tor_leaks hook is fragile)

#39 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11106: Improve test suite thanks to upstream Firefox fix for feedback when access to a local file is denied)

#40 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #15006: Test suite regression: "I successfully start the Unsafe Browser" fails since Tails 3.3)

#41 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Feature #14585: Investigate Dogtail's long-term viability)

#42 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Feature #12019: Test Totem's "Add local video" action)

#43 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11892: Sometimes the remote shell doesn't start because of missing initial Space when modifying the kernel cmdline)

#44 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11890: Checking credentials in Icedove autoconfig wizard sometimes fails in the test suite)

#45 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11755: Dogtail does not work for X applications running as non-amnesia users)

#46 Updated by intrigeri about 2 months ago

  • Blocked by deleted (Bug #11457: "I close the Unsafe Browser" step is fragile)

#47 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to Fix committed

#48 Updated by intrigeri about 1 month ago

  • Target version changed from Tails_3.5 to Tails_3.4

#49 Updated by anonym about 1 month ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF