Project

General

Profile

Feature #13244

Feature #13246: Core work

Feature #13249: Core work 2017Q4

Core work 2017Q4: Foundations Team

Added by intrigeri about 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/29/2017
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #14714: Consider upgrading to Stretch 9.2 in Tails 3.3 Resolved 09/24/2017
Blocked by Tails - Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in Resolved 05/16/2017
Blocked by Tails - Feature #14789: Upgrade to Linux 4.13 Resolved 10/05/2017
Blocked by Tails - Feature #14791: Design how the Foundations Team will tell the Technical Writers what part of our doc needs to be updated Resolved 10/05/2017
Blocked by Tails - Feature #14870: Check what to do wrt. Tor Browser 7.0.7 Resolved 10/20/2017
Blocked by Tails - Bug #14906: devel branch FTBFS since the upgrade of virtualbox-guest-dkms to 5.2.0-dfsg-1 Resolved 10/29/2017
Blocked by Tails - Bug #14763: It should be possible to turn off the on-screen keyboard if desired Resolved 10/03/2017
Blocked by Tails - Bug #14923: devel branch FTBFS since torbrowser-launcher 0.2.8-4 was uploaded Resolved 11/06/2017
Blocked by Tails - Bug #14927: deb.tails.boum.org archive signing key needs to be updated Resolved 11/07/2017
Blocked by Tails - Bug #14940: Upgrade Tor Browser to 7.0.10 Resolved 11/09/2017
Blocked by Tails - Bug #14931: Tails mounts a windows boot partition with amnesia rights Rejected 11/07/2017
Blocked by Tails - Bug #14959: Test UEFI boot with a Tails installed with UUI Resolved 11/11/2017
Blocked by Tails - Bug #8992: USB sticks installed with UUI fail to boot in UEFI mode: "no configuration file found" Resolved 03/02/2015
Blocked by Tails - Feature #14963: Upgrade Thunderbird to one based on 52.4.0-1~deb9u1 Resolved 11/13/2017
Blocked by Tails - Bug #14990: Integrated graphics in Intel i5-7300HQ need xorg-device=intel Resolved 11/18/2017
Blocked by Tails - Bug #14993: uBlock is broken in Tails 3.3 Resolved 11/19/2017
Blocked by Tails - Feature #14999: Upgrade to Stretch 9.3 Resolved 11/25/2017
Blocked by Tails - Bug #15018: Decide if we do a Tails 3.3.1 emergency release Resolved 12/06/2017
Blocked by Tails - Bug #15019: Upgrade tor to 0.3.1.9+ Resolved 12/06/2017
Blocked by Tails - Bug #14971: Remove translations of translations (sic) on unsafe browser warning Resolved 11/16/2017
Blocked by Tails - Bug #14964: Boot from slow medium in Tails 3.3 is extremely slow Resolved 11/14/2017
Blocked by Tails - Bug #15055: sudo is required to build tails but it is not documented Resolved 12/14/2017

History

#1 Updated by intrigeri about 1 year ago

  • Parent task set to #13249

#2 Updated by intrigeri about 1 year ago

  • Blocked by Bug #12460: Thunderbird doesn't use its dedicated SocksPort added

#3 Updated by intrigeri 12 months ago

  • Blocked by Feature #14714: Consider upgrading to Stretch 9.2 in Tails 3.3 added

#4 Updated by intrigeri 12 months ago

  • Blocked by Feature #14579: Tell the Technical Writers what part of our doc needs to be updated for Buster added

#5 Updated by intrigeri 12 months ago

  • Blocked by Feature #14578: Decide when we want to release Tails based on Debian Bullseye added

#6 Updated by intrigeri 12 months ago

#7 Updated by intrigeri 12 months ago

  • Blocked by Bug #13403: Can't print to file from Tor Browser when Tails session not in English added

#8 Updated by intrigeri 12 months ago

  • Blocked by Bug #12679: Sandbox Tor Browser's content renderer processes more strictly added

#9 Updated by intrigeri 12 months ago

  • Blocked by Feature #12615: Consider basing Tails on quarterly snapshots of Debian testing added

#10 Updated by intrigeri 12 months ago

  • Blocked by Bug #12724: Virtualbox shared folders are not automatically mounted in Tails 3.0 added

#11 Updated by intrigeri 12 months ago

  • Blocked by Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons added

#12 Updated by intrigeri 12 months ago

  • Blocked by Bug #12152: Update tails-installer release process added

#13 Updated by intrigeri 12 months ago

  • Blocked by Bug #13437: Translations of notifications about clock and Tor are not applied added

#14 Updated by intrigeri 12 months ago

  • Blocked by Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in added

#15 Updated by intrigeri 12 months ago

  • Blocked by Bug #12372: Get software-properties-gtk starting / fix /etc/os-release added

#16 Updated by intrigeri 12 months ago

#17 Updated by intrigeri 12 months ago

  • Blocked by Feature #14791: Design how the Foundations Team will tell the Technical Writers what part of our doc needs to be updated added

#18 Updated by intrigeri 12 months ago

  • Blocked by Feature #14823: Simulate tracking of security updates on a frozen Buster stable branch between Buster sprint #1 and #2 added

#19 Updated by intrigeri 11 months ago

  • Blocked by Feature #14870: Check what to do wrt. Tor Browser 7.0.7 added

#20 Updated by intrigeri 11 months ago

  • Blocked by Bug #14906: devel branch FTBFS since the upgrade of virtualbox-guest-dkms to 5.2.0-dfsg-1 added

#21 Updated by intrigeri 11 months ago

  • Blocked by Feature #14713: Discuss and evaluate feedback coming from the Florence removal added

#22 Updated by intrigeri 11 months ago

  • Blocked by Bug #14763: It should be possible to turn off the on-screen keyboard if desired added

#23 Updated by intrigeri 11 months ago

  • Blocked by Bug #14786: Can't change resolution under KVM with QXL added

#24 Updated by intrigeri 11 months ago

  • Blocked by Feature #14751: Ensure Firefox's content sandboxing (Level 2) works added

#25 Updated by intrigeri 11 months ago

  • Blocked by Bug #14923: devel branch FTBFS since torbrowser-launcher 0.2.8-4 was uploaded added

#26 Updated by intrigeri 11 months ago

  • Blocked by Bug #14927: deb.tails.boum.org archive signing key needs to be updated added

#27 Updated by intrigeri 11 months ago

  • Blocked by Bug #14940: Upgrade Tor Browser to 7.0.10 added

#28 Updated by intrigeri 11 months ago

  • Blocked by Bug #14931: Tails mounts a windows boot partition with amnesia rights added

#29 Updated by intrigeri 11 months ago

  • Blocked by Bug #14959: Test UEFI boot with a Tails installed with UUI added

#30 Updated by intrigeri 11 months ago

  • Blocked by Bug #8992: USB sticks installed with UUI fail to boot in UEFI mode: "no configuration file found" added

#31 Updated by intrigeri 11 months ago

  • Blocked by Bug #14250: Applications menu stops working sometimes due to time going backwards added

#32 Updated by anonym 10 months ago

  • Blocked by Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly added

#33 Updated by anonym 10 months ago

  • Blocked by Feature #14963: Upgrade Thunderbird to one based on 52.4.0-1~deb9u1 added

#34 Updated by intrigeri 10 months ago

  • Blocked by Feature #14976: Upgrade the Linux kernel to get KPTI added

#35 Updated by intrigeri 10 months ago

  • Blocked by Bug #14990: Integrated graphics in Intel i5-7300HQ need xorg-device=intel added

#36 Updated by intrigeri 10 months ago

  • Blocked by Bug #14993: uBlock is broken in Tails 3.3 added

#37 Updated by intrigeri 10 months ago

#38 Updated by intrigeri 10 months ago

  • Blocked by Bug #15018: Decide if we do a Tails 3.3.1 emergency release added

#39 Updated by intrigeri 10 months ago

  • Blocked by Bug #15019: Upgrade tor to 0.3.1.9+ added

#40 Updated by intrigeri 10 months ago

  • Blocked by Bug #14555: Migrate to Tor Launcher compatible with Firefox ESR60 added

#41 Updated by intrigeri 10 months ago

  • Blocked by Bug #14971: Remove translations of translations (sic) on unsafe browser warning added

#42 Updated by intrigeri 10 months ago

  • Blocked by deleted (Bug #13437: Translations of notifications about clock and Tor are not applied)

#43 Updated by intrigeri 10 months ago

  • Blocked by Bug #14964: Boot from slow medium in Tails 3.3 is extremely slow added

#44 Updated by intrigeri 10 months ago

  • Blocked by deleted (Bug #12724: Virtualbox shared folders are not automatically mounted in Tails 3.0)

#45 Updated by anonym 10 months ago

  • Blocked by Bug #15024: Tor Browser cannot print to file added

#46 Updated by intrigeri 10 months ago

  • Blocked by Bug #15029: Check list of backends in the usr.sbin.cups AppArmor profile (2018 edition) added

#47 Updated by intrigeri 10 months ago

  • Blocked by Bug #15033: Rebase our Thunderbird custom package on top of 52.5.2 added

#48 Updated by anonym 10 months ago

  • Blocked by Bug #15041: Firefox gets uselessly downloaded at ISO build time when Debian security has a newer Firefox than our Tor Browser added

#49 Updated by intrigeri 10 months ago

  • Blocked by Bug #15042: Migrate away from our GNOME "AffectsTails" keyword added

#50 Updated by intrigeri 10 months ago

  • Blocked by deleted (Bug #15041: Firefox gets uselessly downloaded at ISO build time when Debian security has a newer Firefox than our Tor Browser)

#51 Updated by anonym 9 months ago

  • Blocked by Feature #15064: Adapt to Tor's Sponsor4 Tor Launcher UX improvements added

#52 Updated by intrigeri 9 months ago

  • Blocked by Bug #15055: sudo is required to build tails but it is not documented added

#53 Updated by intrigeri 9 months ago

  • Blocked by Bug #15092: Update our 2018 release schedule wrt. new Firefox ESR plans added

#54 Updated by intrigeri 9 months ago

  • Blocked by Bug #15070: Problem connecting to the AP with a RTL8723BE wireless card. added

#55 Updated by intrigeri 9 months ago

  • Blocked by Bug #15132: devel branch FTBFS since aufs-dkms 4.14 is in sid added

#56 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15132: devel branch FTBFS since aufs-dkms 4.14 is in sid)

#57 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15092: Update our 2018 release schedule wrt. new Firefox ESR plans)

#58 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15070: Problem connecting to the AP with a RTL8723BE wireless card.)

#59 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15042: Migrate away from our GNOME "AffectsTails" keyword)

#60 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15033: Rebase our Thunderbird custom package on top of 52.5.2)

#61 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15029: Check list of backends in the usr.sbin.cups AppArmor profile (2018 edition))

#62 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15024: Tor Browser cannot print to file)

#63 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14976: Upgrade the Linux kernel to get KPTI)

#64 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly)

#65 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14823: Simulate tracking of security updates on a frozen Buster stable branch between Buster sprint #1 and #2)

#66 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #14786: Can't change resolution under KVM with QXL)

#67 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14713: Discuss and evaluate feedback coming from the Florence removal)

#68 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14579: Tell the Technical Writers what part of our doc needs to be updated for Buster)

#69 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14578: Decide when we want to release Tails based on Debian Bullseye)

#70 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #14250: Applications menu stops working sometimes due to time going backwards)

#71 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #13403: Can't print to file from Tor Browser when Tails session not in English)

#72 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12679: Sandbox Tor Browser's content renderer processes more strictly)

#73 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #12615: Consider basing Tails on quarterly snapshots of Debian testing)

#74 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12460: Thunderbird doesn't use its dedicated SocksPort)

#75 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12372: Get software-properties-gtk starting / fix /etc/os-release)

#76 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #15064: Adapt to Tor's Sponsor4 Tor Launcher UX improvements)

#77 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #14751: Ensure Firefox's content sandboxing (Level 2) works)

#78 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #14555: Migrate to Tor Launcher compatible with Firefox ESR60 )

#79 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons)

#80 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #12152: Update tails-installer release process)

#81 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #11082: Replace Liferea)

#82 Updated by intrigeri 9 months ago

  • Status changed from Confirmed to Fix committed

#83 Updated by intrigeri 9 months ago

  • Target version changed from Tails_3.5 to Tails_3.4

#84 Updated by anonym 9 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF