Project

General

Profile

Bug #13253

Upgrade Tor to 0.3.0.9

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
06/30/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Code
Blueprint:
Easy:
Affected tool:

Related issues

Related to Tails - Bug #13416: Restore APT pinning of deb.tp.o Resolved 07/04/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

Associated revisions

Revision 0e8ef1fe (diff)
Added by anonym 5 months ago

Temporarily prioritize deb.t.b.o over deb.tp.o.

So we install 0.3.0.9-1~d90.stretch+1 (from deb.t.b.o) instead of
0.3.0.9-1~d99.buster+1 (from deb.tp.o, or rather our snapshot of it
which incorrectly has this Debian buster version of the package,
refs: #13413).

Will-fix: #13253

History

#1 Updated by intrigeri 5 months ago

"Accepted tor 0.3.0.9-1 (source) into unstable"

#2 Updated by anonym 5 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30

(Instead of bumping the torproject snapshot serial (due to #13413)) I uploaded these packages to stable's APT suite:

tor_0.3.0.9-1~d90.stretch+1_amd64.deb
tor-dbg_0.3.0.9-1~d90.stretch+1_amd64.deb
tor-geoipdb_0.3.0.9-1~d90.stretch+1_all.deb

I claim that these are the ones from deb.torproject.org. :)

#3 Updated by anonym 5 months ago

  • Related to Bug #13416: Restore APT pinning of deb.tp.o added

#4 Updated by anonym 5 months ago

  • Status changed from In Progress to Fix committed
  • Assignee changed from anonym to intrigeri
  • % Done changed from 30 to 100
  • QA Check set to Ready for QA

So I also had to commit 0e8ef1fe71bae0f48e8e65186a656e1e8169e7bc (due to #13413, which incorrectly puts the (higher version) buster packages in our stretch snapshot), and its reversal is tracked as #13416.

intrigeri, can you please make sure I didn't upload any backdoor's in the above .deb:s? Just unassign yourself, in either case.

#5 Updated by anonym 5 months ago

  • Status changed from Fix committed to In Progress

#6 Updated by intrigeri 5 months ago

#7 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

anonym wrote:

intrigeri, can you please make sure I didn't upload any backdoor's in the above .deb:s? Just unassign yourself, in either case.

I don't see why I should check this, while we're not checking our custom packages.

#8 Updated by intrigeri 5 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF