Project

General

Profile

Bug #13437

Translations of notifications about clock and Tor are not applied

Added by xin 3 months ago. Updated 16 days ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
Start date:
07/07/2017
Due date:
% Done:

90%

QA Check:
Feature Branch:
bugfix/13437-translations-not-applied, greeter:bugfix/13437-translations-not-applied
Type of work:
Code
Blueprint:
Easy:
Affected tool:
Greeter

Description

Since 3.0, notifications about clock synchonization and Tor status are in English.

Tested with Spanish, French and German.


Related issues

Blocks Tails - Feature #13244: Core work 2017Q4: Foundations Team Confirmed 06/29/2017

Associated revisions

Revision f9648271 (diff)
Added by intrigeri 3 months ago

Enable the bugfix-13437-translations-not-applied APT overlay (refs: #13437).

Revision d43a6328
Added by bertagaz 3 months ago

Merge remote-tracking branch 'origin/bugfix/13437-translations-not-applied' into stable

Fix-committed: #13437

History

#1 Updated by mercedes508 3 months ago

  • Status changed from New to Confirmed
  • Assignee set to sajolida

#2 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to bertagaz
  • Type of work changed from Research to Code

@bertagaz: This is a code bug, right? So assigning to you as the next RM.

#3 Updated by intrigeri 3 months ago

  • Assignee changed from bertagaz to intrigeri
  • Target version set to Tails_3.1

@bertagaz: This is a code bug, right? So assigning to you as the next RM.

It's not part of the RM's job to take care of bugs.
Reassigning to me as the current Foundation Team on-call person.

#4 Updated by intrigeri 3 months ago

#5 Updated by intrigeri 3 months ago

  • Category set to Internationalization
  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Affected tool set to Greeter

Regarding "Tor is ready": /etc/NetworkManager/dispatcher.d/60-tor-ready.sh expects it'll find $LANG in /etc/default/locale, which is not a valid assumption on Tails 3.0.1, which is a problem in itself. That's a bug in the Greeter's PostLogin.default, that calls localectl set-locale twice (once for $LANG, once for the formats settings). The second call overwrites the effect of the first one. I'll merge these two calls into a single one, so it should be a straightforward fix => adding to the foundations team's plate.

Regarding "Synchronizing the system's clock", we display this in two places:

  • /etc/NetworkManager/dispatcher.d/20-time.sh, in a rare case; this one has never been gettext'ized (there's a "XXX" in the code) so it's not a regression and I'll ignore it for now.
  • /usr/local/lib/tails-htp-notify-user, called by /etc/NetworkManager/dispatcher.d/20-time.sh too after doing export_gnome_env. I don't know why export_gnome_env doesn't pick up $LANG. It might be a consequence of the localectl -related bug described above, so I'll fix that one first and will see if it fixes this one.

#6 Updated by intrigeri 3 months ago

  • Feature Branch set to bugfix/13437-translations-not-applied, greeter:bugfix/13437-translations-not-applied

#7 Updated by intrigeri 3 months ago

intrigeri wrote:

  • /usr/local/lib/tails-htp-notify-user, called by /etc/NetworkManager/dispatcher.d/20-time.sh too after doing export_gnome_env. I don't know why export_gnome_env doesn't pick up $LANG.

Correction: it's not export_gnome_env's responsibility to do so. If $LANG was set in the NM environment, everything would work fine, so indeed I'll see if fixing the Greeter bug is enough.

#8 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

The two regressions described above are fixed here (in French) by the topic branch.

#9 Updated by bertagaz 3 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

The two regressions described above are fixed here (in French) by the topic branch.

Seems they are, good catch! Merged the related branch, congrats.

#10 Updated by bertagaz 2 months ago

  • Status changed from Fix committed to Resolved

#11 Updated by xin 18 days ago

This problem is back in 3.2 (at least for "Tor is ready").
I don't know if it have the same reason and what I have to change to update this ticket.

#12 Updated by intrigeri 18 days ago

  • Status changed from Resolved to Fix committed
  • Target version changed from Tails_3.1 to Tails_3.3

That's because bertagaz failed to merge greeter.git:bugfix/13437-translations-not-applied into master (or push his merge) when he merged the corresponding branch in tails.git, so my work there made it into 3.1 but not into 3.2 :/

I've now merged it so this should be fixed in 3.3.

#13 Updated by intrigeri 18 days ago

  • Status changed from Fix committed to In Progress
  • Assignee set to anonym

I've now merged it so this should be fixed in 3.3.

Well, this requires releasing a new WhisperBack, that does not happen every time we do a Tail release, so putting this back on the RM's plate so he knows that this time we really need it.

#14 Updated by intrigeri 16 days ago

  • % Done changed from 100 to 90
  • QA Check deleted (Pass)

intrigeri wrote:

Well, this requires releasing a new WhisperBack,

Err, s/WhisperBack/Greeter/.

#15 Updated by intrigeri 16 days ago

#16 Updated by intrigeri 16 days ago

Also available in: Atom PDF